Wordpress style not being detected properly - HELP PLEASE RRS feed

  • Question

  • Ok so the problem is that Windows Live Writer is not detecting my Wordpress theme/style correctly. Even though I have tried updating webblog style through WLW a lot of times it still gives broken images and broken CSS while in Preview mode.

    I am using the same WLW version on my Laptop and added the same webblog but everything seems to be fine there. It detected the Wordpress style correctly and nothing is broken but the problem is only on my PC.

    There is no use of even uninstalling and then reinstalling WLW as for some damn reason the settings are stored in the PC and even if i uninstall it, WLW still saves the settings.

    My problem is somewhat similar to the thread here


    Please help me out guys

    BTW another question to WLW developers is why doesnt WLW flush all settings and all sorts of keys and data when it is uninstalled :@
    Friday, June 6, 2008 3:22 PM

All replies

  • You may be experiencing the same issue as the post you mentioned. Which OS's and versions of IE are on your laptop and PC?

    Also, to reiterate, flushing settings/reinstalling Writer will not resolve any template detection issues. In our experience refreshing all Writer settings has very rarely solved any problems, if ever. Because of the setup cost involved in using Writer, and the important data that Writer stores (draft posts), most users appreciate the fact that we don't delete everything and force them to start from zero when they reinstall.

    Friday, June 6, 2008 4:53 PM
  • I am using IE6 and Windows XP SP2 on Laptop (on which WLW is working perfectly) and am using the same IE6 and Windows XP SP2 on my home PC (on which WLW is not detecting styles properly)

    My other observations tell me that the style detection problem is not arising only for a particular blog only rather I have tried over 3 different blogs and WLW on my PC is not able to detect styles of any of these blogs

    I have mailed the logs to Joe Cheng

    The other thing is it does not even give any communication error like "could not download style" or etc. When it reaches to the point of downloading stylesheets, it just quickly skips it.

    I think that removing WLW completely and reinstalling it can help. At least we I can try?

    I know you say completely removing WLW won't help but what other option do I have? I need to do it.

    And to completely remove it you must tell me how to do it cz simply uninstalling it won;t help. I need to remove it such that it never existed on my PC.

    Help me please.
    Friday, June 6, 2008 7:46 PM
  • You can go into Documents and Settings\<User>\Application Data\Windows Live Writer\blogtemplates, find the latest folder, open it up and see if the themes have been downloaded correctly. If not, it's possible that the connection is being disrupted somehow while Writer is trying to download the theme (do you have firewall settings on your PC that is different from your laptop?).

    From what you are saying it sounds like the theme gets partially downloaded but is not displayed correctly (broken images and CSS).This seems consistent with an interrupted connection.

    To completely remove all Writer settings you have to go into the registry.

    Also, this may not affect Writer but for your safety and security we recommend that you install all required updates and upgrade to SP3 and IE7.

    Friday, June 6, 2008 8:11 PM
  • I opened Documents and Settings\<User>\Application Data\Windows Live Writer\blogtemplates and searched each folder. As you suspected, the images have not been downloaded correctly and instead of thumbnails I see red cross boxes in place of all images.

    Now comes the part where I check my firewall settings. Basically my laptop and PC use 100% the same configuration so connection is not the problem but still to ensure this I disabled my Kaspersky anti-virus and also disabled the Windows built-in firewall.

    Then I tried to refresh the blog style in WLW and when it comes to part of downloading styles and files, it just haults and does nothing. The image below will explain better.


    It remained in that form for like 20 minutes then I had to manually cancel it.

    Its impossible for the connection to be the problem as I am using the same connection settings on my laptop where the style is updated without any flaw and delays plus WLW does allow me to post to the blog but the only problem is it can not update the style.

    If I can post to the blog, it certainly means the connection is fine and stable all the way.

    Here is a screenshot of how the style looks in WLW currently.


    I think I should try completely removing it from my PC and reinstalling it. I know how to edit/change the registry. All you need to tell me is the values and location of the registry keys that I have to delete/change.

    I will install IE7 once this WLW problem is sorted out.

    Help me! thanks
    • Edited by Dj Flush Friday, June 6, 2008 9:27 PM added link
    Friday, June 6, 2008 9:26 PM
  • Common guys! Help me! Its a microsoft product. Show some support please.
    Saturday, June 7, 2008 7:29 PM
  • Our registry settings are stored at:
    HKEY_CURRENT_USER\Software\Microsoft\Windows Live\Writer

    Removing that key will cause a lose of settings from WLW.

    I wouls suggest installing an application like http://www.fiddlertool.com/Fiddler2/version.asp and using this when you run your configuration refresh so you can see if there is a problem with the HTTP requests to download them. 

    Sunday, June 8, 2008 11:08 PM
  • Same problem here...
    And I'm using IE 7.0.5730.13 and Windows XP SP3!

    Someone please give us a solution? :D


    Tuesday, June 10, 2008 6:09 PM
  • So sorry for the delay in replying, I've been on vacation. Dj Flush, judging from your log file, one of the components on your machine has been corrupted--not belonging to Writer, but probably Internet Explorer. If you're running Windows XP, can you try reinstalling IE7? Then try refreshing the theme again in WLW.

    Thiago, can you e-mail your log file (Help | About | show log file) to joe.cheng *AT* microsoft.com? Thanks.
    Wednesday, June 18, 2008 5:32 AM
  • I have the same problem.  My blog www.noct.org is experiencing the same thing.  I cannot get it to view the CSS file.  Everything comes up, when I do a preview, as though there is no CSS file available.

    I have another blog, www.randomfix.com which works just fine.  This blog is using an earlier version of WordPress along with an earlier version of K2 theme as well.

    The Noct blog is updated to the most recent nightly build of K2 and the most recent released version of WordPress.

    This post goes along with my post about the text wrapping not working in IE7 with my Noct blog but it works fine with the Random Fix blog.
    Tuesday, June 24, 2008 6:45 PM
  • Having same exact problem. 

    SP3/IE7.  WordPress blog at www.starraisers.com.  My computer at work can see it and detect it fine.  Here, my laptop, which only uses windows firewall, and which I have turned off for this entire project, is going through the "update blog" thing just fine, doesn't freeze or anything.  It just says its done updating and goes to show me a blank sheet with no formatting at all.

    Uninstalled ALL windows live products.  Deleted ALL registry keys referring to "writer" or "windows live" (that took a WHILE too.)  Deleted several windows live / writer folders from local settings and application data and program files (even after the uninstallation left everything  behind...). 

    Cleared temp files and ran windows update before reinstalling anything.


    Ran windows update (mainly for the writer update available) and then rebooted before running again.

    Still. No. Go.

    Let me know if there's any information I can give that will help.

    ~Dan Hughes
    Thursday, July 17, 2008 5:17 PM
  • When I looked at the Windows Live Writer log file I saw a lot of "System.Runtime.InteropServices.COMException (0x80040155)"

    When I did a search for that, I found a site that said that their log file was getting that same error due to having the Speedbit program "Download Accelerator Plus" installed on their machine.  Link Here When they removed it, Windows Live Writer started working again.  They reinstalled it, and it was broken once more.

    Now, I do not have Speedbit's program on my machine.  I do, however, have a similar program from MetaProducts: "Download Express"

    On a hunch, I uninstalled that program, and voila, Windows Live Writer detected my blog again.  I reinstalled the program, and sure enough, it stopped detecting.

    So, on one hand, this problem is resolved for me, but on the other.... what is with these other programs that would cause this type of interference with Live Writer.  MetaProducts did not install any addon's or anything that I could see... I don't use IE though, I use FireFox, so I couldn't tell you what IE did exactly while the software was installed.  I have an addin with FireFox that uses the MetaProducts software.

    Any Ideas?

    ~Dan Hughes
    • Edited by Lone Starraiser Friday, July 18, 2008 5:25 AM Added link to site
    Friday, July 18, 2008 5:24 AM