locked
Project Server 2010 Schedule Tasks cannot edit first tow RRS feed

  • Question

  • Hi,

    I am not able to edit the first task created in the project detail pages->schedule. I can edit the other tasks I create below that. Please help:)

    Monday, May 16, 2011 10:18 PM

Answers

  • HI Graham,

    well that requires a longer answer generally and would strongly recommend that you do a training. However here is who you delete a sumary task:

    open MS project and connect to Project Server

    open the project schedule

    Move all "subtasks" under the summary task out so that the summary task does not have any subtasks

    Now you can delete the task that used to be the summary task.

    Save and publish your project again.

    Hope this helps


    Marc Soester [MVP] http://marcsoester.blogspot.com
    • Marked as answer by Graham1135 Thursday, May 19, 2011 11:05 PM
    Thursday, May 19, 2011 10:59 PM
  • Well I found out that you get this problem when

    1. you hide the ID column
    2. Project is checked out, so check project in and click edit again, it should be fine
    • Marked as answer by Graham1135 Tuesday, July 19, 2011 9:40 AM
    Tuesday, July 19, 2011 9:39 AM

All replies

  • Hi Graham,

    I assume that the first task is either the Project Summary task ( task level 0) or another summary task. Summary tasks can not be amended (unless they are manually schedule tasks).

    Hope this helps


    Marc Soester [MVP] http://marcsoester.blogspot.com
    Monday, May 16, 2011 10:35 PM
  • Hi,

    So if this is a summary task, how do I hide it to solve my problem. I checked the summary tasks check box and it was not ticked. When I ticked it, I can see another row now so I assume it is not a summary task.

    Tuesday, May 17, 2011 1:05 AM
  • HI Graham,

    If the task is not a summary task, you should be able to amend the task. Just a couple of questions:

    where do you try to change the task? In MS Project or in Project Web App?

    What value do you try to change on the task?

    I am sure we will find out very soon why you cant amend the task :)


    Marc Soester [MVP] http://marcsoester.blogspot.com
    Tuesday, May 17, 2011 4:24 AM
  •  

    Thanks.

    I use project web app. Go to  project center select a project and click on it. The click schedule in the options. Thjis will give a list of tasks in the project. No matter which project I open, I cannot edit the first task.

     

    What I want is that if this is some sort of summary field then it should be hidden so that the user does not have to deal with the problem.

     

    Tuesday, May 17, 2011 8:29 PM
  • Graham can you please check what the Task ID number is. If it is Task 0 than it is the project summary task. You can navigate to Options within the Ribbon of Project Web and untick the option "PRoject Summary Task". That will hide this task.

    Hope this helps


    Marc Soester [MVP] http://marcsoester.blogspot.com
    Tuesday, May 17, 2011 10:49 PM
  • Hi,

     

    The task ID is 0. But the project summary task check box is unticked so I am not able to remove it. When I tick this, I see another task ID 1 which has the task name the same as the project name.

    How do I remove this from all users. I do not want anyone to use summary task as it cannot be edited as mentioned before.

    Wednesday, May 18, 2011 3:28 AM
  • There are several ways, firstly you can of course amend your schedule and take the summary task out of the schedule. That way it will not appear in the Web Ap schedule. Another option is to include a column called "Summary". When adding the column to a user can filter to "exclude tasks where summary = yes". You can even set up a Project Detail view where the summary is already filtered out. The disadvantige is of course that if you have a large schedule that users dont know what task to amend.

    I personally believe that it should be a training component that you can inbed into your process.

    Hope this helps


    Marc Soester [MVP] http://marcsoester.blogspot.com
    Thursday, May 19, 2011 3:24 AM
  • Hi Marc,

    How do I amend my shedule to remove the summary task? Sorry I am a newbie here.

    Thursday, May 19, 2011 8:52 PM
  • HI Graham,

    well that requires a longer answer generally and would strongly recommend that you do a training. However here is who you delete a sumary task:

    open MS project and connect to Project Server

    open the project schedule

    Move all "subtasks" under the summary task out so that the summary task does not have any subtasks

    Now you can delete the task that used to be the summary task.

    Save and publish your project again.

    Hope this helps


    Marc Soester [MVP] http://marcsoester.blogspot.com
    • Marked as answer by Graham1135 Thursday, May 19, 2011 11:05 PM
    Thursday, May 19, 2011 10:59 PM
  • Hi Marc,

    I am new to Project Server also, but something is seriously not right about this. I think Graham's problem is the same as mine.

     

    Here is the scenario:

    - I create a new project in PWA with 3 manually scheduled tasks (none of them are summary tasks). They have IDs 1, 2, 3.

    - I save and check in the project.

    - I check out the project to edit it, and the first task now has ID = 0, and is not editable (???).

    - I check it back in.

    - I check out the project in Project Professional - the tasks have IDs 1, 2, 3, and are all editable.

    What gives?

     

    Important thing to note: If I check the project out in PWA, and tick "Project Summary Task", I get a Project Summary Task (what a surprise), with ID = 1!?

    Edit: Here's an image

    Photobucket

    Would appreciate some help with this mess...

    Cheers,

    Daniel

     


    Friday, June 17, 2011 6:45 AM
  • Daniel,

     

    Did you manage to fix the problem?


    Tuesday, June 21, 2011 4:48 AM
  • Well I found out that you get this problem when

    1. you hide the ID column
    2. Project is checked out, so check project in and click edit again, it should be fine
    • Marked as answer by Graham1135 Tuesday, July 19, 2011 9:40 AM
    Tuesday, July 19, 2011 9:39 AM