locked
Window MSI not working RRS feed

  • Question

  • My PC is not getting any updates to the Windows XP operating system.

    I have tried doing a manual update via the MicrosoftUpdate Web site. Whether I choose Express OR custom update I get the error [Error number: 0x800A0046].

    The web page suggests the following
    1. In Internet Explorer, on the Tools menu, click Internet Options.
    2. Click the Security tab, click the Internet security zone icon, and then click Custom Level.
    3. In the Settings dialog box, scroll to the Miscellaneous section.
    4. Under Userdata persistence , select Enable.
    5. Click OK and when the security warning dialog box appears, click Yes.

    All of which I have done but still I get the error and NO updates.

    I have tried regsrv32 qmgr.dll & regsrv32 qmgrprxy.dll
    both of which succesfully registered but did not fix the problem.

    I have also noticed that the Windows installer does not work either. Therefore I cannot install any new software using MSI.

    I have tried re-registering the msiexec.exe with no effect. I have tried re installing MSI version 3.1 & 4.5 with no effect.

    I set up MSI logging and the error MSI is returning error 1601.

    in my mind this is all suggesting some sort of security / policy issue......

    On another forum I was advised to download and run the Windows Genine Advantage Diagnostic Tool and to paste it's results in this forum.
    These are the results of the tool:-
    Diagnostic Report (1.9.0011.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Validation Code: 0

    Cached Validation Code: N/A
    Windows Product Key: *****-*****-T6DFB-Y934T-YD4YT
    Windows Product Key Hash: 3g4CZGFEDgbKmn/oB4pa2FZsssU=
    Windows Product ID: 76487-OEM-2211906-00102
    Windows Product ID Type: 2
    Windows License Type: OEM SLP
    Windows OS version: 5.1.2600.2.00010100.3.0.pro
    ID: {F608820B-CDF4-458D-9E4D-E493F063B1F1}(3)
    Is Admin: Yes
    TestCab: 0x0
    WGA Version: Registered, 1.9.40.0
    Signed By: Microsoft
    Product Name: N/A
    Architecture: N/A
    Build lab: N/A
    TTS Error: N/A
    Validation Diagnostic: FCEE394C-458-80070005_025D1FF3-344-80070005_025D1FF3-229-80070005_025D1FF3-230-1_025D1FF3-238-2
    Resolution Status: N/A

    WgaER Data-->
    ThreatID(s): N/A
    Version: N/A

    WGA Notifications Data-->
    Cached Result: 0
    File Exists: Yes
    Version: 1.9.40.0
    WgaTray.exe Signed By: Microsoft
    WgaLogon.dll Signed By: Microsoft

    OGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002
    OGAExec.exe Signed By: N/A, hr = 0x80070002
    OGAAddin.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 103 Blocked VLK
    Microsoft Office Enterprise 2007 - 103 Blocked VLK
    Microsoft Office Publisher 2007 - 100 Genuine
    OGA Version: N/A, 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: FCEE394C-458-80070005_025D1FF3-344-80070005_025D1FF3-229-80070005_025D1FF3-230-1_025D1FF3-238-2

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
    Default Browser: H:\Documents and Settings\Dell\Local Settings\Application Data\Google\Chrome\Application\chrome.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{F608820B-CDF4-458D-9E4D-E493F063B1F1}</UGUID><Version>1.9.0011.0</Version><OS>5.1.2600.2.00010100.3.0.pro</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-YD4YT</PKey><PID>76487-OEM-2211906-00102</PID><PIDType>2</PIDType><SID>S-1-5-21-1482476501-1801674531-725345543</SID><SYSTEM/><BIOS><SLPBIOS>Dell System,Dell Computer,Dell System,Dell System</SLPBIOS></BIOS><HWID>A27139470184406D</HWID><UserLCID>0809</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>GMT Standard Time(GMT+00:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM/><GANotification><File Name="WgaTray.exe" Version="1.9.40.0"/><File Name="WgaLogon.dll" Version="1.9.40.0"/></GANotification></MachineData><Software><Office><Result>103</Result><Products><Product GUID="{90120000-0030-0000-0000-0000000FF1CE}"><LegitResult>103</LegitResult><Name>Microsoft Office Enterprise 2007</Name><Ver>12</Ver><Val>ACD7202654E586</Val><Hash>fFic3JgCreGGRxyF8uMWB4R4Jcg=</Hash><Pid>89388-707-1528066-65235</Pid><PidType>14</PidType></Product><Product GUID="{91120000-0019-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Publisher 2007</Name><Ver>12</Ver><Val>979BB238A0B0260</Val><Hash>WU6EhCy8SvL1ZmdefuAWShU5qoY=</Hash><Pid>81613-304-6577442-62151</Pid><PidType>10</PidType></Product></Products><Applications><App Id="15" Version="12" Result="103"/><App Id="16" Version="12" Result="103"/><App Id="18" Version="12" Result="103"/><App Id="19" Version="12" Result="100"/><App Id="1A" Version="12" Result="103"/><App Id="1B" Version="12" Result="103"/><App Id="44" Version="12" Result="103"/><App Id="A1" Version="12" Result="103"/><App Id="BA" Version="12" Result="103"/></Applications></Office></Software></GenuineResults> 

    Licensing Data-->
    N/A

    HWID Data-->
    N/A

    OEM Activation 1.0 Data-->
    BIOS string matches: yes
    Marker string from BIOS: 1A90C:Dell Inc|1A90C:Microsoft Corporation
    Marker string from OEMBIOS.DAT: Dell System,Dell Computer,Dell System,Dell System

    OEM Activation 2.0 Data-->
    N/A

    I have also enabled logging of the MSI tool to try and diagnose the problem.
    This is a copy of the log from MSI:-

    === Verbose logging started: 05/08/2009  15:08:12  Build type: SHIP UNICODE 4.05.6001.00  Calling process: H:\WINDOWS\system32\msiexec.exe ===
    MSI (c) (BC:94) [15:08:19:718]: Resetting cached policy values
    MSI (c) (BC:94) [15:08:19:718]: Machine policy value 'Debug' is 0
    MSI (c) (BC:94) [15:08:19:718]: ******* RunEngine:
               ******* Product: H:\DOCUME~1\Dell\LOCALS~1\Temp\IXP377.TMP\iTunes.msi
               ******* Action:
               ******* CommandLine: **********
    MSI (c) (BC:94) [15:08:19:718]: Machine policy value 'DisableUserInstalls' is 0
    MSI (c) (BC:94) [15:08:25:156]: SOFTWARE RESTRICTION POLICY: Verifying package --> 'H:\DOCUME~1\Dell\LOCALS~1\Temp\IXP377.TMP\iTunes.msi' against software restriction policy
    MSI (c) (BC:94) [15:08:25:156]: SOFTWARE RESTRICTION POLICY: H:\DOCUME~1\Dell\LOCALS~1\Temp\IXP377.TMP\iTunes.msi has a digital signature
    MSI (c) (BC:94) [15:08:36:218]: SOFTWARE RESTRICTION POLICY: H:\DOCUME~1\Dell\LOCALS~1\Temp\IXP377.TMP\iTunes.msi is permitted to run at the 'unrestricted' authorization level.
    MSI (c) (BC:94) [15:08:37:250]: Failed to connect to server. Error: 0x80070005

    MSI (c) (BC:94) [15:08:37:265]: MainEngineThread is returning 1601
    === Verbose logging stopped: 05/08/2009  15:08:37 ===

    The error MSI seems to be causing is Error 1601......!

    Thursday, August 6, 2009 12:33 PM

Answers