locked
'Password incorrect' during WHS Connector install RRS feed

  • Question

  • I'm having some issues installing the WHS connector to my Win7 Pro PC.

    It worked fine before, but I had to uninstall it because of the faulty update MS released a couple of days ago. Now, when i try to install it, it says my password is incorrect. It's driving me crazy: I really need to access my backed up files. So far I've tried the following, all found through Google:

    • Changed security policy (LAN manager verification level)
    • Tried it with and without the faulty MS update installed
    • Tried several 'setup.exe's, from C:\WHS, from another person, from before the MS update, from after the MS update...
    • Changed the security security settings in the C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys folder
    • Tried connecting with modem disconnected (so none of my systems are on the internet, just LAN)
    • Synchronised times (even tried with a different NTP pool)
    • Changed workgroup
    • Re-entered password in WHS console through RDP (I can access it fine through there)
    • Rebooting countless times
    • Trying on another system

    Of course, I am 200% sure the password is correct, so it must be something else... I tried everything I could find. It does this on all my systems, through WiFi and through LAN.
    Any suggestions?

     

    Tuesday, February 1, 2011 1:27 PM

Answers

  • I did it through remote desktop. Here are some more detailed steps:

     

    1. Go to Start -> All Programs -> Administrative Tools -> Component Services.
    2. Find 'WHSTransportService' under Console Root/Component Services/Computers/My Computer/DCOM Config
    3. Right click -> Properties. Go to security tab.
    4. Under 'Launch and activation permissions press 'Customise' and click the Edit button
    5. Click on 'add', and in the screen that pops up type in the box: IUSR_<your server name here>
    6. Click 'check names' and see the text you just entered change in something like '<your server name here>\IUSR_<your server name here>'
    7. Press OK and check whether or not the user you just added is showing in the list. Now give this user full control.
    8. Try entering the password again, it should work now.
    If it doesn't you can try doing the above for 'Access Permissions' and 'Configuration Permissions' (in step 3) also.
    • Marked as answer by TommyDJ Saturday, February 5, 2011 5:55 AM
    Saturday, February 5, 2011 5:55 AM

All replies

  • Please check if (again) if time AND TIMEZONE setting are identical on client and server.
    Henk Panneman - http://www.homeserverweb.nl
    • Proposed as answer by Tiderfish Thursday, April 5, 2018 3:26 AM
    Tuesday, February 1, 2011 3:57 PM
    Moderator
  • Tried this?

    Start > Run menu: rundll32.exe keymgr.dll, KRShowKeyMgr
    Find the name of your WHS, highlight it and "Remove it".
    Then restart your W7 client and retry...

    - Theo.


    No home server like Home Server
    Tuesday, February 1, 2011 9:10 PM
    Moderator
  • They are. I even pressed synchronise on both client & server with the same time server set up right before installing the connector. They are equal.
    Tuesday, February 1, 2011 9:30 PM
  • I fixed it! I looked in the event viewer and kept seeing a DCOM error message at the time I wanted to login. The CLSID pointed me to the WHSTransportService in Component Services. I added the user 'IUSR_myserver' to the security list and now it works!

    • Marked as answer by TommyDJ Wednesday, February 2, 2011 11:13 AM
    • Unmarked as answer by TommyDJ Saturday, February 5, 2011 5:55 AM
    Wednesday, February 2, 2011 11:13 AM
  • Glad to hear you fixed it. Can you please post detailed steps?
    Henk Panneman - http://www.homeserverweb.nl
    Wednesday, February 2, 2011 12:05 PM
    Moderator
  • I did it through remote desktop. Here are some more detailed steps:

     

    1. Go to Start -> All Programs -> Administrative Tools -> Component Services.
    2. Find 'WHSTransportService' under Console Root/Component Services/Computers/My Computer/DCOM Config
    3. Right click -> Properties. Go to security tab.
    4. Under 'Launch and activation permissions press 'Customise' and click the Edit button
    5. Click on 'add', and in the screen that pops up type in the box: IUSR_<your server name here>
    6. Click 'check names' and see the text you just entered change in something like '<your server name here>\IUSR_<your server name here>'
    7. Press OK and check whether or not the user you just added is showing in the list. Now give this user full control.
    8. Try entering the password again, it should work now.
    If it doesn't you can try doing the above for 'Access Permissions' and 'Configuration Permissions' (in step 3) also.
    • Marked as answer by TommyDJ Saturday, February 5, 2011 5:55 AM
    Saturday, February 5, 2011 5:55 AM
  • I have 3 different computers all running Win7 x64 that were running WHS connector fine before the latest update.  After the update I was unable to install the connector on any of the computers.  Spent several hours, tried all of the above "fixes" as well as several others from elsewhere, but kept getting stupid "Unknown Network Error" after I entered in my password.  This is how I fixed it:

     

    1. Copy all connector files from server to the client

    2. Unplug network cable (or turn off Wifi) on client

    3. Install software

    4. It will tell you that it can't find your home server and allows you too search manually

    5. Select the option to find manually

    6. Enter IP address of the server (ideally name should've worked but it didn't work for me even though I can ping server from client by name)

    7. It will find the server, join, and configure backup

    8. Done!

     

    Hope that this helps someone else fighting the same issue.

    Friday, March 18, 2011 6:18 AM
  • Had a similar problem because I foolishly created a new administrator account on the WHS 2011 box.  (standard practice at work to disable the built-in administrator account and create a new one with a different name).  Once I re-enabled the admin account, it worked fine.

     

    I tried the provided answer here, and I was unable to find the "WHSTransportService" installed anywhere (not under DCOM Config, Services, or anywhere else).

    • Proposed as answer by efgslats Friday, March 8, 2013 12:56 AM
    Saturday, April 30, 2011 4:58 AM
  • Success! No, not with any of the techniques presented. I don't have WHSTRANSPORTSERVICE or LANMAN nor could I RDP to the server. So, reluctantly, I removed the hard drive I had installed WHS 2011 on and wiped it clean and then re-installed using the CD in another computer. Stopped the install at the first reboot, shoved it in my HP 490 hulk, went and had a cold shower, and came back to try RDP. Lo and behold, there was the install menu waiting patiently for me to answer questions and very carefully insert the password. All is working fine. I added the rest of my 3 TB of hard drives and reshuffled the folders. After setting up the backups, everything is swimming. I am now screwing up the courage to install the software to make the LEDs work. I can also start on my other project to make the empty box into a super (small s) computer per the latest project in Maximum PC. So, I am happy today - though this is only Tuesday.
    Tuesday, August 9, 2011 5:36 PM
  • - Running a freshly installed version of Windows XP (yes even in 2012). (MSFT Tech Support told me that I was having problems because I was running the Home Edition. I beleive that's incorect as I was running Home Edition before reformating and starting fresh)
    - Tried to install the "connector" and got the infamous "The password in incorrect" message.
    - WHS runs well and I have access to it and the console through another laptop.
    - Yes the password is correct as I can log on to the console through my other laptop.

    I've read many thread on the topic on this forum and others:
    - Dates and time zones are same
    - Tried to find the WHSTransportService in DCOM. Never found it.
    - Tried the rundll32.exe keymgr.dll, KRShowKeyMgr and there was nothing in the combo box to "remove"
    - I've tried renaming my PC and reboot both the WHS and PC.

    While investigating the "Event Viewer" on my PC I can read the following ERROR message
    "Windows Home Server protocol mismatch. This computer uses protocol version 6.0.3436.0 but computer (WHS NAME) uses protocol version 6.0.2423.0. A connection cannot be established."

    That sounds like a problem to me ? How can I get to protocols to match? Is it only a software version problem?
    My WHS is updated but I've installed the connector by using the files accessible on the WHS.

    I'm out of ideas. Suggestions appreciated.
    • Edited by pameunier Saturday, February 11, 2012 1:39 AM
    Friday, February 10, 2012 9:36 PM
  • Yea me too! I am wondering how to get the protocols to match. I 've downloaded the connector sw from http://servername:55000 to my WIN7 machine but my problem occurs after I enter my password. I receive the Discovery.exe has stopped working error. The event viewer lists the exact same error however-

    "Windows Home Server protocol mismatch. This computer uses protocol version 6.0.3436.0 but computer (my WHS NAME) uses protocol version 6.0.2423.0. A connection cannot be established."

    Everthing is ok on my other machines (XP and WIN764)so I am certain it is a problem with the WIN7 machine. As a work around I was able to execute the WHStrayapp.exe located in the WHS folder under programs files which restored the Home server icon back onto my status tray. All the functions are operable and the icon is green, but the shared folders on server icon does not appear on the desktop. It is accessible by right clicking the tray icon.


    • Edited by sjones5 Saturday, February 11, 2012 3:03 PM
    Saturday, February 11, 2012 3:00 PM
  • LOL I had the same problem :-) 

    I got errors like server not found, or it said that the password was incorrect...
    I enabled the local administrator account, and it worked right away!

    Friday, March 8, 2013 12:57 AM