locked
How to Upgrade from .NET 2.0 to .NET 4.0 RRS feed

  • Question

  • I have 2 MCTS exams in .NET 2.0 how can I upgrade to .NET 4.0?
    or do I have to take the exams and prerequisites again?
    here's what I have:
    Microsoft® Certified Technology Specialist ﴾MCTS﴿
    Certification/Version : .Net Framework 2.0, Web
    Applications
    Exam ID Description Date Completed
    536 TS: Microsoft .NET Framework - Application
    Development Foundation
    November 22, 2007
    528 TS: Microsoft® .NET Framework 2.0 - Web-based
    Client Development
    October 11, 2007
    I want to get to :

    MCPD on Microsoft Visual Studio 2010

    If you plan to develop applications by using Visual Studio 2010 and the Microsoft .NET Framework 4.0, the Microsoft Certified Professional Developer (MCPD) on Visual Studio 2010 certifications can help you validate your skills and abilities. You should have two to three years of experience using the technologies covered in the exam. The available certification paths include the following:

    ·         Windows Developer 4—for developers who build rich client applications for the Windows Forms platform by using the Microsoft .NET Framework 4. 

    Windows Developer 4 on Visual Studio 2010

    Exam number

    MCTS prerequisite: TS: Windows Applications Development with Microsoft .NET Framework 4

    Exam 70-511 

    MCTS prerequisite: TS: Windows Communication Foundation Development with Microsoft .NET Framework 4

    Exam 70-513 

    MCTS prerequisite: TS: Accessing Data with Microsoft .NET Framework 4

    Exam 70-516 

    MCPD requirement: PRO: Designing and Developing Windows Applications Using Microsoft .NET Framework 4

    Exam 70-518 

    Wednesday, June 29, 2011 4:02 PM

Answers

  • There is no upgrade for the MCTS in 2.0 to 4.0 because getting an MCTS on version 4.0 only requires passing one exam (contrary to the MCTS on 2.0 which requiered two exams).

    If you want to get the MCTS on Web development on .Net 4.0, you only need to pass exam 70-515. There is no equivalent in version 4.0 to the old exam 70-536 that you needed as a prerequisite on version 2.0.

    Edit: If you want to go beyond MCTS and you wish to obtain the MCPD, then you also need three additional exams: 70-513 (WCF), 70-516 (Data) and 70-519 (PRO).

     


    • Proposed as answer by Mr. Wharty Thursday, June 30, 2011 12:12 AM
    • Marked as answer by Rubel Khan Monday, July 25, 2011 12:55 AM
    Wednesday, June 29, 2011 9:18 PM