locked
Unable to get Printer Sharing to work RRS feed

  • Question

  •  

    My network consists of the following:

     

    Main: hub XP Home 32-bit wired

    Xeon Server: Xp Prof 32-bit wired

    Laptop: Vista 32-bit wireless

     

    Printer: HP D5160 connected by USB to Main

     

    All 3 computers have OneCare installed under the same ID.  I can print to the HP from both the Main and the Xeon Server.  I am unable to print, or even install the HP printer on the laptop.

     

    I have searched the forums and have gone through the steps that were solutions to other people's issues with no luck.  I went through the OneCare wiki printer debugging script and still no luck.  Network is set up as Home/Private.  I am able to access files on the Main from my laptop, but can't find printer.  I installed print drivers on laptop and updated print drivers on Main and still no luck.

     

    Finally exhausted everything I could find or think of, so contacted Microsoft OneCare chat help.  After spending 45 mins online with them, they said that it is a OneCare limitation that it can not share a printer over a wireless connection.  According to what I have read on the forums, that doesn't seem to be an issue, so I'm back at square one.

     

    Since you guys know more than Microsoft Help, could you suggest anything I could try?

     

    Don

    Friday, September 12, 2008 5:54 PM

Answers

  • Finally was able to get the laptop to print over the network by setting the printer up manually outside of OneCare.

     

    On the Vista laptop

     

    1: Control Panel -> Printers -> Add Printer

    2: Add local printer

    3: Create new port -> Local Port

    4: Enter port name (address) For me this was \\Main\HP Photosmart 5100 series

    5: Installed driver

    6: Test print

     

    SUCCESS!

    Tuesday, September 16, 2008 4:27 PM

All replies

  • OneCare support gave you incorrect information.

    The only limitation of printer sharing using the functionality from within OneCare is that the PCs must be all 32 bit (or all 64 bit). You can't share from a 32 bit OS to a 64 bit OS.

    Are you trying to use OneCare's printer sharing feature or are you sharing the printer manually?

    You might want to try the following and then configure the printer to be shared manually, then install the printer yourself using the HP install disc and then pointing to the shared network printer from the laptop.

    Open OneCare on each of the computers.

    Click Change Settings

    On the firewall tab, click configure firewall

    If the network is shown as Public, click Change Location to change it to "Home or Work."

    Click the Advanced Settings button

    Click Network connections tab.

    If there are multiple active connections shown, you may need to disable the extras in your Windows network connections settings. (Network and Sharing Center, manage connections, in Vista; Right click My Network Places and select Properties on the Start menu in XP)

    On the Ports and Protocols tab, add a check mark next to File and Printer Sharing - for subnet and Internet if the first setting alone (after all of the above are verified) does not allow Sharing to work.

    If all of the above fail, please go back to support and ask for your case to be escalated if the front line tech cannot resolve it quickly.

     

    -steve

     

    Friday, September 12, 2008 6:34 PM
    Moderator
  • Thank you for your quick response.

     

    I knew the tech didn't know what they were talking about when they mentioned the wireless limitation.

     

    I already tried the following (from one of your previous forum responses):

     

    Open OneCare on each of the computers.

    Click Change Settings

    On the firewall tab, click configure firewall

    If the network is shown as Public, click Change Location to change it to "Home or Work."

    Click the Advanced Settings button

    Click Network connections tab.

    If there are multiple active connections shown, you may need to disable the extras in your Windows network connections settings. (Network and Sharing Center, manage connections, in Vista; Right click My Network Places and select Properties on the Start menu in XP)

    On the Ports and Protocols tab, add a check mark next to File and Printer Sharing - for subnet and Internet if the first setting alone (after all of the above are verified) does not allow Sharing to work.

     

    I will attempt to install the printer manually.

    Friday, September 12, 2008 6:54 PM
  • Well, installed software from HP disk onto vista laptop.  Tried to manually add printer from main.  Got the same error.

     

    window pops up "Connecting to HP Photosmart D5100 series on Main"

     

    then

     

    another window "Windows cannot connect to the printer.  Operation could not be completed (error 0x0000000d)."

     

    I will attempt to work with OneCare support again.

    Friday, September 12, 2008 7:25 PM
  • Don.Burton,

     

    Thank you for visiting the OneCare forum for Printer Sharing.

    This topic seems to be out of scope but here is a weblink to a different post on another forum on the error message you are seeing:

     

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=1093075&SiteID=17

     

    I hope this helps,

     

    Lori MS

    Friday, September 12, 2008 8:51 PM
  • Don,

    I have an HP laptop running vista, and have tried all the steps from OneCare and the forums without sucess. I can only print if I go to change settings and disable OneCare, or shut down the laptop (strange but it prints the que when I shut down). 

    Charles.L

     

    Sunday, September 14, 2008 5:06 PM
  • Finally was able to get the laptop to print over the network by setting the printer up manually outside of OneCare.

     

    On the Vista laptop

     

    1: Control Panel -> Printers -> Add Printer

    2: Add local printer

    3: Create new port -> Local Port

    4: Enter port name (address) For me this was \\Main\HP Photosmart 5100 series

    5: Installed driver

    6: Test print

     

    SUCCESS!

    Tuesday, September 16, 2008 4:27 PM