locked
Activity Feeds Customizations RRS feed

  • Question

  • Hello World,

    I've installed/Published the Activity Feeds solution in CRM. Once that was completed, I when to Activity Feed Configurations and added the name of the entities i want to enable ie (contact, account, opportunity, appointment). I confirmed all are "Wall Enabled" as well as having a status of "Active"

    I then navigated to each individual entity and published each entity. I am now able to follow or unfollow records. However the "rules" never populated for entities like opportunity, so if I update an opportunity that I am following I do not get an update on my wall. Has anyone else experienced this? Any help with incorporating this great tool with be very much appreciated.

    Thanks in advanced.

    Pasha

    Monday, March 5, 2012 11:10 PM

Answers

  • One more thing is to make sure that AF solutions plugins are enabled. During AF installation, there is a prompt on  "Activate any processes and enable sdk message ..." and you need to make sure that you put a CHECKBOX on this prompt. It is a known issue (we can't enable this by default).

    You can also check whether the plugins are enabled or not by doing the following:

    - Double click on the AF solution.

    - On the left nav, it will show you SDK Message Processing Steps and on the right view, it will list all the plugins. Verify that the status of the plugins are Enabled.

    If the status of the plugins are not enabled, then please uninstall the solution and re install with that steps in mind.

    Let me know if this still does not solve your problem.

    Maya

    Thursday, March 8, 2012 8:33 PM
  • Thanks again Maya! You helped me out with the first piece of the puzzle. The second part was I needed to add PreferredDC then the name of my preferred Domain Controller. Now all works! Cant wait to start using this feature!
    Friday, March 9, 2012 4:27 PM

All replies

  • Hi Pasha,

    Thanks for contacting us.

    What field are you updating in opportunity?

    The out of the box rules will create autopost when you update opportunity for an account/contact, or when you add a new competitor for an opportunity for account/contact, or when an opportunity is won/lost.

    Maya

    Microsoft CRM QA

    Wednesday, March 7, 2012 1:11 AM
  • Thanks for your reply Maya.

    I've tried closing opportunities  as won/lost, and updated sales stages etc. but I haven ot received any updates on my wall. I'm not sure what I'm missing. I created the Post Configuration entity for opportunity (lowercase, and confirmed the name matches.) I then went to the Opportunity Entity and published the entity, however no rules have populated. I've attached a screenshot.  Any help would be greatly appreciated, would love to get this cool new feature implemented!

    Wednesday, March 7, 2012 4:31 AM
  • Two things here:

    - You should see 10 rules for Oppotunity once you add. You are doing the correct thing by specifying opportunity all lowercase. What security role/privilege does your user have? Can you check what privilege you have on Post Rule Configuration entities?

    - Rather than publishing Opportunity entity, you should publish all (or to be specific publish: Post Configuration and Post Rule Configuration entities.

    Thank you

    Maya

    Wednesday, March 7, 2012 8:13 PM
  • Hi Maya - I have the System Administrator role so I have full org rights on all entities. I just uninstalled the solution and reinstalled added configs for those entities and published ALL customizations and I'm still not getting any auto rule generation. Could this be related to RU6? Any other suggestions? Thanks for your time!
    Wednesday, March 7, 2012 9:15 PM
  • One more thing is to make sure that AF solutions plugins are enabled. During AF installation, there is a prompt on  "Activate any processes and enable sdk message ..." and you need to make sure that you put a CHECKBOX on this prompt. It is a known issue (we can't enable this by default).

    You can also check whether the plugins are enabled or not by doing the following:

    - Double click on the AF solution.

    - On the left nav, it will show you SDK Message Processing Steps and on the right view, it will list all the plugins. Verify that the status of the plugins are Enabled.

    If the status of the plugins are not enabled, then please uninstall the solution and re install with that steps in mind.

    Let me know if this still does not solve your problem.

    Maya

    Thursday, March 8, 2012 8:33 PM
  • Thank you Maya! That was definitely my issue. Weird thing is now on the post configuration rule when I go and create one it just spins. I'm guessing its pretty resource intensive and since I'm setting this up in lab my lab environment is a little scaled down. Do you know how resource intensive the Activity Feed Configuration is?
    Thursday, March 8, 2012 11:11 PM
  • I am glad we found that issue.

    AF config is more resource intensive compared to other AF activities since it creates the post configuration entity and all the post rule entities (there can be about 10 rules) in each.

    How long does it take in your env? What your machine spec and are there other stuff running?

    We're improving the AF configuration scenario in our next release. Hopefully it will alleviate some of your pain.

    Again, let me know if you still can't get AF to work.

    Maya

    Thursday, March 8, 2012 11:46 PM
  • Thanks Maya - I found this other post here: https://community.dynamics.com/product/crm/f/117/p/73163/134961.aspx

    that is exactly the issue i'm facing. I'll make the registry change and see if it gets resolved. Thanks for all of your help!

    Friday, March 9, 2012 12:26 AM
  • Thanks again Maya! You helped me out with the first piece of the puzzle. The second part was I needed to add PreferredDC then the name of my preferred Domain Controller. Now all works! Cant wait to start using this feature!
    Friday, March 9, 2012 4:27 PM