locked
Also can not connect from Project client to Server RRS feed

  • Question

  • I can reach and create projects from the web site with no problem, but when trying to connect either launching Project directly, or from "Open -> In Project Professional" on the website, I get the "Could not retrieve server initialization data." error.
    Wednesday, March 10, 2010 8:59 PM

Answers

  • We had a bug in Beta2 where host header sitest would exhibit this kind of problem. It is fixed for RTM.

    Thanks,
    Boaz Lev
    MSFT
    Tuesday, March 16, 2010 5:24 PM

All replies

  • Hello Carson,

    When you open Project Professional 2010, did you register the account?

    To register the account
       FILE   >>> INFO  >>> "Manage Accounts"

    Also, make sure all the accounts do not have a default account.  This is to make sure the default "Computer" account is not being used.

    I really hope that it is something simple like this.

    Michael Wharton, MBA, PMP, MCT
    Thursday, March 11, 2010 2:58 AM
  • Unfortunately, I don't think this is it. I have already created an account, with the URL I use to reach the site IE. 

    edit:

    I did a clean install of sharepoint 2010 and project server 2010, on a 2008 r2 server. I'm really just looking for help on how to troubleshoot this. Are logs for attempted connections stored anywhere on the server or client? The error message is worthlessly vague, and seems to result from multiple issues (having searched through this forum, none of the other hits on it have been relevant).
    Thursday, March 11, 2010 4:36 PM
  • I am running into the same problem.  I ensured that the Account was created to my PWA server and that I have full permissions to the site.  I get the same issue.   I am able to create a Project Plan in EPM2010.  Even if I try and open that project, I get the error.   There just doesn't seem to be much information on what the error means
    Thursday, March 11, 2010 5:03 PM
  • Can you share a little more info on a repro environment? Are you using a host header site?

    Thanks,
    Boaz Lev
    MSFT

    Monday, March 15, 2010 8:36 PM
  • Boaz,

    In my case, I am indeed using a host header, setup through Alternate Access Mapping.   This is the only TCP Port 80 Web app that's running...   Outside of that, this is a Win2k8R2 server with SQL2k8..  

    Monday, March 15, 2010 9:29 PM
  • I'd like to ask you both if the only problem you're having is connecting by using the edit button on the PWA Projects ribbon, or is this true for simply opening the Project client and connecting to the server directly?

    Are you experienced users of Project and Project Server? If not, are you certain that you created your Project Server account within the Project Client? This is done from the backstage by clicking File > Info tab. If you haven't completed this step, you cannot connect to Project Server.

    Let's verify that each of you can connect to your PWA instance this way, then we can troubleshoot launching it from PWA.
    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG
    Tuesday, March 16, 2010 12:38 PM
  • Gary,

    Good questions, I'll try and answer in order
    1. Yes, it's the same message whether I open up Project 2007 directly, or if I open a project from PWA Projects ribbon "Could not retrieve server initialization data"
    2. I'm an experienced Project user and somewhat experienced Project Server user.  I've done this successfully with a PS2007 server.
    3. I used the Microsoft Office 2010 Tools | Microsoft Project Server 2010 (beta) Accounts option from the start menu to create the account.   Should be exactly the same as doing it from the backstage..


    I was thinking that there could be an issue with the whole PWA and Web Application/AAM, so I deleted both (and the databases) and created a brand new Web App on port 80 called epm2010.   I then provisioned EPM 2010 against that and created a new PWA site.   I imported resources from AD and ensured that my account has administrator rights, just to be sure.


    I also have the demo2010a image that I am using on a hyper-v server in my home lab.   I'm trying to compare environments to see if there is something missed.   The frustrating part is that there isn't much about the actual error..   I definitely would appreciate any thoughts on next steps.
    Tuesday, March 16, 2010 4:43 PM
  • We had a bug in Beta2 where host header sitest would exhibit this kind of problem. It is fixed for RTM.

    Thanks,
    Boaz Lev
    MSFT
    Tuesday, March 16, 2010 5:24 PM
  • Thanks Boaz... Any work arounds?
    Tuesday, March 16, 2010 5:51 PM
  • We have created several PWA sites, making sure there is no host header used and still have the same result could not retrieve server initialization data.  Kinda hard to do anything without the heavy client interaction...


    Thursday, March 18, 2010 11:18 PM
  • So, a couple more things on this.

    There are 2 errors in the event log that get generated each time this error happens:

    MSSOAP Soap error: Loading the request into SoapReader failed..

    MSSOAP Unspecified client error

    Both have event ID 16

    Friday, March 19, 2010 7:42 PM
  • Please let us know how to fix the reported issue "Could not retrieve server initialization data"
    Saturday, May 8, 2010 11:46 AM
  • Hi All,

    Please make sure that there is right alternate access mapping in Share Point Central Administration.

     

    Tuesday, July 26, 2011 10:17 AM
  • I added the site to trusted sites and that fixed the problem
    Shane O'Hanlon (Accenture)
    Tuesday, September 13, 2011 6:22 PM
  • I have this problem also and have tried various threads with no luck. Does anyone have an answer for this problem?
    Sunday, June 7, 2020 3:20 AM