none
QFX import into Microsoft Money RRS feed

  • Question

  • Read several threads on this subject, the most relevant by Cal Learner (Thursday, November 11, 2010 6:58 AM).

    I'm running MS Money Plus (yes, still using it - and wish it hadn't gone away).  BofA had one business line where they still offered the Money download (OFX file) option but that goes away Jun 9th this year.  Also - using Windows XP.  I can successfully import the QFX version into Money but only using the manual file import.  Would like to automate the process.  Note I'm not a PC/Windows "expert" but know enough to be careful with the registry.

    1.  Tried running the registry update Cal recommended (QFX2OFX.reg)  The registry did not update; i.e. I observed only one or two changes but not everything in the above .reg file.

    2.  Tried using File Manager, Options, File Types and create a new file type extension (QFX), then associate it with "mnyimprt.exe"; noted some anomolies during that process telling me it probably didn't work correctly.  e.g. after the association, QFX showed but the icon was generic (i.e. not showing Money as did the OFX extension) and also the "delete" option was not available for the QFX listing.

    3.  I'm hesitant to run REGEDIT and manually create the entries in Cal's QFX2OFX file until I understand more about what I need to do and why the .reg file failed to run. 

    Ideas anyone?

    Friday, May 10, 2013 4:41 PM

All replies

  • You might try launching regedit as Administator.  You could right-click on C:\Windows\regedit.exe and choose RunAsAdministrator. Then File->Import the .reg file. If your windows system folder is named something else, find regedit there. Consider creating a restore point in case you want to undo regedit changes.

    For those who might want to translate, here is the file:

    ==========begin qif2ofx.reg===============================
    REGEDIT4

    [HKEY_CLASSES_ROOT\.qfx]
    "Content Type"="text/qfx"
    @="ofx.Document"

    [HKEY_CLASSES_ROOT\.qfx\ofx.Document]

    [HKEY_CLASSES_ROOT\.qfx\ofx.Document\ShellNew]

    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/x-qfx]
    "Extension"=".qfx"

    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\text/qfx]
    "Extension"=".qfx"
    ==========end qif2ofx.reg===============================




    Friday, May 10, 2013 8:32 PM
    Moderator
  • Cal,

    Thanks for the very prompt reply.

    2 PC's; one primary for testing - an older ASUS netbook and the second, my "production version", is running on a virtual machine (VMWare), both current XP-based systems.

    PC1 (the ASUS) - given to me as a gift; RegEdit, "Run as ... Administrator" not an option; apparently the primary user (me) has admin rights. 2nd PC I ran as Administrator.  I'm using rstrui.exe as my registry backup.  After running your script (the above file), I can see new entries for the file type ".qfx" along with "MIME", etc but the actual content of the entries failed to update - identical results on both PC's.  See below:

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.qfx]
    @="QFX_auto_file"

    [HKEY_CLASSES_ROOT\.qfx\ofx.Document]

    [HKEY_CLASSES_ROOT\.qfx\ofx.Document\ShellNew]

    [HKEY_CLASSES_ROOT\Mime\Database\Content Type\application/x-qfx]

    [HKEY_CLASSES_ROOT\Mime\Database\Content Type\text/qfx]

    Saturday, May 11, 2013 3:24 PM
  • Sorry... the RunAsAdministrator thing does not apply to XP.

    I think you are saying that when you select the HKEY_CLASSES_ROOT\.qfx key in RegEdit you see, for example,
    Name      Type    Data
    (default) REG_SZ  ofx.Document
    
    
    rather than
    Name            Type        Data
    (default)       REG_SZ      ofx.Document
    Content Type    REG_SZ      text/qfx
    
    
    I think you mentioned rstrui.exe to indicate that was your alternative to making a restore point, and not as your way of inspecting the contents of the registry.

    Would those be correct? If so, in Regedit, I would right-click the area to the right of the selected key, and do a New->StringValue. Give the name as "Content Type" without the quotes. Then right-click "Content Type" and choose Modify. Enter "text/qfx" without the quotes as the value data.

    If that works, repeat this for the corresponding missing info on the other keys. If it doesn't work, you might inquire about using Regedit on XP on an Windows OS forum.
    Saturday, May 11, 2013 4:48 PM
    Moderator
  • I've been able to add a registry entry under Windows XP that allows Money Sunset Deluxe to seamlessly open .QFX files. Here's exactly what I did:

    Copy this block of text, without the lines containing "BEGIN" and "END".

    ==========BEGIN QFX_to_OFX.REG ===============================

    REGEDIT4

    [HKEY_CLASSES_ROOT\.qfx]
    "Content Type"="text/qfx"
    @="ofx.Document"
    [HKEY_CLASSES_ROOT\.qfx\ofx.Document]
    [HKEY_CLASSES_ROOT\.qfx\ofx.Document\ShellNew]
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/x-qfx]
    "Extension"=".qfx"
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\text/qfx]
    "Extension"=".qfx"

    ==========END QFX_to_OFX.REG ===============================

    Save it into a text file (use NotePad) under file name "QFX_to_OFX.REG" (without the quotes).

    Double click the file.

    Do you see a dialog box:

    "Are you sure you want to add the information to the registry?..."

    If you do, this worked. Click "yes".

    Reboot.

    Test it with a .QFX download.


    Sunday, May 12, 2013 9:41 PM
  • For Cal -

    From your above thread, and just to keep everything clear:

    A.  "I think you are saying that when you select the HKEY_CLASSES_ROOT\.qfx key in RegEdit you see, for example,

    Name      Type    Data
    (default) REG_SZ  ofx.Document"

    After running your "script", my registry entry is (note the incorrect entry in the Data field):

    Name      Type    Data
    (default) REG_SZ  QFX_auto_file

    B.  You are correct in my use of rstrui.exe

    C.  I manually made the other changes using RegEdit, including correcting the problem noted in 'A' above - now in the process of testing and initial results are encouraging on both machines.

    D.  and the tech/geek question on the table is, "Why did the script (reg import file) not run correctly?"

    Thanks Cal!


    • Edited by wh_b Monday, May 13, 2013 7:26 PM
    Monday, May 13, 2013 1:36 PM
  • Also for Cal -

    I have been following this thread because I have also not been able to get your script to make the registry changes.  After I run the script, I see the expected Keys but the values are not added.  From what I know (which isn't much) your script is obeying all the rules but it just doesn't work.

    Moreover, when I add the values using regedit.exe, I still cannot automatically open a .qfx file.  For example, I go to the Discover web site,  click "Download" and select QFX format,  and then "Open with MSMoey" in the pop-up dialog box.  As expected, focus shifts to MSMoney but nothing is imported.  (The files is, indeed, downloaded and I can import it using File>Import in MSMoney.)

    I am running Windows 7 x64.  Could this be an issue with 64-bit versions of Windows?


    Bill Becker


    Monday, May 13, 2013 11:16 PM
  • Bill Becker,

    From a novice, but noticed you are selecting ".qif" format?  If I understand the script correctly, we're solving for an auto-download of the ".qfx" flavor.  Am I missing something?

    Bill (wh_b)

    Tuesday, May 14, 2013 3:58 PM
  • Thanks for pointing out my typo!  I have edited the post.

    Bill Becker

    Tuesday, May 14, 2013 4:11 PM
  • Using Windows 10 Anniversary 64 and Money Sunset.  Shell works great.  Thank you
    Thursday, May 18, 2017 12:55 PM
  • As far as I can see the reg file has the wrong type of "quotes". Regedit doesn't like "funny" quotes.  If you swap them all out it works as expected. 

    “  No Good

    "  OK

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.qfx]
    @="ofx.Document"
    "Content Type"="text/qfx"

    [HKEY_CLASSES_ROOT\.qfx\ofx.Document]

    [HKEY_CLASSES_ROOT\.qfx\ofx.Document\ShellNew]

    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/x-qfx]
    "Extension"=".qfx"

    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\text/qfx]
    "Extension"=".qfx"



    • Edited by Greg Kuyat Thursday, February 22, 2018 5:11 PM
    Thursday, February 22, 2018 5:09 PM
  • Make sure that you create the reg file using Notepad, or another purely text editor to avoid extra formatting created by a word processor, or the wrong types of characters created by the editor.

    Bob - MSN Mobile

    Friday, February 23, 2018 5:13 PM
  • does it matter where in the registry this goes?

    Friday, February 22, 2019 10:45 PM
  • does it matter where in the registry this goes?

    In the *.reg file, the parts in square brackets identify the name of the key, and that identifies where each piece goes.


    Saturday, February 23, 2019 12:01 AM
    Moderator