none
Achievements and statistics not matching RRS feed

  • Question

  • My profile statistics show that my answers are 143. But I got a silver achievement, Forums Answerer III. But in FAQ, it's explained that only on reaching 150 answers, the achievement is achieved. Therefore, is this an error?

    Balaji Kundalam

    Friday, October 4, 2013 2:41 PM

Answers

  • I just thought of another possibility. I know in the TechNet Wiki some activity never gets recorded in our profiles, but some metadata somewhere does get updated. I know because there is a weekly blog highlighting people with the most weekly activity, and it frequently finds many more activities (articles updated) than were posted either on the Wiki leaderboard, or in user profiles.

    Perhaps the same thing can happen in the forums, where server/performance problems prevent forum activity from showing up in our profile (as activities or in our statistics). I know for sure that the Wiki statistics can be wrong. Maybe the same is true of forum statistics (and others have complained that the gallery statistics can miss things).

    I would email "fissues" at microsoft dot com. They might be able to look into your situation and verify for sure. If there is a bug in the awarding of achievements, they should want to know. Or maybe they need to update your statistics to reflect missing activity.


    Richard Mueller - MVP Directory Services

    Friday, October 4, 2013 3:50 PM
    Moderator

All replies

  • I cannot explain what you experience. I've never seen a discrepancy like this before. Thanks for reporting it.

    The usual experience is that there is a delay before such an achievement is awarded. There are two reasons. One, I believe a process only runs periodically to award many achievements, so it can take at least a few days. Second, the count of answers in your profile can include cases where you marked your own reply as an answer (especially if you are a moderator), but such cases do not count toward the achievement. As I stated, I've never seen an achievement awarded before the requisite number of answers is recorded in the profile. I wonder if something changed.


    Richard Mueller - MVP Directory Services

    Friday, October 4, 2013 3:32 PM
    Moderator
  • I just thought of another possibility. I know in the TechNet Wiki some activity never gets recorded in our profiles, but some metadata somewhere does get updated. I know because there is a weekly blog highlighting people with the most weekly activity, and it frequently finds many more activities (articles updated) than were posted either on the Wiki leaderboard, or in user profiles.

    Perhaps the same thing can happen in the forums, where server/performance problems prevent forum activity from showing up in our profile (as activities or in our statistics). I know for sure that the Wiki statistics can be wrong. Maybe the same is true of forum statistics (and others have complained that the gallery statistics can miss things).

    I would email "fissues" at microsoft dot com. They might be able to look into your situation and verify for sure. If there is a bug in the awarding of achievements, they should want to know. Or maybe they need to update your statistics to reflect missing activity.


    Richard Mueller - MVP Directory Services

    Friday, October 4, 2013 3:50 PM
    Moderator
  • Thanks for the information. I've experienced the issue of getting a low count in Wiki, but this appears to be very strange. As per your suggestion, I'll mail to fissues at microsoft dot com.

    Balaji Kundalam

    Friday, October 4, 2013 4:36 PM