locked
Issue with Multiple Lookup Control on Edit RRS feed

  • Question

  • Hi,

     

    We found an issue with the Multiple Lookup Control on MOSS 2007. Our configuration is a small farm with;

                    1 server running SQL Server 2005 with all the latest patches.

                    1 server running MOSS 2007 SP1 with Infrastructure update for WSS and Office Servers.

     

     Following are the steps to replicate the issue;

     

    1.       Crete a custom SharePoint List called List1. Create about 10 entries in the list.

    2.       Create another custom SharePoint list called List2.

    3.       Create new multiple lookup column in List2 looking at List 1.

    4.       In list2 check, if a mandatory “title” column is already there, if not then create another column and mark it to be mandatory.

    5.       Create a new record in list2 and enter some text in title field, select a couple items at the multiple lookup field, save the record.

    6.       Back on the list2 try edit the record you created in previous step.

    7.       Clear the “title” column or the other mandatory column. Select more items from the multiple lookup field. Click Save.

    8.       Page will post back to itself notifying about the missing mandatory fields. If you notice you will see that the selected values on the multiple lookup field are not retained. They will revert back to what was saved originally.

     

    It seems that multiple lookup field works fine if no data is saved already against it but if there is and you try to edit that it’s not keeping its view state on validation check. We have tried this in custom SharePoint template pages with EnableViewState=”true” but still the same behavior. Can you please suggest that how to fix it? Is there any work around or is it a bug which needs to be fixed.

     

    Thanks,

     

    Kabad

    Friday, June 19, 2009 3:23 PM