locked
CDATA in response RRS feed

  • Question

  • <usp_Load_DetailResponse xmlns="http://schemas.microsoft.com/Sql/2008/05/TypedProcedures/dbo">
    <StoredProcedureResultSet0>
    <StoredProcedureResultSet0 xmlns="http://schemas.microsoft.com/Sql/2008/05/ProceduresResultSets/dbo/usp_Load_Detail">
    <UnNamedColumn0>
    <![CDATA[<A1><B1>0</B1></A1>]]>
    </UnNamedColumn0>
    </StoredProcedureResultSet0>
    </StoredProcedureResultSet0>
    <ReturnValue>0</ReturnValue>
    </usp_Load_DetailResponse>

    How do I eliminate the CDATA and get the desired nodes(<A1><B1>0</B1></A1>) as xml. 

    I modified the XSD and replaced the UnNamedColumn0 with <A1><B1>0</B1></A1> and the SP uses XML XPath to create the output.



    • Edited by Sax001 Monday, October 8, 2018 7:39 PM
    • Moved by Stanly Fan Tuesday, October 9, 2018 1:50 AM From Winform
    Monday, October 8, 2018 7:39 PM

Answers

All replies

  • Hi Sax001,

    This forum is discussing and asking questions about the Windows Form and ClickOnce, I will move this thread to Where is the Forum for...? forum to redirect it.

    Thanks for your understanding.

    Regards,

    Stanly


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Edited by Stanly Fan Tuesday, October 9, 2018 1:50 AM
    Tuesday, October 9, 2018 1:50 AM
  • I'd probably ask for help over here.

    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/home?forum=transactsql

    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/home?forum=sqldatabaseengine

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    • Proposed as answer by Stanly Fan Tuesday, October 9, 2018 1:59 AM
    Tuesday, October 9, 2018 1:56 AM
  • Stanly,

    The above response message is from Micorsoft BizTalk server request response call from an orchestration, hence posted in BizTalk forum, hoping to see if others had faced the same issue? 




    • Edited by Sax001 Tuesday, October 9, 2018 4:25 PM
    Tuesday, October 9, 2018 4:25 PM
  • Then you could ask for help over here.

    https://social.msdn.microsoft.com/Forums/en-US/home?category=biztalkserver

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Tuesday, October 9, 2018 4:29 PM