locked
New drive won't show up RRS feed

  • Question

  • Was running low on disk space in my EX470 which has 500GB system drive, another 500GB internal, a 1TB internal, a 300GB internal, and a 500GB external USB.  Safely removed the old 300GB drive by removing it from storage pool and tried to replace it with a new 1TB drive.  It never appears in the server storage tab so that I can add it to the storage pool (and the light by the slot never turns purple).  When I remote desktop to the server, I can see the drive in disk management.  Checking the qsm*.log file, I see the following regarding my new drive when I add it:

     

    7/22/2008 10:09:57 PM  f44] LoadDisk: Found disk \\?\PhysicalDrive4
    Disk 6cdab7d9-f59a-478b-b87c-119a20cb1797
        Name: \\?\PhysicalDrive4
        Friendly Name: WDC WD10 EAVS-00D7B0 SCSI Disk Device
        Device Name: WDC WD10 EAVS-00D7B0     W -DCWUA04766513
        Address: Port0Path0Target3Lun0
        Device path: \\?\SCSI#Disk&Ven_WDC_WD10&Prod_EAVS-00D7B0&Rev_1.00#4&32d9331e&0&000300#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}
        Adaptor: SiS 0182/1182 RAID Controller
        Status: ONLINE
        Health: HEALTHY
        Device type: DISK
        Media type: 0x0000000c
        Size: 1000204886016
        Bytes per sector: 512
        Sectors per track: 63
        Tracks per cylinder: 255
        Flags: 0x00000000
        Bus type: VDSBusTypeScsi
        Partition style: MBR
        Signature: 0x44fdfe06
    ERROR: Out of memory trying to allocate Disk

     

    Any ideas?  Reviewed other threads, but found nothing exactly like this.  Some folks had similar problems, but didn't describe the errors listed above.  I'm reformatting the drive on another PC, based on advice in another thread, but its not clear that will (or should) matter.

    Wednesday, July 23, 2008 4:30 AM

Answers

  • Can you file a bug report on Connect, with server talq logs included?

    And afterward, you could try rebooting your server.
    Wednesday, July 23, 2008 11:54 AM
    Moderator

All replies

  • Can you file a bug report on Connect, with server talq logs included?

    And afterward, you could try rebooting your server.
    Wednesday, July 23, 2008 11:54 AM
    Moderator
  • Hi, have you filed a bug with logs? Microsoft is interested in investigating ("Cool bug." Smile ) but they need the bug in Connect, with logs.
    Thursday, July 24, 2008 1:52 AM
    Moderator
  • Just posted this evening.  Bug ID 357547/CAB 493235471.  My current storage is maxed out, so hoping they can get it resolved soon.

     

    I also added the drive to a USB enclosure and plugged it into the server via USB, but got the same result.

     

    Upgraded to PP1 a few days ago, but not sure if related.  Other interesting item is that currently, pie chart on storage tab shows sytem use at 232GB (9%).  Was definitely 20GB prior to applying PP1, but not sure what it was before I started swapping drives.  Also as part of the swap, I had to remove duplication on 1TB family video share to free up space so I could remove the drive.  Don't know if thats relevant or not.  Put all of that in bug.

     

    Thanks for your help.

     

    Thursday, July 24, 2008 2:29 AM
  • I've let them know that your bug report is there (though they may be watching this thread now) so I would assume they'll be in contact in a day or two.

    Just so you're aware, I don't know that they will be able to deliver a resolution that will fix your server. They'll want to try to figure out how and why it happened, and how to prevent it if they can. If that results in a fix for you, or a workaround, great. And they will try to make that happen, I'm sure, but it's not always possible. But good luck!
    Thursday, July 24, 2008 3:27 AM
    Moderator
  • Downgraded from PP1 and tried again.  It recognized drive and I was able to add it to storage.  Then reinstalled PP1.  Went downhill quickly after that.  I had an existing Western Digital 500GB external USB drive (same manufacturer as the drive I was trying to install).  After the upgrade, the external drive appeared as not in the storage pool.  Inspecting the storage manager setting in the registry, both WD volumes (the external USB and the new drive I was adding) were associated with the same disk, as though I had partitioned one physical drive into two volumes.  Not true.  Should have had two disks and two volumes.  I ended up removing the WD internal drive and fixing the registry based on setting on the whs.reg file still OK on the external WD USB drive.

     

    Bought a Maxtor 1TB drive and installed it tonight in PP1.  Is working just fine.

     

    Not sure how WHS uniquely identifies a physical drive, but seems like somehow it was unable to tell that they were different drives.

     

    Will also update connect.

    Tuesday, July 29, 2008 2:41 AM
  • I'm having the same problem:

     

    I have a Seagate FreeAgent Pro 1TB external hard drive attached to the WHS via USB. The drive is shown under "My Computer" on the WHS, and also manageable through the Disk management console (both via Remote Desktop Connection).

     

    However, the drive doesn't show up under "Server Storage" on the WHS Console.

     

    A few days ago, the same drive was recognized and I used it to back up the server. Later, I detached the FreeAgent and added some internal hard drives. One of these drives was the hard disk of another FreeAgent Pro 1TB which I took out of the external case and mounted it in the server housing. So maybe WHS is unable to distinguish both drives.

     

    I wasn't able to resolve this yet... so I can't back up my server.

     

     

     

    Friday, August 1, 2008 2:14 AM
  • I just "solved" the problem:

     

    I attached the external drive to another PC, then converted the (empty) disk into a GPT disk and did a quick format (with the disk management console).

     

    After that, I connected the drive to the WHS and it was detected properly.

     

    Friday, August 1, 2008 2:38 AM