locked
Office Communicator 2007 R2, unable to send file to LAN user. RRS feed

  • Question

  • I am currently using the Office Communicator 2007 R2 in Office.
    Server is Standard Edition.
    File attachment filtering has disable.
    No restriction on GPO.
    Firewall on all users are disable.

    Now my question is:

    ME <- A, Friend1 <-B, Friend2 <- C

    1. A can send file to B, but B cannot send file to A
    2. A cannot send file to C and C cannot send file to A

    Anyone has encounted this problem before.
    I had search through lots of articles but cannot find any help. Thank you.
    Friday, May 29, 2009 6:52 AM

Answers

  • If you have any VMWare product on the computer, where VMWare has created additinal network interfaces, then disable them (with this the bridge mode will still function, but NAT wil not).
    If you have MS VPN configured on the computer, then you will have to uncheck setting for use remote gateway.

    Regards
    Bert
    • Marked as answer by kenkct Monday, October 19, 2009 3:20 AM
    Friday, October 16, 2009 10:21 AM

All replies

  • Hi henkct,

    This does sound like something is blocking communication between the clients since filetransfers are peer-to-peer. What error message do you get? And what antivirus software? Have you tried disabling your antivirus clients? Also, check your internal OCS server Application (check if your server is filtering file extensions or specified file extensions)
    Check out my Microsft Unified Communications (Dutch) Blog @ www.MsUC.nl
    • Proposed as answer by R Stevens Saturday, May 30, 2009 10:58 PM
    Saturday, May 30, 2009 10:46 PM
  • hi! R Stevens,
    Thank you for your reply, i am using Ms ForeFront antivirus. I am getting the error message :
    "Cannot send "document" to user. This may be due to firewall restrictions or network problems. Please try again. If you need further assistance, contact your system administrator."


    The Server filtering file extensions service is disabled.
    Tried with ForeFront antivirus disabled.
    Tried with Firewall Disabled.
    Workstations are within same v-lan, same network, same switch, same location, and next to each other.
    Monday, June 1, 2009 5:54 AM
  • Hi Kenct,

    File transfer is a peer to peer action, ports 6891-6901 are used for file transfer. Is it possible these ports are unavailable on your clients? Also I would try and start debugging your file transfer traffic using a packetsniffer. (for example http://www.wireshark.org/).

    If you have recently changed any of the policies, make sure you reapply them and check if they actually work with RSOP on the workstations.

    If there isnt a Firewall on, or antivirus / antispam tool enabled and you are all on the same subnet it really should work!
    Check out my Microsoft Unified Communications (Dutch) Blog @ www.MsUC.nl
    Monday, June 1, 2009 10:51 AM
  • Hi R Stevens,

    i had check with all clients, all firewall and antivirus/antispam are disabled, there is no change with Rules and Policy neither.
    If thats the policy problem. i wont be able to send files to some clients.
    All workstation are in the same subnet.

    This is the tricky parts, it should be able to send files 2 way, but practically it dont work that way.
    been search through the web, some said was told by microsoft this is a well known issue of OCS, use Net Meeting instead for file transfer.
    (but this does not solve my problem, is that really nothing i can do, and these weirdo behaviour is common to OCS)
    Tuesday, June 2, 2009 3:40 AM
  • hi! stevens, addition to my first thread,


    all ports are open, no firewall rules or antivirus rules blocking, all workstationa are from same ghost image and same domain.


    1. A can send file to B, but B cannot send file to A
    2. A cannot send file to C and C cannot send file to A
    3. B can send file to C, C can send file to B

    already try with Wireshark  packetsniffer but still unable to find the cause.

    please help. TQ
    Thursday, September 3, 2009 8:37 AM
  • Can you check to see if you can just go to the admin share. or can you even see the other machines doing a UNC to them?
    Mitch Roberson |MCITP:Enterprise Server Admin, Messaging |MCTS:OCS with Voice Achievement |MCT
    Thursday, September 3, 2009 2:07 PM
  • hi mitch,

    thanks for your reply, i tested with admin share, we can access each other with admin share admin$, but the problem still exist.
    Friday, September 4, 2009 2:07 AM
  • we here have a similar problem. but here no one can send files to each other on the internal network. on our clients are also no firewalls installed or they are deactivated, etc. the anti-virus software should not be a problem. We also have tried to deactivate our trendmicro virus scanner and still we have no chance that the file is sent.

    Friday, September 4, 2009 2:19 PM
  • i now have watched the traffic on my firewall if i want to send a file to a user who is sitting next to me. Everytime we send a file, it seems that the communicator wants to open a direct connection over http to some strange ip, e.g 92.122.206.51, 66.235.132.118, 66.235.132.118. But we have a squid-proxy which handels http traffic and so the connection is blocked. I will watch this behaviour but for me it seems that the communicator is asking some outside server to initiate the peer-to-peer connection.

    So plz correct me if I'm wrong but if this is true - why does the communicator want to do this in an internal environment!!!
    Monday, September 7, 2009 9:40 AM
  • trying to get feed back from microsoft as well, but they claimed all these error should not happened and is due to user problem or workstation firewall issue. they claimed there is no external network included on peer to peer file transfer, it is only within the 2 workstation. really cant find helps elsewhere.

    for the clemens-bbq question, the microsoft create this communicator is for use in office only. hope this information helps you.
    Monday, September 7, 2009 10:18 AM
  • I think I found the problem. As I have installed VMware Server locally the Communicator tries to establish the connection through one of the VMware network devices. I now have deactivated those devices and guess - it's working! Files now reach the receiver. Communicator somehow chooses the wrong networkdevice. So why does Communicator take the wrong device for file transfers and why for the sake of god does it use the correct one for everything else (audio, video, chat)?
    • Proposed as answer by BBQigniter Wednesday, September 9, 2009 2:34 PM
    • Unproposed as answer by kenkct Thursday, September 10, 2009 2:46 AM
    Monday, September 7, 2009 11:36 AM
  • my colleagues tried but still not luck. looks like this is not the answer for my question.
    may be it only works on your environment, may be there are something else that causing it to fail.
    further, it also cant explain why audio, video, chat works but not files sharing.
    it must be something needs to be done to the P2P configuration.
    Thursday, September 10, 2009 2:46 AM
  • I think I found the problem. As I have installed VMware Server locally the Communicator tries to establish the connection through one of the VMware network devices. I now have deactivated those devices and guess - it's working! Files now reach the receiver. Communicator somehow chooses the wrong networkdevice. So why does Communicator take the wrong device for file transfers and why for the sake of god does it use the correct one for everything else (audio, video, chat)?

    Clemens-BBQ,

    VMware will cause issues with file transfers.  Our users have experienced the same thing.  Instead of disabling adapters, try changing your NIC binding order. 

    To do so, navigate to Network Connections | Advanced | Advanced Settings (You'll have to unhide the menu for W7).  Once the dialog box appears, locate the connections field under the Adapters and Bindings tab.  Locate your primary NIC/WLAN entry and then move it to the top of the list.   Click "OK" and then you should be in good shape.

    Hope this helps,
    Keenan
    • Proposed as answer by Keenan Crockett Wednesday, October 14, 2009 8:01 PM
    • Unproposed as answer by kenkct Friday, October 16, 2009 9:12 AM
    Wednesday, October 14, 2009 8:00 PM
  • tested, but still no luck. perhaps something else cause the communicator having the file transfer issue.
    Friday, October 16, 2009 9:14 AM
  • If you have any VMWare product on the computer, where VMWare has created additinal network interfaces, then disable them (with this the bridge mode will still function, but NAT wil not).
    If you have MS VPN configured on the computer, then you will have to uncheck setting for use remote gateway.

    Regards
    Bert
    • Marked as answer by kenkct Monday, October 19, 2009 3:20 AM
    Friday, October 16, 2009 10:21 AM
  • thanks brothers, i managed to solve it only through uninstalling VMware, Virtual Server and Virtual PC.
    is there anywhere i can do to have both run together as Keenan Crockett solution didnt work.
    Monday, October 19, 2009 3:22 AM
  • Hello,
    I have question about strange behavior of Office communicator.
    Only one of our user, has noticed strange behavior of office communicator. When she tries to initiate call, when new windows should appear, it does not. Similira when someone sends her IM message. She can see message in small windows in the right down corner, but when she click on it, nothing happen.
    I was thinking that maybe something is blocking communicator from opening new windows. But she doesn't have any antispyware software. Her machine is updated.
    Does anyone has idea, why is this hapenning.


    Thank you, for your answer!

    Regards,

    Rok Rogelj
    Monday, October 19, 2009 6:16 AM
  • Hello,
    I made further investigation. I also enabled communicator logging. But I cannot find anything. There si nothing in event viewer. If someone is calling that person, she can answer the call, by clicking on the pop up in the down right corner. She can speek, but she can't see conversation windows. If she want to call someone, or send instant message, nothing happen....I also tried to uninstall and install again, but no change.
    Any idea?
    Tuesday, October 20, 2009 1:36 PM