locked
Can no longer open console or access shares on server itself or from other machines RRS feed

  • Question

  • So I leave my custom built server on 24/7. I haven't touched it or done anything with it. I come home from work and can't access my shares from my desktop. I remote into it and the shares won't show up even on the server itself. The console won't load. I see errors telling me the backup service isn't running so I manually start it but that doesn't fix the issue. I look in the event log and see errors related to the dmigrator.exe

    If I open explorer and try to navigate to the D drive it locks up windows explorer. 

    I looked in device manager and have no errors. I loaded up disk management and it lists all the drives. I've rebooted many times but still get errors. I shut it down overnight and booted it up in the morning but still have errors. 

    So as far as I can tell I have no hardware failures. No updates are auto applied. So this pretty much just happened out of the blue. 

    Is there any way to fix this? I imagine i'm look at a server reinstallation but 3 out of 4 times I don't even get that option on the install disc. And migrating data off of the system to do a new install is going to require me to buy more drives to dump data on to. My wife is not happy about that. I have about 4tb of data on the thing.
    Thursday, April 22, 2010 5:24 PM

All replies

  • Have you run a chkdsk on all your drives according to this FAQ:
    http://social.microsoft.com/Forums/en/whsfaq/thread/b5372407-1f24-4eff-9092-069c4b4f0cee

    You really should consider a secondary means of backup offsite. 


    --
    Thursday, April 22, 2010 6:11 PM
  • I had just found a online solution I was going to use. Came across the asus service and WHS add in for unlimited storage and was going to install it last night when this issue happened. Talk about timing! 

    I will run the chkdsk and see what happens.

    Friday, April 23, 2010 12:26 AM
  • chkdsk has been running all night. I imagine it will be running all day. I have a dozen drives in the server.
    Friday, April 23, 2010 1:07 PM
  • Is the D: drive still accessible from a command prompt?

    Since you say Explorer hangs if you try to access it, this may well be the drive causing the issues. It holds all the references for accessing the shared folders, tombstones to the files, backup database etc.
    If this is damaged, you will not have access, just as you describe.

    In case chkdsk d: /r does not recover from that failure a server reinstall (eventually to a new disk put in as replacement drive) may be a chance to recover (given all drives are detected properly during the initial stages of setup, which is sometimes difficult with disk controllers running in SATA mode) or the manual method as described in the FAQ How to recover data after server failure would be your possibilities.

    Best greetings from Germany
    Olaf

     

    Saturday, April 24, 2010 11:45 AM
    Moderator
  • The chkdsk fixed it. Took forever to run because I have so many drives but it worked. I'd still like to figure out what caused the problem in the first place so I can avoid it in the future.
    Sunday, April 25, 2010 2:33 PM
  • Make a note of which drive(s) had a problem and monitor them in the future, if the same drives throw up problems again then maybe it's and idea to remove them from your server and check them over with the manfs. diagnostic tools.


    --
    Sunday, April 25, 2010 3:14 PM