locked
Cannot connect to WHS wirelessly RRS feed

  • Question

  • Hey Everyone.  I have a very wierd problem.  I built my own home server using WHS and the first night everything worked great.  I have the server connect to my home router (D-Link DIR-655 wireless N) through ethernet and also connected my laptop to the router by ethernet.  HOwever, when I unplug my computer from the ethernet and connect to my router through wlan I cannot log into WHS console or access my shared folders, or RDC.  But when I plug my laptop to ethernet it works again.  I also am able to connect to the internet wirelessly so no problems there.  I contacted the guys at MIcrocenter to help my and they dont know why its not working wirelessly on the wlan.   PLEASE HELP!!!!

    BTW my laptop is an ASUS running windows vista 64
    Tuesday, January 12, 2010 5:50 AM

Answers

  • I figured it out.  I have Kapersky 2010 internet security and when I uninstalled it and tried to connect wirelessly everything worked.  The problem now it to find the feature to allow Kapersky to allow me to access the home server wirelessly.  Any ideas what this is? THanks!
    Thursday, January 14, 2010 12:16 AM

All replies

  • It's probably an issue with wireless settings on your router or wireless firewall settings on the client. Please do:

    1. Connect your laptop wired
    2. Open command prompt, type ipconfig /all and hit enter
    3. For your Ethernet LAN adapter write down: IP-address, Subnetmask, Gateway address, DHCP server, DNS servers
    4. Connect wireless
    5. Open command prompt, type ipconfig /all and hit enter
    6. For your wireless adapter write down: IP-address, Subnetmask, Gateway address, DHCP server, DNS servers
    7. Compare the values you wrote down for both adpaters. For the IP-address only the last number should differ, all others should be identical
    8. If this is OK it's also possible your firewall adopts different settings when you connect wirelessly, thus blocking connection to your server.

    EDIT: If IP configuration and client firewall settings are OK please check if your router is set to isolate your wireless from your wired network (AP isolation mode). If so disable AP isolation.
    Tuesday, January 12, 2010 10:30 AM
    Moderator
  • Hi Eric,
    I too have never been able to access my WHS via WiFi, and I have been fixing PC problems since '83 so have seen a lot.
    Even with fixed IP, subnet, DNS, etc
    eg
    WiFi PC
    IP = 192.168.1.100
    Sub = 255.255.255.0
    Gate = 192.168.1.1
    DNS = 192.168.1.1

    WHS
    IP = 192.168.110
    Sub = 255.255.255.0
    Gate = 192.168.1.1
    DNS = 192.168.1.1
    and turning any and all firewalls off (including router). It just doesn't work except via Ethernet.
    I have tried it with XP (home & Pro), V Ultimate, V Home Prem, Win7 Ultimate but not one will connect to WHS via WiFi.
    I even changed my router from a Linksys WRT54GS to a Netgear, a Netcomm, a Dlink and a TPlink. (PS, none were as fast as my WRT with Satori firmware)

    I too would love to know if anyone has ever been able to connect wirelessly and just how they did it.
    Tuesday, January 12, 2010 12:12 PM
  • @comprob, I have no problem connecting the same computer wired and wireless, for XP Pro, Vista Ultimate, Win7 Home premium and Win7 Ultimate systems.
    Tuesday, January 12, 2010 12:57 PM
    Moderator
  • Are you able to ping your WHS from your laptop wirelessly? If you click on Start -> Run (or Windows Key + R) and then type "mstsc /v <WHS name here>" (without quotes) does it give you a login screen? If not try the same command but put the IP address of the server instead of your WHS name? Does that give you any results?

    If it does, try going back and use the WHS name instead of IP address, again?


    If that works, you have an issue with your internal DNS.


    Let us know please!
    Tuesday, January 12, 2010 7:28 PM
  • So I tried everything.  I dont know how to disable AP Isolation, if I have it on my d-link router, and everything listed above checks out except gateway which I cant find, so I dont know what to do.
    Wednesday, January 13, 2010 2:05 AM
  • AP Isolation is for keeping multiple wireless clients from seeing each other. It won't have an effect on this problem (unless your WHS was connected wirelessly (unsupported, bad idea, and not your situation)).

    When you say "everything checks out except gateway" does that mean it doesn't list your gateway or you can't ping....what?
    Wednesday, January 13, 2010 2:54 AM
  • I mean when I follow the command prompt, I couldnt find the gateway and I dont know if I can ping to my server.  Your also right that AP Isolation doesnt work.

    Wednesday, January 13, 2010 3:03 AM
  • As far as pinging goes you just type "ping <ip address of WHS>" (without quotes)

    If that works but "ping <name of WHS>" (without quotes again) doesn't work then we can try this.
    I don't like using this solution but what if you try editing your host file:

    1) Open notepad as an administrator
    2) Click File -> Open
    3) You'll need to change the file type to All Files
    4) Goto the C:\Windows\System32\drivers\etc and open hosts
    5) Here you're going to add a new line with the following information:
         <ip address of your WHS> [press tab key] <name of your WHS>
    6) Save the file
    7) Try conecting now.

    Wednesday, January 13, 2010 4:19 AM
  • I figured it out.  I have Kapersky 2010 internet security and when I uninstalled it and tried to connect wirelessly everything worked.  The problem now it to find the feature to allow Kapersky to allow me to access the home server wirelessly.  Any ideas what this is? THanks!
    Thursday, January 14, 2010 12:16 AM
  • I figured it out.  I have Kapersky 2010 internet security and when I uninstalled it and tried to connect wirelessly everything worked.  The problem now it to find the feature to allow Kapersky to allow me to access the home server wirelessly.  Any ideas what this is? THanks!

    thank you.  i had the exact same problem and was wondering why i couldn't access my console.  having said that, i was able to access the server when going through the network page and then accessing the server as a media device.  this allowed me to play videos and mp3 files on the server when connecting wirelessly.  pausing Kaspersky allowed me to access the console.

    has anyone figured out how to configure Kaspersky to allow console access?

    Sunday, December 5, 2010 4:05 PM
  • As far as pinging goes you just type "ping <ip address of WHS>" (without quotes)

    If that works but "ping <name of WHS>" (without quotes again) doesn't work then we can try this.
    I don't like using this solution but what if you try editing your host file:

    1) Open notepad as an administrator
    2) Click File -> Open
    3) You'll need to change the file type to All Files
    4) Goto the C:\Windows\System32\drivers\etc and open hosts
    5) Here you're going to add a new line with the following information:
         <ip address of your WHS> [press tab key] <name of your WHS>
    6) Save the file
    7) Try conecting now.

    And after some years.......

    Many thanks!  to Safesax. This guide worked for me. I suddently had problems connecting wirelessly from my Win7 x64 laptop to WHS  - wired worked fine. Pinging IP address worked but pinging server name didn't.

    Used to have wifi access with no problems, but suddently no more.

    After editing host file as described everything rocks again!    :-D

    Wednesday, February 15, 2012 3:33 PM
  • I was having the problem of not being able to connect wirelessly to my Windows Home Server from a Windows 8.1 machine. Uninstalling McAfee Antivirus fixed the problem.
    Thursday, December 11, 2014 4:19 AM