locked
Disabling Infinite loop detection in Chain Workflow - CRM 2015 RRS feed

  • Question

  • Hi All, 

    I have a chain workflow which works on 100K of data rows. Each workflow in the chain executes a batch. Since there is a loop detection in effect, the chain couldn't continue after 8th iteration.  How do I disable loop detection in this case? Is there any workaround for this in CRM 2015?  

    ** I don't want to increase the depth or time in deployment settings. 

    Thanks


    nasayoo

    Wednesday, July 8, 2015 7:19 PM

Answers

  • In the chain workflow, once it reaches the depth of 7, wait for one hour so that the depth will be reset to 0 and then execute. This will avoid infinite loop and continue the job. 

    nasayoo

    • Marked as answer by nasayoo Friday, July 31, 2015 2:15 PM
    Friday, July 31, 2015 2:15 PM