locked
Issue with SSRS report column link(CRM 2013 On-Premise) RRS feed

  • Question

  • Hi All,

    Facing an issue with the SSRS report ( CRM 2013 on-premise) record link. Setting a link to report column to open the corresponding record link. The issue is when clicking on the column link it always opening the parent record. But the URL is correct if I copy the URL to another new window it is opening the required entity record.

    Even I have tried giving the record link as had coded the same issue is happening.

    Any help will be appreciated.

    Tuesday, June 3, 2014 5:11 AM

Answers

  • Hello Payman,

    Thanks for your time.

    I have used the below code to open the record hyperlink

    Parameters!CRM_URL.Value & "?ID={"&Fields!contractid.Value.ToString()&"}&LogicalName=contract

    The issue seems to in local instance. When I moved to production it is working fine.

    The only difference is in my local instance did not install the roll up 1 but in the  production we have installed the roll up for the on premise CRM.

    I am not sure because of this roll up or any other reason.

    Regards,

    Priya.

    Friday, June 6, 2014 10:49 AM

All replies

  • Hi,

    Could you please provide the code by which you create links in the report?


    Persian Dynamics CRM Community | انجمن متخصصان فارسی زبان

    Wednesday, June 4, 2014 2:33 PM
    Moderator
  • Hello Payman,

    Thanks for your time.

    I have used the below code to open the record hyperlink

    Parameters!CRM_URL.Value & "?ID={"&Fields!contractid.Value.ToString()&"}&LogicalName=contract

    The issue seems to in local instance. When I moved to production it is working fine.

    The only difference is in my local instance did not install the roll up 1 but in the  production we have installed the roll up for the on premise CRM.

    I am not sure because of this roll up or any other reason.

    Regards,

    Priya.

    Friday, June 6, 2014 10:49 AM