locked
not able to run workflow crm4.0 RRS feed

  • Question

  • i enabled trace i get the exception

    HTTP status 401: Unauthorized

    asyncservice un Authrized

    trace

    at AsyncOperationCommand.Execute(AsyncEvent asyncEvent)

    at PoolHandler.ProcessAsyncEvent(AsyncEvent asyncEvent)

    at PoolHandler.InvokeHandlerInPool(Object state)

    at ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)

    at _ThreadPoolWaitCallback.PerformWaitCallbackInternal(_ThreadPoolWaitCallback tpWaitCallBack)

    at _ThreadPoolWaitCallback.PerformWaitCallback(Object state)

    >Exception while trying to execute AsyncOperationId: {B05600CF-6B9C-DE11-B53E-00155D001116} AsyncOperationType: 1 - System.Net.WebException: The request failed with HTTP status 401: Unauthorized.

    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)

    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)

    at Microsoft.Crm.SdkTypeProxy.CrmService.Retrieve(String entityName, Guid id, ColumnSetBase columnSet)

    at Microsoft.Crm.Asynchronous.SdkTypeProxyCrmServiceWrapper.Retrieve(String entityName, Guid id, ColumnSetBase columnSet)

    at Microsoft.Crm.Asynchronous.SdkPluginDescriptionProvider.GetPluginTypeDescription(Guid pluginTypeId, IOrganizationContext context)

    at Microsoft.Crm.Caching.PluginTypeCacheLoader.LoadCacheData(Guid key, IOrganizationContext context)

    at Microsoft.Crm.Caching.CrmMultiOrgCache`2.CreateEntry(TKey key, IOrganizationContext context)

    at Microsoft.Crm.Caching.CrmSharedMultiOrgCache`2.LookupEntry(TKey key, IOrganizationContext context)

    at Microsoft.Crm.Caching.PluginTypeCache.LookupEntry(Guid pluginTypeId, IOrganizationContext context)

    at Microsoft.Crm.Asynchronous.AsyncOperationCommand.GetPluginType(Guid pluginTypeId)

    at Microsoft.Crm.Asynchronous.EventOperation.InternalExecute(AsyncEvent asyncEvent)

    at Microsoft.Crm.Asynchronous.AsyncOperationCommand.Execute(AsyncEvent asyncEvent)

    Tuesday, September 8, 2009 12:56 PM

Answers

All replies

  • Hi,

    check in the MSCRM_CONFIG database in the table  "DeploymentProperties" the values in the entries with the following name in the field Columname
    -  ADSdkRootDomain

    - ADWebApplicationRootDomain
    - AsyncSdkRootDomain

    In all fields should be the name same like "<servername>:port"


    Viele Grüße

    Michael Sulz
    axcentro GmbH
    MVP für Microsoft Dynamics CRM
    Tuesday, September 8, 2009 1:56 PM
  • thanks
    i check its same value in all fields
    Tuesday, September 8, 2009 3:09 PM
  • are you have another idea about thi problem
    Tuesday, September 8, 2009 3:37 PM
  • Hi,

    under wich account runs the async service of crm on your server?
    Viele Grüße

    Michael Sulz
    axcentro GmbH
    MVP für Microsoft Dynamics CRM
    Thursday, September 10, 2009 5:53 AM
  • Hi There,

    I have exactly the same problem. Also all my system jobs have the same problem. It keeps being in the "waiting" state. When viewing the advanced view of the message, it states the same message, 401 Unauthorized.

    My Async service runs under network service account. Tried running the service under the ultimate domain administrator, but no luck either.

    Any ideas what can be the cause of this ?

    BR,

    Ronald
    Friday, September 18, 2009 2:47 PM
  • Some ideas,
    verify your IFD settings,
    on the async server ping ADWebApplicationRootDomain & AsyncSdkRootDomain and see what ip you get.
    check your IIS logs to get the 401 error 401.#


    SJ
    Saturday, September 19, 2009 5:08 AM
  • Hi SJ,

    Wah thas the IFD settings to do with the Async service? I specified in deploymentprops server_fqdn:port (I have two servers in NLB, so figured I had to specify then fqdn). I can ping both ADWebApplicationRootDomain and AsyncSdkRootDomain, they resove fine to server_fqdn.

    Haven't checked the IIS logs so far.

    But how does IFD influence Async? Basically, I want user to always connect to the same URL, so https://<orgname>.company.com, internal and external both SSL.

    BR,

    Ronald
    Sunday, September 20, 2009 9:07 PM
  • IFD doesn't use AD authentication.

    Do a quick test and see if the async works if your async server is listed in the ifdnetworkaddress reg string.


    SJ
    Monday, September 21, 2009 12:29 AM
  • Hi SJ,

    I faked the IFD by putting in a bogus network range for the internal IP space. Reason, I want users to connect to same string, no matter if they are inside or outside the private network. This is the same for all our other services (OCS, Exchange, WSS, etc.).

    But I will try and post the results, I have problems now anyway =)

    BR,

    Ronald
    Tuesday, September 22, 2009 7:37 PM
  • Hi SJ,

    I put in the correct networkrange and subnet mask in the IFD tool and restarted IIS and the ASync Service (is there anymore I should do ?). I still get the message Unauthorized on the system jobs (I just resumed an existing one, should I create a new one instead ?).

    What did change is that from the internal access you have a single sign on. I still can access the URL the same way as externally (eg. customercrm.company.com).

    Any ideas what else to check ?

    BR,

    Ronald
    Tuesday, September 22, 2009 8:37 PM
  • Please if possible
    skype or gtalk jcvniekerk@gmail.com
    Tiaan van Niekerk http://crmdelacreme.blogspot.com Skype:tiaan.van.niekerk1
    Wednesday, September 23, 2009 3:44 AM
  • Hi Tiaan,

    plz check you mail.

    BR,

    Ronald
    Wednesday, September 23, 2009 10:28 AM
  • Hi Topski , you would still get the IFD login if you are using NAT and your clients are connecting with the external ip to the crm server.

    have you resolved your problem yet? can you discribe your setup?
    SJ
    Thursday, September 24, 2009 1:33 PM
  • Hi SJ,

    Here's my setup (all on Windows 2008):
    Server 1:
    CRM with Async Service (running under NETWORKSERVICE)
    IIS AppPool created, Dynamics Web Site is running under a domain user (CRMService), Pipeline mode set to classic.
    Wildcard *.company.com for SSL

    Server 2:
    SQL Server 2005 SP2

    Server 3:
    SSRS Server

    Server 4:
    ISA 2006 server, publishing the Dynamics CRM web site externally

    On the same LAN as the CRM server I have a Terminal Server farm, these are used by the majority of the internal users (access from remote networks with Thin Clients). I have also the possibility to connect with a laptop to the CRM server, this however will be routed and will not be in the same subnet as the CRM servers. Therefore I  guess CRM will work the same way as through ISA, so no differences there for the end users.

    I followed mostly the implementation guide for hosters (there are two manuals, also a walk through) and I followed a lot of articles related to running CRM on Windows 2008 (IIS7).

    Do you need to run the CRM ASync service under the same account as the account configured in the CRM app pool account? There might a cerdentials conflict. I assume the app pool users tried to access the Async Service. I made the service user local admin of the server, but no luck either.

    Do you need some more specific information ?

    Thanks !

    BR,

    Ronald
    Thursday, September 24, 2009 7:33 PM
  • Hi SJ,

    The CRM Async service now runs under the same account as the CRM app pool user account (domain user with local admin rights on server 1). Still the same message. I resumed an existing duplicate detection job. Should I create each time a new job for testing?

    BR,

    Ronald
    Thursday, September 24, 2009 7:54 PM
  • have you reviewed this http://support.microsoft.com/kb/950100

    Async doesn't have to run as the same user as the app pool.

    did you ping the server name that the async is connecting to? you want to be sure it's connecting to the right ip for eg not the ipv6 ip.

    check your IIS logs to get the exact 401 error code.

    review that your crm groups are populated correctly.
    SJ
    Friday, September 25, 2009 4:39 AM
  • Hi SJ,

    I checked my CRM server (running the web services and the Async service) and I have installed all role services for IIS (except FTP). Is this maybe too much ? I just checked everything during install.  Do you know which role services I need for IIS7 ?

    Best regards,

    Ronald
    Monday, September 28, 2009 8:38 AM
  • Hi Topski , the roles you need for win2k8/iis are listed here http://support.microsoft.com/kb/950100.

    is that what you mean?

    Are you still having this problem , if you want we can do a screen share maybe fresh eyes would help.
    SJ
    Wednesday, October 14, 2009 12:38 PM
  • Hi,

    I had the similar problem. We also had IFD Deployment and Hardwareloadbalancing system. And our systemjobs are all in waiting

    Has anybody figured out a solution to this?

     

    Regards
    Matthias

     

    Monday, October 18, 2010 6:31 PM