locked
Back Button error in CRM 2013 RRS feed

  • Question

  • I have a strange error in CRM 2013 with Chrome. When I enter in an entity form and I click the Back button quickly the Google Chrome browser gives me these two errors:

    <CrmScriptErrorReport>
      <ReportVersion>1.0</ReportVersion>
      <ScriptErrorDetails>
       <Message>Uncaught TypeError: Cannot read property 'length' of undefined</Message>
       <Line>5</Line>
       <URL>/_common/global.ashx?ver=-790502954</URL>
       <PageURL>/main.aspx?etc=1090&extraqs=%3fetc%3d1090&pagemode=iframe&pagetype=entityrecord</PageURL>
       <Function>anonymousr:Cannotreadproperty'length'ofundefined</Function>
       <CallStack>
        <Function>anonymousr:Cannotreadproperty'length'ofundefined</Function>
       </CallStack>
      </ScriptErrorDetails>
      <ClientInformation>
       <BrowserUserAgent>Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.102 Safari/537.36</BrowserUserAgent>
       <BrowserLanguage>undefined</BrowserLanguage>
       <SystemLanguage>undefined</SystemLanguage>
       <UserLanguage>undefined</UserLanguage>
       <ScreenResolution>1280x1024</ScreenResolution>
       <ClientName>Web</ClientName>
       <ClientTime>2014-02-04T14:08:04</ClientTime>
      </ClientInformation>
      <ServerInformation>
        <OrgLanguage>1033</OrgLanguage>
        <OrgCulture>1033</OrgCulture>
        <UserLanguage>1033</UserLanguage>
        <UserCulture>4105</UserCulture>
        <OrgID>{8382510D-7C13-DE11-8EB8-00155D010313}</OrgID>
        <UserID>{BEE2D282-7C13-DE11-8EB8-00155D010313}</UserID>
        <CRMVersion>6.0.1.61</CRMVersion>
      </ServerInformation>
    </CrmScriptErrorReport>

    <CrmScriptErrorReport>
      <ReportVersion>1.0</ReportVersion>
      <ScriptErrorDetails>
       <Message>Uncaught TypeError: Cannot call method 'get_element' of null</Message>
       <Line>1153</Line>   <URL>/_common/JsProvider.ashx?IsRefreshForm=true&ids=1759665639-1968334880-202661451-1547461133-1992083491-1000289424-159335543-1194605645-1039841082-1314140682-1376927455-1030632819-1181113682-1025323794-1625018438-513446117-1460109179-1088147315-706656670-232397045-468302605-1405388298-1731109441-2029667886-399776211-330369912-202888856-1793205875-204060739-342519603-542820515-1946640899-1603536461-1220618931-511599809-1264077421-131822024-1188909594-783705869-374257838-1391165063-115658814-60010994-1303204299-2050812538-512064351&ver=-790502954</URL>
       <PageURL>/main.aspx?etc=1090&extraqs=%3fetc%3d1090&pagemode=iframe&pagetype=entityrecord</PageURL>
       <Function>anonymousr:Cannotcallmethod'get_element'ofnull</Function>
       <CallStack>
        <Function>anonymousr:Cannotcallmethod'get_element'ofnull</Function>
       </CallStack>
      </ScriptErrorDetails>
      <ClientInformation>
       <BrowserUserAgent>Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.102 Safari/537.36</BrowserUserAgent>
       <BrowserLanguage>undefined</BrowserLanguage>
       <SystemLanguage>undefined</SystemLanguage>
       <UserLanguage>undefined</UserLanguage>
       <ScreenResolution>1280x1024</ScreenResolution>
       <ClientName>Web</ClientName>
       <ClientTime>2014-02-04T14:08:04</ClientTime>
      </ClientInformation>
      <ServerInformation>
        <OrgLanguage>1033</OrgLanguage>
        <OrgCulture>1033</OrgCulture>
        <UserLanguage>1033</UserLanguage>
        <UserCulture>4105</UserCulture>
        <OrgID>{8382510D-7C13-DE11-8EB8-00155D010313}</OrgID>
        <UserID>{BEE2D282-7C13-DE11-8EB8-00155D010313}</UserID>
        <CRMVersion>6.0.1.61</CRMVersion>
      </ServerInformation>
    </CrmScriptErrorReport>

    And sometimes throws me an error in the XrmServiceToolkit.js:

    <CrmScriptErrorReport>
      <ReportVersion>1.0</ReportVersion>
      <ScriptErrorDetails>
       <Message>Uncaught NetworkError: A network error occurred.</Message>
       <Line>1654</Line>
       <URL>/%7B635267946830000061%7D/WebResources/remcod_/scripts/xrmservicetoolkit.js?ver=-790502954</URL>
       <PageURL>/main.aspx?etc=1090&extraqs=%3fetc%3d1090%26id%3d%257bFB10E024-FF63-E311-9410-00155DFE6E01%257d&pagemode=iframe&pagetype=entityrecord</PageURL>
       <Function>anonymousrror:Anetworkerroroccurred.</Function>
       <CallStack>
        <Function>anonymousrror:Anetworkerroroccurred.</Function>
       </CallStack>
      </ScriptErrorDetails>
      <ClientInformation>
       <BrowserUserAgent>Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.102 Safari/537.36</BrowserUserAgent>
       <BrowserLanguage>undefined</BrowserLanguage>
       <SystemLanguage>undefined</SystemLanguage>
       <UserLanguage>undefined</UserLanguage>
       <ScreenResolution>1280x1024</ScreenResolution>
       <ClientName>Web</ClientName>
       <ClientTime>2014-02-04T14:49:34</ClientTime>
      </ClientInformation>
      <ServerInformation>
        <OrgLanguage>1033</OrgLanguage>
        <OrgCulture>1033</OrgCulture>
        <UserLanguage>1033</UserLanguage>
        <UserCulture>4105</UserCulture>
        <OrgID>{8382510D-7C13-DE11-8EB8-00155D010313}</OrgID>
        <UserID>{BEE2D282-7C13-DE11-8EB8-00155D010313}</UserID>
        <CRMVersion>6.0.1.61</CRMVersion>
      </ServerInformation>
    </CrmScriptErrorReport>

    These errors do not happen in IE 11

    Any advice?

    Thanks.

    • Edited by Leandro86 Wednesday, February 5, 2014 1:51 PM
    Wednesday, February 5, 2014 1:50 PM

All replies

  • I also get these type off errors when for instance I am in an Opportunity and click on an Activity. But to get back to the Opportunity I accidently click on the Opportunity button from the top ribbon menu instead of click on the dropdown arrow on the right of the Opportunity button and selection the previous opportunity.

    I am testing in both IE10 & 11 and it happens in both

    I get the same errors

    Unfortunately I am at a lose as well.

    Kind Regards

    Mike

    Tuesday, June 3, 2014 3:36 PM
  • Hi Leandro,

    Unfortunately these errors (specifically the ones you mentioned) are bugs in the under-lying software, and developers don't have the ability to fix them.
    However you can stop them from displaying to users;

    If you open your Personal Options in CRM, and click on the Privacy tab, you can opt to either "Automatically send..." or "Never send..." error reports.
    This will stop these types of messages from popping up when you are navigating CRM.

    You WILL still see javascript and plugin errors with this option changes however. :)

    ~ Atomic Coder

    • Proposed as answer by Nathan Eccles Sunday, June 22, 2014 5:51 AM
    Thursday, June 5, 2014 7:38 AM