locked
MS CRM 4.0 Plugin registration tool Error -An item with the same key has already been added RRS feed

  • Question

  • When i Register a plugin assembly by importing a solution xml  i keep getting "An item with the same key has already been added " i did unregister the whole assembly closed and restarted the plugin registration tool and again tried but still no go ..Please help
    Wednesday, August 3, 2011 7:42 AM

All replies

  • Hi,

    Make sure from the system if the plugin assembly is uninstalled correctly, you can try searching the plugin assembly into the CRM database table or can rename the namespace of the Plugin Assembly and rebuild it. You can execute the following select query on CRM database to retrieve all plugin assemblies information.

    SELECT [Path]
       ,[Name]
       ,[Version]
       ,[VersionNumber]
       ,[PluginAssemblyId]
       ,[PluginAssemblyIdUnique]
       ,[PublicKeyToken]
     FROM [PluginAssemblyBase]
    


    Jehanzeb Javeed

    http://worldofdynamics.blogspot.com
    Linked-In Profile |CodePlex Profile

    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    Wednesday, August 3, 2011 12:24 PM