locked
MS CRM 4.0 - Not able to change the Business Unit for existing user RRS feed

  • Question

  • I've a parent BU and Child BU in my CRM system. User is assigned a child BU. Now I need to change the BU to parent BU. However, the system itself doesn't allow me to do so. The dialog opened says: 

    "Moving users to different business unit removes all role assignment for the users selected. You must assign the users at least one new role in the new business unit after they have been moved to the new business unit. Also, the current user cannot be moved becasuse this creates authentication issues."

    Upon chaning the BU, system throws an error. Not sure, what could be the possible reason.
    Note: I've System Admin rights on the system.

    Thanks,
    Abhi


    Tuesday, June 14, 2011 1:02 PM

Answers

All replies

  • What error does it throw after changing BUs?

    Gonzalo | gonzaloruizcrm.blogspot.com

    Tuesday, June 14, 2011 1:04 PM
    Moderator
  • It's a standard CRM message - "An error has occurred. Try this action again. If the problem persists, contact Microsoft Dynamics CRM ........"

    The event viewer gives me the following warning details:

    Event Type:	Warning
    Event Source:	ASP.NET 2.0.50727.0
    Event Category:	Web Event 
    Event ID:	1309
    Date:		6/14/2011
    Time:		6:37:06 PM
    User:		N/A
    Computer:	test
    Description:
    Event code: 3005 
    Event message: An unhandled exception has occurred. 
    Event time: 6/14/2011 6:37:06 PM 
    Event time (UTC): 6/14/2011 1:07:06 PM 
    Event ID: 39eeeeba75e64af0abd97742b996bb1a 
    Event sequence: 46923 
    Event occurrence: 46 
    Event detail code: 0 
     
    Application information: 
      Application domain: /LM/W3SVC/2/ROOT-1-129525081344944888 
      Trust level: Full 
      Application Virtual Path: / 
      Application Path: C:\Program Files\Microsoft Dynamics CRM\CRMWeb\ 
      Machine name: test 
     
    Process information: 
      Process ID: 6508 
      Process name: w3wp.exe 
      Account name: NT AUTHORITY\NETWORK SERVICE 
     
    Exception information: 
      Exception type: TargetInvocationException 
      Exception message: Exception has been thrown by the target of an invocation. 
     
    Request information: 
      Request URL: http://X.X.X.X:5555/Test/_grid/cmds/dlg_changeorg.aspx?iObjType=8&iTotal=1&iIndex=0&ownerId={03BF5146-3E75-DF11-B6FB-001517B566D0}&ownerType=10&iId={79089AF1-3C93-DF11-A1CB-001517B566D0} 
      Request path: /Test/_grid/cmds/dlg_changeorg.aspx 
      User host address: X.X.X.X
      User: Test\testuser 
      Is authenticated: True 
      Authentication Type: Negotiate 
      Thread account name: NT AUTHORITY\NETWORK SERVICE 
     
    Thread information: 
      Thread ID: 1 
      Thread account name: NT AUTHORITY\NETWORK SERVICE 
      Is impersonating: False 
      Stack trace:  at Microsoft.Crm.Application.Utility.Util.RaiseXMLError(Exception exception)
      at Microsoft.Crm.Dialogs.ChangeOrgDialogPage.ConfigureForm()
      at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
      at System.Web.UI.Control.PreRenderRecursiveInternal()
      at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
     
     
    Custom event details: 
    
    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    

     

    Tuesday, June 14, 2011 1:14 PM
  • Are you able to run a trace using the CRM Diag tool?

     

    This is brilliant for find the root error messages

     

    Tony

    Tuesday, June 14, 2011 1:14 PM
  • Hello Abni,

    I faced with same error several times. It seems to be Timeout error. To fix it you should check following article - http://support.microsoft.com/kb/918609


    Microsoft CRM Freelancer

    My blog (english)
    Мой блог (русскоязычный)
    Follow Andriy on Twitter
    Tuesday, June 14, 2011 1:19 PM
    Moderator
  • Hi Andriy, the article available at the mentioned link talks specifically about the 'Timeout error' and I believe we've not come across import of heavy customizations which can eventually leads to timeout. Earlier, we were able to perform change in business units for any user. But now, I cant change the BU for any of the user. Unable to figure out where the issue is.

    Also, I am not allowed to change the registry for the server machine. I think, I need to find other workaround for the same. Let me know if anything else can be done for the same.

    Thanks a lot for your helping hand as always.

    Thanks,
    Abhi 

    Tuesday, June 14, 2011 5:56 PM
  • I believe that the error will be the same - Timeout error and I'm afraid that there no way out how to fix this issue.
    Microsoft CRM Freelancer

    My blog (english)
    Мой блог (русскоязычный)
    Follow Andriy on Twitter
    Tuesday, June 14, 2011 7:55 PM
    Moderator
  • Thanks Andriy. Let me give it a try.

    Wednesday, June 15, 2011 5:15 AM
  • Have you removed user security roles before changing his BU?
    Wednesday, June 15, 2011 11:41 AM
  • Nope. In fact, I tried with different scenarios before actually changing the BU for the user. But still of no use.
    Wednesday, June 15, 2011 12:10 PM
  • Hi,

    I've seen this a while ago happening on a Dynamics CRM 4 and SQL Server 2005, both under VMware ESX 4.

    I did fixed this issue changing the OLEDBTimeout value to 8000 and the ExtendedTimeout value to 100000. However, as far as I recall there was also a change I had to alter the timeout of the ASP.NET under the Dynamics CRM 4 IIS.

    Sorry I don't have it at the top of my head but perhaps this can point you in the right direction?

    UPDATE: Perhaps this article would help? http://blogs.msdn.com/b/crminthefield/archive/2011/06/13/microsoft-dynamics-crm-timeout-settings.aspx

     


    MCC, MCP, MCTS

    • Edited by pmdci Tuesday, September 20, 2011 12:41 PM added link to article
    • Proposed as answer by pmdci Tuesday, September 20, 2011 12:41 PM
    Tuesday, September 20, 2011 12:39 PM
  • Hi,

    Thanks for your suggestion.
    Well, in order to resolve the issue, I updated the relevant DB tables and it worked for me. If the problem persists in future, I'll try the above mentioned solution.

    Thanks,
    Abhi

    Tuesday, September 20, 2011 12:53 PM
  • Hi,

     

    When you change the Business Unit, the roles will also be removed. Once you change the Business Unit, you will also have to set the security roles for the user. This is the default functionality.

     

     

    Thanks,

     

    Panguluri


    Thanks, Vinod K Panguluri
    • Proposed as answer by pangulurivk Tuesday, September 20, 2011 1:33 PM
    Tuesday, September 20, 2011 1:06 PM
  • Yes Panguluri. That's very true!
    Thanks.
    • Proposed as answer by mido_elsheikh Thursday, January 5, 2017 2:03 PM
    Tuesday, September 20, 2011 1:45 PM