Run Report Button functionality is missing in CRM when customised with Ribbon workbench RRS feed

  • Question

  • Hi,

       I am using crm 2013, in this i have enabled the 'Run Report' in the Quote form using the Ribbon Workbench tool, and applied customized JavaScript to that button. Based on the script condition the button will enable or disable in the form. but after applying customization the button functionality is missing, i.e. when i click on the button it is not opening anything.

      After some searching in the google i have found that, after enabling the button in Ribbon Workbench we need to set the following dispaly rules Iscore property to True.

                      a.       Mscrm.HideOnCommandBar

    b.      Mscrm.CreateConnection

    c.      Mscrm.IsConnectionsEnabledPrimary

    d.      Mscrm.HideOnModern

    but i didn't find these rules in the tool. please help me anyone if you have any information.

    Thanks in advance.


    Sunday, January 12, 2014 7:59 AM

All replies

  • Hi,

    From my experience, when you need to customize an OOTB ribbon button, you should duplicate it, hide the OOTB one and apply your EnableRule to your new one.

    To do this, you need to modify customization xml file manually (I use Ribbon Workbench tool too but always check the xml file after that).

    So for duplicate point:

    1. You need to get RibbonDiff of OOTB 'Run Report' button using SDK tool: \sdk\samplecode\cs\client\ribbon\exportribbonxml.

    2. Then copy everything to your own button.

    3. Hide the OOTB one.

    Hope it helps.

    Monday, January 13, 2014 7:15 AM
  • Hi Nagaraj,

    The only reason you need to set the 'IsCore' property to True on the enable/display rules is to tell the Ribbon Workbench not to customize them. Setting IsCore allows you to reference the OOTB rules without changing their definitions.

    If you post your RibbonXml, I'll take a look.


    Scott Durow
    Blog www.develop1.net    Follow Me
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Monday, January 13, 2014 11:25 AM
  • Hi All,

        Thanks for replying, i have found and solved the error, in the ribbon work bench tool i have added one more command rather than adding the enable rule to the the existing command. so, i have removed the extra command and added the enabling rule to the existing command. now it is working fine.

    Once again thanks for your support.




    Monday, January 13, 2014 11:31 AM