none
Email Alerts in SharePoint RRS feed

  • Question

  • I've spent quite a bit of time on it and I've run out of things to try. We have a SBS server running here (2003 R2) and it's hosting a file share and a Sharepoint site (WSS 3.0). I've purchased and installed an SSL certificate  and configured IIS to only allow secure connections (https). Every thing is working great and it is nice to not need the VPN to access the site from the outside. Now that more people are using the site we are looking to use more of the features that Sharepoint makes available. 

     

    One of them is email alerts. Tony  has setup a workflow and it is working great except none of the email alerts are getting to their recipients. I looked into it and found that it was using the email addresses in Active Directory instead of the addresses set by user's in their profile on the Sharepoint site. I went into AD and found that the only option it had for email addresses was  machine's local domain. None of the user accounts have Exchange mail boxes because we are using Yahoo to host our email. It turns out that user's that have Exchange mail boxes have additional options where you can set additional (outgoing) email addresses and set them as 'primary' so presumably Exchange's virtual SMTP server would use those. I also set the 'Outgoing email' settings in the Sharepoint Central Administration site to use our Yahoo SMTP server. Of course this doesn't work because the Yahoo SMTP server does not use the standard port 25 and Sharepoint won't let you change which port it uses (it doesn't have any options for authentication either which the Yahoo server requires). I also tried to use our ISPs mail server which does operate on port 25 and doesn't require authentication but that didn't work either (we actually were receiving errors in the Sharepoint workflows that were trying to send emails but the errors only said that it was unable to connect to the outgoing mail server).

     

    So the only way out (that I can see) is to set the Sharepoint outgoing mail server to itself so that Exchange catches the request and uses it's virtual SMTP server. At this point Sharepoint was no longer showing any outgoing email errors. I tried many things to have the Exchange SMTP server relay to an outside SMTP server but so far Exchange always places the mail in the user's local mailbox so it never goes out. I've checked the SMTP server logs and of course it shows that every thing is working fine.

     

    • Edited by Mike Walsh FINModerator Friday, January 23, 2009 5:44 AM "NEED Help.NEWBIE ADMINISTRATOR" removed from Subject. Adds nothing.
    • Moved by Mike Walsh FINModerator Friday, January 23, 2009 5:46 AM off-topic (Moved from MSDN and TechNet Search Feedback to Off-Topic Posts (Do Not Post Here))
    Thursday, January 22, 2009 3:42 PM

All replies