locked
windows home server and linksys wrt310n router RRS feed

  • Question

  • I read a thread that was posted here last year. It is the same problem that I currently have, but the fix for this poster did not work for me. Here is the original post:

    "After having problems configuring my WHS remote access to work with my Linksys WRT310n router, I cantacted Linksys chat support and they helped me configure the settings to make WHS work. This required loosening the security a tiny bit but nothing that would be too terrible I don't think. Just remember to have the Windows Firewall on. 
    First, you have to reserve the DHCP IP address for your server. In the router setup screen under setup click on DHCP Reservation. You should see your server listed in the DHCP table if it's online. Check the box next to your server and click Add Clients. That will reserve the IP address of your server.
    Second, the Linksys rep had me change the MTU setting to Maunal-1300 on the setup page. I don't know whether this step is actually neccessary but I went along with it anyway.
    Third, go to the Security tab and uncheck: Filter Anonymous Internet Requests and Filter Internet NAT Redirection.
    Fourth, go to the Applications and Gaming tab and setup port forwarding on ports 80, 443, 3389, 4125 and 56000 set to the IP address of your server that you reserved earlier. I set 80, 443, 4125 and 56000 to TCP and 3389 to Both.
    Last, go to the Administration tab and in the Management screen check the boxes to enable UPnP and Allow Users to Configure.
    This should allow full and complete control of WHS Remote Access."


    I'm trying to configure WHS remote access too. Since reading the above post, I have done the exact same things this poster did (Matt), but it didn't help me.
    I have a wrt310n wireless router wired to a box with Windows Home Server. The router sits behind a sprint 660 dsl modem. When the home server tries to configure the linksys router it goes through all the steps fine until it gets to "trying to access my webpage from the internet" (the last step) and it fails.

    What can I do differently than he did to make this work? In the mean time...I'm just chewing into my 120 day eval copy with no joy.

    Rob

    Saturday, April 4, 2009 7:10 PM

Answers

  • Hi Rob,
    what you write, shows that the modem is indeed not in bridged mode, but creates its own private network, and the router is behind creating another one.
    Maybe you can reconfigure your wireless router to work as access point (which would be in the same network) instead of working as router(which routes traffic between different networks).
    What are the outputs of ipconfig /all on a client and the server?
    Another potential method would be to open the Windows Firewall exceptions for the necessary components on the WHS to allow access from all computers instead of local subnet, but I wouldn't think of this as a good idea, since it makes the machine more vulnerable against attacks from the Internet, which pass the first line of defense (the "modem in router mode").
    Best greetings from Germany
    Olaf

    Tuesday, April 7, 2009 1:24 PM
    Moderator

All replies

  • Hi Rob,
    port 56000 belongs not to the ports to forward, 3389 is also only to be forwarded, if you need to use Remote Desktop client connection over the Internet (which is unsupported and requires other steps).
    In the router forward only port 80, 443 and 4125 manually to the internal IP address of your home server.
    Allow UPnP configuration better should stay off in the router settings in my opinion, since otherwise a malicious website from any of your client PCs could do the same.
    (In this case an error or a warning of the WHS assistent is not very important.)
    Before starting the Remote Access configuration you should also download and install all updates for WHS using the Update button on the console as long, as you still get updates. Power Pack 2 made some improvements in the setup for remote access.
    Can you ping the registered domain yourname.homeserver.com?
    In this case the registration went already through and you should be able to test remote access from outside of your home.
    (Inside loopback access via the external address is not supported by several router models.)
    Best greetings from Germany
    Olaf
    Saturday, April 4, 2009 7:20 PM
    Moderator
  • Hi Olaf,
    Thanks for the reply. 


    I have assigned a static IP to my home server.
    I have forwarded ports 80, 443 and 4125 to the assigned IP address of the home server.
    I will have to remove port forwarding for port 56000 and 3389 when I get home later.
    I will also turn off UPnP setting on my router when I get home too.
    I have installed updates, but I don't think I have Power Pack 2. I have to check that too...when I get home.
    I can ping my registered domain from here where I work. When I try to access the page in a web browser it says IE can't display the page.


    Greetings back at you from Las Vegas, Nevada

    Rob

    Saturday, April 4, 2009 7:37 PM
  • Hi Rob,
    please validate in the router configuration, if the pinged address is the same as the one on the external interface of your router.
    Is the router directly connected to the Internet or is there an extra modem?
    Can you open your website internally via http://yourservername?
    Best greetings from Germany
    Olaf
    Sunday, April 5, 2009 7:19 AM
    Moderator
  • Hello Olaf,

    I can ping my linksys router 192.168.1.1 and get a response. It is the same ip address in the router configuration.
    I can ping my homeserver ip address and get a response from it too.
    I have a sprint 660 dsl modem (Zyxel 660) connected to my linksys wrt310n wireless router. I have a wired connection from the linksys router to the server.
    When i try to put http://myname.homeserver.com into a web browser it returns my dsl modem web page!
    I can get to my home server website via the server ip address in a web browser.

    I don't understand. I have tried alot of things. I have forwarded the correct ports in the router. I even forwarded the correct ports in the dsl modem. I even tried bridging the dsl modem and that doesn't work either.
    When i try to configure the router via the console, it goes good until it gets to the line about accessing my webpage via the internet and it fails...everytime...with everything i've tried.

    Monday, April 6, 2009 5:11 AM
  • Hi Robb,
    192.168.1.1 is an internal IP address, not the external directly reachable from the Internet.
    Maybe the modem explains something - it should configured be in bridged mode with your router. If it is not, it might be in bridged mode.
    Although, since you can reach your WHS, port forwarding seems to work - besides for port 80, which is caught by the modem? Can you disable web configuration in the modem settings (since it is not good, if somebody from outside can access your routers configuration page)?
    Would you be able to connect to your home server via https://myname.homeserver.com?
    Best greetings from Germany
    Olaf
    Monday, April 6, 2009 9:14 AM
    Moderator
  • Hi Olaf,

    This is what I did, and it worked.

    I ran a cable to a switch, then ran a cable from my server to the switch. then I ran a cable from the wireless router to the switch.
    Then I went into the webpage of the modem and started forwarding ports to ip's. I had to constantly check with Shields Up to see if the ports were open. Finally after one of the combinations...it worked! I was able to remote into the server.
    But... now, since the server is all by itself behind the modem (in router mode), the server can't reach all my other computers on the wireless router. - No Joy.

    It's great that I can remote into the server now, but now it's not going to back up any of my other computers. Do you have a workaround for this?

    Rob
    Tuesday, April 7, 2009 4:46 AM
  • Hi Rob,
    what you write, shows that the modem is indeed not in bridged mode, but creates its own private network, and the router is behind creating another one.
    Maybe you can reconfigure your wireless router to work as access point (which would be in the same network) instead of working as router(which routes traffic between different networks).
    What are the outputs of ipconfig /all on a client and the server?
    Another potential method would be to open the Windows Firewall exceptions for the necessary components on the WHS to allow access from all computers instead of local subnet, but I wouldn't think of this as a good idea, since it makes the machine more vulnerable against attacks from the Internet, which pass the first line of defense (the "modem in router mode").
    Best greetings from Germany
    Olaf

    Tuesday, April 7, 2009 1:24 PM
    Moderator
  • Hi Olaf,

    How do I configure the router as a wireless access point behind the modem?

    Rob
    Tuesday, April 7, 2009 3:12 PM
  • Hi Olaf,

    How do I configure the router as a wireless access point behind the modem?

    Rob
    It's preferable to place your DSL modem in bridge mode, if possible. The 660 is manufactured by Zyxel; you can probably find manuals on their web site, or you can search Google for instructions on how to do this. You can also check on portforward.com to see if there are any instructions there. Or you can request step by step instructions from your ISP; explain that having both the modem in router mode and your router is causing problems accessing the Internet and hopefully they will be able to assist you.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, April 7, 2009 3:42 PM
    Moderator
  • Got it. Thanks for taking the time.

    Rob
    Tuesday, April 7, 2009 9:06 PM