locked
Port 443 a must? RRS feed

  • Question

  • One problem I have with Remote Web Access, is that my ISP uses port 443 as a way to remote access the broadband modem for support matters.
    So it's "locked" in the modems configuration file.

    Any ideas, except changing ISP?

     

     


    WHS 2011 RTM up and running, v.1 gone to meet its maker...
    Monday, June 6, 2011 3:33 PM

Answers

  • One problem I have with Remote Web Access, is that my ISP uses port 443 as a way to remote access the broadband modem for support matters.
    So it's "locked" in the modems configuration file.

    Any ideas, except changing ISP?

     

     


    WHS 2011 RTM up and running, v.1 gone to meet its maker...


    Just a thought.

    Are you able to map a different external port in the router to port 443 on your server?. I have never tried re-direct https and do not know whether it is possible or not. Redirecting RDP ports is no issue so it may be worth giving it a go.

    Then connect by https://yourserver.homeserver.com:xxxxx  Where xxxxx is the redirect port number.

    Like I said don't know for sure but is probably worth trying.

    Dave


    The Frog on the Lilypad at Home
    • Edited by frogz1 Tuesday, June 7, 2011 12:03 AM typo
    • Proposed as answer by kariya21 Thursday, June 9, 2011 3:53 AM
    • Marked as answer by Jonas Svensson -FST- Friday, June 10, 2011 5:03 PM
    Monday, June 6, 2011 11:57 PM

All replies

  • One problem I have with Remote Web Access, is that my ISP uses port 443 as a way to remote access the broadband modem for support matters.
    So it's "locked" in the modems configuration file.

    Any ideas, except changing ISP?

     

     


    WHS 2011 RTM up and running, v.1 gone to meet its maker...


    Just a thought.

    Are you able to map a different external port in the router to port 443 on your server?. I have never tried re-direct https and do not know whether it is possible or not. Redirecting RDP ports is no issue so it may be worth giving it a go.

    Then connect by https://yourserver.homeserver.com:xxxxx  Where xxxxx is the redirect port number.

    Like I said don't know for sure but is probably worth trying.

    Dave


    The Frog on the Lilypad at Home
    • Edited by frogz1 Tuesday, June 7, 2011 12:03 AM typo
    • Proposed as answer by kariya21 Thursday, June 9, 2011 3:53 AM
    • Marked as answer by Jonas Svensson -FST- Friday, June 10, 2011 5:03 PM
    Monday, June 6, 2011 11:57 PM
  • Thanks for the response Dave.

    I have no idea, I'll try and report back here.

     


    WHS 2011 RTM up and running, v.1 gone to meet its maker...
    Tuesday, June 7, 2011 12:03 PM
  • I just tried out the https port redirection using WHS V1 as the target and it works fine.

    I simply altered the external port to be 4433 and port forwarded to the normal port 443 on the whs. Connecting externally using https://xxxxxx.homeserver.com:4433 worked perfectly with no issues with accessing the web page. To check the forwarding was working correctly tried to access via the normal port 443 which then failed.

    PLEASE NOTE: This is on WHS V1 as I am nolonger running WHS 2011. I do not see why it should matter and will hopefully help get around the port 443 problem with your ISP.  

    Although not directly relevant to this forum and only added as an extra comment which may or may not be helpful to WHS 2011 users, the whs V1 check on remote access is still happy. I was expecting it to fail it's check after I altered the external port but it has had no issue's at this point in time.

    Dave


    The Frog on the Lilypad at Home
    • Edited by frogz1 Wednesday, June 8, 2011 9:25 AM Terrible typing
    Wednesday, June 8, 2011 9:21 AM
  • Have this same problem but running WHS 2011.  I have tried re-directing ports to no avail.  There are issues with sending data back through the router.  When running the WP7 connector as well, you only have access to an account page and cannot access content from the server.

    Unless the WHS 2011 team decides to make changes to the server to enable a change from 443 to a user configurable port, my only option will be to move to another ISP that doesn't block the SSL port.  Are there any plans to make this change?

    Thanks, Chris

    Friday, July 15, 2011 8:05 PM
  • I too am having the same issues with redirecting ports. I'm on Telus and they block ports 80 and 443 for the customers "safety"...ya right. Has anyone had luck configuring redirection with Windows Home Server 2011?
    Tuesday, September 20, 2011 7:39 PM
  • I'm now running WHS 2011 and will try the https and http redirection again in the next couple of days.

    Not sure why WHS v1 and WHS 2011 would react differently but I'll let you know what happens once I get chance to re test.

    My ISP doesn't block any ports therefore there was no requirement to try redirection of the ports on 2011 earlier.

    Dave


    The Frog on the Lilypad at Home
    Tuesday, September 20, 2011 8:39 PM
  • It's fairly unlikely that port redirection is going to work. I'm pretty sure that the code behind the web site has port 443 coded into it in a few spots. Unfortunately, since that code is in a .Net assembly, there's no way to alter the port.

    Something worth trying: In IIS, bind an additional port for SSL, and forward that port directly to your server. Then connect to your server using e.g. https://myserver.homeserver.com:4433/etc. I may be missing a step there; it's not something I do regularly. But hopefully y'all get the idea. :)


    I'm not on the WHS team, I just post a lot. :)
    Wednesday, September 21, 2011 1:16 AM
  • I've done this previously but don't quite remember exactly what I did so I thought I'd try again but I still couldn't get it to work.  Here's what I did:

    For IIS binding I went to the IIS Manager on the home server --> right-clicked the Default Web Site --> Edit Bindings --> added a new https binding to port 4433.

    For the firewall I added port 4433 through Windows Firewall with Advanced Security --> Inbound Rule.  This worked but to be extra sure I just disabled the firewall for testing purposes.

    On my firewall I forwarded port 4433 to the IP addy of my home server.

    I then made sure that I could connect to Remote Web Access on my LAN using port 4433.  Next I tested using a port scanner on the web to see if port 4433 was open and it was.

    I then tried from an external device to connect to Remote Web Access and this failed.

    Wednesday, September 21, 2011 4:38 AM
  • I got my port to redirect without any issues.  Using my dd-wrt firmware enabled router I did a port-forward from 4433 to 443.  It looks something like this....Port in 4433  Ip 192.168.0.xx port out 443.  I am assuming that the router does all the work in both directions since it seems to be working fine.   The good news is I did not have to go into IIs7 and monkey with any of the port bindings.  Https://xxxx.homserver.com:4433  

    I hope this may help.

    I have discovered one issue with media streaming routines.  The do not add the 4433 port to the url that they create.
    Friday, July 6, 2012 6:16 PM