locked
Windows Media Centre EPG RRS feed

  • Question

  • The microsoft EPG (for UK) with the Windows Media Centre on Vista does not download guide data beyond 31 December 2012. How do i get it to download that data please. i have done a download and it just seems to update to 31DEC2012 only.
    • Moved by Max Meng Wednesday, January 2, 2013 5:09 AM (From:Office 2010 - IT Pro General Discussions)
    Sunday, December 30, 2012 2:38 PM

Answers

All replies

  • Michael -

    I've also got the same problem; the EPG on 2 Vista PCs only go to 31 Dec 12, while a Windows 7 one has downloaded EPG details into 2013.  I have tried deleting the Vista EPG file and downloading a new copy, and it only downloads EPG info until 31 Dec 12.  So, it appears to be either at the EPG end, or the way Vista interfaces with it..

    You're not alone!

    Regards

    Sunday, December 30, 2012 10:54 PM
  • Same for me.

    My freesat win 7 pc has no epg past 31st Dec 2012

    Monday, December 31, 2012 2:50 AM
  • my Windows 7 HTPC is not updating it's EPG either...

    started getting warnings a couple of days ago that I had less than 3 days worth of listings, but didn't think much of it as I've never had issues with the EPG before and assumed it would sort itself out...

    Event log entry shows it IS downloading EPG, so it must be downloading an empty file...


    Doesn't seem to be an issue my end, I guess I'll just have to wait for those nice people in Redmond to return to work and get it fixed...

    Tuesday, January 1, 2013 9:38 AM
  • Me too! On windows 8 nothing at all now 1/1/13
    Tuesday, January 1, 2013 10:18 AM
  • Same here, on Windows 7 Pro. I don't understand how Microsoft can even entertain this as a possibility. An unreliable EPG makes Windows a non-competitor in the DVR market.
    Tuesday, January 1, 2013 5:58 PM
  • Just what I need on New Years Day with a hangover - a dead media centre :( 

    I'm on W7 HP if that makes a difference.

    I'm guessing no one has any EPG entries on their guide - I have noted though if I put a channel on it will then enter that program and the following one into the guide.


    If this doesn't get resolved soon, I'll be off to the shops to get a stand-alone freesat recorder and sack the PC off.
    • Edited by David_Thornber Tuesday, January 1, 2013 6:44 PM
    • Proposed as answer by saxon009 Tuesday, January 1, 2013 7:30 PM
    • Unproposed as answer by saxon009 Tuesday, January 1, 2013 7:30 PM
    Tuesday, January 1, 2013 6:43 PM
  • if you look in settings/tv/Guide/About Guide Listings you will see start date 1/1/0001 12:00:00 AM End Date 1/1/2013 11:00:00 AM  (i think Microsoft need to get a new licence or agreement)
    Tuesday, January 1, 2013 7:38 PM
  • Hi, I have windows media centre on vista service pack 2 and also find that the EPG is not downloading. Suggest to Microsoft this is a severity 2 software defect and needs resolving quickly if it wants to avoid some very unhappy customers.
    Tuesday, January 1, 2013 8:42 PM
  • I have the same issue, thus far I haven't seen any response from Microsoft, which I think is an appalling way to treat customers, and what are MS Partners supposed to tell their customers, oh sorry yeah sometimes Microsoft just stops bothering to maintain or support their products?

    The result of this is I'm experimenting with MediaPortal, if successful I could setup a Linux media center, if I find I can achieve everything necessary on a Linux box then the rest of the machines in the house will get switched over, then the company machines, then my clients...

    Come on Microsoft get your act together, you can't treat customers this way, your stats on WMC usage don't reflect the impact this will have, if your plan is to go purely into phones and tablets and discard the rest of your customer base at least come clean and be honest about it.

    Wednesday, January 2, 2013 10:48 AM
  • Both my parents are blind and windows media centre is a vital part of their lives which they control with the amulet voice remote.  For the last few days they've been stuck since the "3 days remaining" error keeps popping up and has stopped them from being able to use their tv and the other media on it.  will there be any word from Microsoft on this issue????

    By the way if you use media centre as your tv I heavily suggest you invest in the voice remote as it is a fantastic flawless piece of kit. http://m.youtube.com/index?desktop_uri=%2F&gl=GB#/watch?v=UtRdwPuw1lkhttp://m.youtube.com/index?desktop_uri=%2F&gl=GB#/watch?v=UtRdwPuw1lk

    Wednesday, January 2, 2013 11:08 AM
  • I have experienced this problem too.

    I have spoken to Microsoft Support on two occasions today. On both occasions they have tried to push the problem back onto me. However, in between calls, I also spoke to 'Broadcasting Data Services', who I guess provide the EPG on behalf of Microsoft in the UK. Interestingly, they said that they had been receiving a lot of calls on this issue, but that they were satisfied (without specifying why) that the problem lay with Microsoft.

    I notice that WMC users in the States have also experienced something similar, but seemingly have had their problem resolved.

    Incidentally, I was referred to the Microsoft KB935685 article for a 'Hotfix' on my second occasion of calling, but I am holding-off for now in the hope that Microsoft will come up with something more up-to-date, especially since my EPG had the same start and end dates referred to by 'saxon009', which would suggest that this is more to do with the date and an expiry issue of some kind!

    Regards 

    Wednesday, January 2, 2013 6:10 PM
  • These questions should probably be asked in the Windows 7 Media forum.

    Karl


    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer



    My Blog: http://unlockpowershell.wordpress.com
    My Book: Windows PowerShell 2.0 Bible
    My E-mail: -join ("6B61726C6D69747363686B65406D742E6E6574"-split"(?<=\G.{2})",19|%{[char][int]"0x$_"})

    Wednesday, January 2, 2013 6:20 PM
  • Just for the sake of clarification (and apologies for not doing so first time round), I am only running WMC TV EPG on a machine running Windows Vista 64-bit Home Premium (I am also new to the Forum).

    Regards

    Graham

    Wednesday, January 2, 2013 6:27 PM
  • I’ve got exactly the same problem (no EPG after 1 Jan 2013) and was simply monitoring until MS resolve the problem. I assumed that when MS got back from their Christmas and New Year break they’d sort this out, it’s quite obviously a widespread/universal problem at least in the UK. As we’re home users few will have the facility to raise support calls. From other people’s posts it seems that those who can and do raise support calls are told by MS support staff that it’s their computers which are at fault. This is hopeless!

    These are monitored forums aren’t they? Come on Microsoft, sort it out. There are many thousands of us who’ve trusted you to provide a facility which we now rely on. If you’ve messed up or are intentionally ditching this service then at least tell us. We won’t be happy and we’ll trust you less in future but it’s nothing compared to keeping quiet and leaving us wondering whether or not to sign up to Sky+, delve into digiguide and Big Scree EPG etc. If we know what’s happening we can make plans rather than sitting in limbo for 2 days, 3 days a week, 2 weeks?

    Treating us with this sort of indifferent contempt is disgraceful.


    RobinG

    Wednesday, January 2, 2013 6:35 PM
  • Just to add my voice to this - no EPG listing for the new year after asking for a download in WMC under Windows 7 Ultimate. This definitely consumed network bandwidth as show by Task Manager but the data didn't appear. I'm an IT professional, MSDN subscriber and multimedia developer so I can tell the difference between problems with my machines and a supplier / provider!!

    Come on Microsoft - give us an explanation and a fix!!!

    Wednesday, January 2, 2013 7:23 PM
  • Again, hoping that Microsoft will listen if enough people complain, I have this problem too and I use WMC daily instead of a set top box, so it's pretty annoying!

    Please answer!

    Wednesday, January 2, 2013 10:19 PM
  • Same problem here.  I have two systems, one running WinXP, the other Win7 and both have the identical problem. I did notice a comment on the Red Bee Media Broadcasting Data Services website (the EPG provider) ....."Following some technical changes to our website, you may be required to re-register your details with us".  It may be that the the technical changes have stopped the epg working with the Microsoft media centre: if so, we will have to wait for MS to provide an update or workaround.
    Thursday, January 3, 2013 12:11 AM
  • I have the same problem.  In the run up to the first of January received messages saying epg was about to expire, now no epg data all for any channel.  Using media portal which is a free open source download with EPG until this gets resolved by Microsoft.  Was thinking of upgrading Vista to windows 7 or 8 but after this debacle probably won't bother.
    Thursday, January 3, 2013 12:17 AM
  • Same problem here (winter hill tx, north west UK).  I know this has happened before (2009ish) and it was fixed quite quickly but why has there been no official response from MS or RedBee?

    Just a quick one liner across a selection of forums would suffice, just to let us, THE CUSTOMER, know that it is being looked at. 

    Thursday, January 3, 2013 9:57 AM
  • Yep me too. I spent hours looking for reasons, tried about 4 different things from Microsoft websites to fix it. All I succeeded in doing is wasting the time and losing my favourite channels and HD channels.  Thanks Microsoft.
    Thursday, January 3, 2013 10:07 AM
  • I've managed to get 1 Week listings working for freesat using a free program called EPG Grabber on SourceForge, took me about 2-3 hours to install and then re-map my channels guide listings to the EPG Grabber ones, seems to work very well and I'll set it up as an automated nightly process this evening, it imports into the WMC guide automatically, great stuff, happy wife now.

    If people still seem stuck I'll try and post a more detailed set of instructions tonight but it's all info you can find with a bit of googling...


    John Braham

    Thursday, January 3, 2013 10:09 AM
  • Please do John I cant figure out how to work around this problem so would appreciate a simple set of instructions
    Thursday, January 3, 2013 1:18 PM
  • This really needs to be asked in the Windows 7 Media forum.

    Before posting here, read"PURPOSE OF THIS FORUM - This forum tells you where to go ask questions - Please Read Before Posting"

    Karl


    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer



    My Blog: http://unlockpowershell.wordpress.com
    My Book: Windows PowerShell 2.0 Bible
    My E-mail: -join ("6B61726C6D69747363686B65406D742E6E6574"-split"(?<=\G.{2})",19|%{[char][int]"0x$_"})

    Thursday, January 3, 2013 2:16 PM
  • Ok - I've posted the question in the Windows 7 Media forum.  
    Thursday, January 3, 2013 3:59 PM
  • Thanks!

    Maybe we will get this resolved now.

    The link to the question is:

    http://social.technet.microsoft.com/Forums/en-US/w7itpromedia/thread/df021a39-55b4-440b-8a4c-6e905977344e

    Karl


    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer



    My Blog: http://unlockpowershell.wordpress.com
    My Book: Windows PowerShell 2.0 Bible
    My E-mail: -join ("6B61726C6D69747363686B65406D742E6E6574"-split"(?<=\G.{2})",19|%{[char][int]"0x$_"})

    Thursday, January 3, 2013 4:20 PM
  • I restalled everything factory-shipped on my premium vista laptop to no avail! It's not a virus or stupid update from microsoft, it's simply a defect or bug in the software itself I think. I too don't know what to do...
    Thursday, January 3, 2013 5:26 PM
  • It's obvious MS wants us all to pay for new Windows Software...... We are running Vista and its my daughter's only source of tv and recording. Microsoft have you ever had to deal with the hissy fits of a hormonal teenager? Get your fingers out a fix the technicality you know is your fault as so many are experiencing issues. This is yet another example of trying to get us to part with yet more cash. Off to buy an iMac next, far more reliable and stable and the customer service is better, yes it costs more, but then they last longer than 3 years!
    Thursday, January 3, 2013 7:33 PM
  • It's obvious MS wants us all to pay for new Windows Software...... We are running Vista and its my daughter's only source of tv and recording. Microsoft have you ever had to deal with the hissy fits of a hormonal teenager? Get your fingers out a fix the technicality you know is your fault as so many are experiencing issues. This is yet another example of trying to get us to part with yet more cash. Off to buy an iMac next, far more reliable and stable and the customer service is better, yes it costs more, but then they last longer than 3 years!

    Obvious but quite incorrect. As the same problem exists for Windows 7 and Windows 8 it’s quite independent of operating system and spending more money won’t help until Microsoft’s Internet based program guide is fixed.

    We’re all just as frustrated but you shouldn’t believe a different version of Windows would help. Now a Mac on the other hand…


    RobinG

    Thursday, January 3, 2013 7:39 PM
  • Ok I have sat down and written out the instructions now, it's not as scary as it looks to set up, until it's set up as an automated task though just remember to run it each day, I'll try and create the instructions for automating it, I posted the answer in the thread Karl created;

    http://social.technet.microsoft.com/Forums/en-US/w7itpromedia/thread/df021a39-55b4-440b-8a4c-6e905977344e?prof=required


    John Braham, Analyst Programmer

    Friday, January 4, 2013 1:38 AM
  • FIXED - 

    i dont know if it's fixed for everyone, but mine now works.

    what i did

    Tasks - Settings -  TV - Guide 

    Restore Channel Defaults  (takes a few minutes to complete)

    Guide is now there. if not download update.

    Friday, January 4, 2013 6:39 AM
  • Mine is fixed too!

    I booted-up this morning and the WMC EPG automated update icon appeared in the system tray, indicating that the latest guide listings were being downloaded. When I checked in WMC, the EPG was populated again, although a little tweaking was required (as is normal after refreshing the guide) to make sure that all the regional channel information was correct.

    Graham

    Friday, January 4, 2013 9:31 AM
  • Yes, all seems to working again. Just download latest guide listings or wait for it to happen on schedule.

    Tasks -> TV -> Guide -> Get Latest Guide Listings

    If you've disabled automatic updates, remember to turn them back on:

    Tasks -> General -> Automatic Download Options

    Best of luck.


    RobinG

    Friday, January 4, 2013 10:22 AM
  • yep, miracle; I woke up this morning and accidentally found out the EPG was working again!
    Friday, January 4, 2013 2:57 PM
  • @Tekkitaylors

    try investing time in Linux instead of more even money in Mac... just a thought

    Friday, January 4, 2013 3:00 PM