none
IIS Server Issue RRS feed

  • Question

  • I am experiencing an issue with the IIS:

    I have created a web app which works well on the localhost before I installed the IIS. however, AFTER I installed the IIS on my box, and run the web app off the IIS, it’s getting the some issues - please see the errors below: Class Not registered/Access Denied. The Class was registered and I have the admin access to my box - the same web app does work well without IIS.

    So it seems to be IIS related: need to get registered/access from IIS??

    Please help - thanks in advance!!

    Retrieving the COM class factory for component with CLSID {61D770B4-2C9C-4BFB-9D39-0AF2033A297C} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

    Retrieving the COM class factory for component with CLSID {61D770B4-2C9C-4BFB-9D39-0AF2033A297C} failed due to the following error: 80070005 Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)).

    • Moved by 宝宝徐 Tuesday, November 21, 2017 5:40 AM
    Friday, November 10, 2017 7:13 PM

All replies

  • Hi,

    Welcome to MSDN forum.

    Please go to Microsoft IIS forum to open a new thread where you will get more professional support about IIS problems. If you have problems about installing .net framework, please feel free to let me know.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, November 13, 2017 6:44 AM