locked
HPC 2012 R2 Server Components Installation Fail RRS feed

  • Question

  • Hi All,

    I'm trying to installHPC 2012 R2 to my server. My DB configuration is set as remote. In my architecture, there is two DB servers on "allways on" architecture and traffic is managed by a dns. In configurations of databases, I wrote my dns server (SQLSRV1,1253) name and db names (Hpcmanagement the others hpcdiagnostics etc.). Everything is fine and installation starts but gives error at server components installation. The error is :

    Error -2147467259: failed to create SQL database : hpcmanagement, error detail : unknown error.

    After I click Ok in error code, its rolling back and give one more error :

    Component Microsoft HPC Pack 2012 R2 server compoınents cannot be installed with error code 1603. Fatal error during installation

    To solve my problem I took below actions :

    I installed ssms to head node and tried to connect my database engine (SQLSRV1,1253) with windows auth and its successfull. I check security options, everything seems like fine. I could create/delete/drop tables, procedures and Databases.

    I check my installation path security options and gave all permission to my user.

    I check couple of registry records that I could find related with these, and update them.

    But nothing changed, please help me :)

    OS : Windows Server 2012 R2

    Package : HPC 2012 R2 (update 3)

    DB : SQL server 2012

    • Edited by acyilmaz Sunday, April 21, 2019 10:16 PM
    Sunday, April 21, 2019 10:12 PM

All replies

  • Could you check whether TLS 1.0 is disabled on your head node machine?

    There is a known issue that if TLS 1.0 is disabled, the Hpc Server componenent fails to install (In fact, this is an issue of WIX tool we used to generate the HpcServer_64.msi.)

    If so, you can temporarily enable TLS 1.0 on your head node machine, and after the HPC head node installation, you can disable it again.

    Monday, April 22, 2019 5:15 AM
  • I tried with TLS 1.0 

    Enabled's default value is ffffffff, disbaled is 1 I change them Enabled to 1 disbaled to 0 but when I restart it becomes defaults values. However when I try this in different server with same TLS config, installation ends successfully.

    Monday, April 22, 2019 7:43 AM
  • Tuesday, April 23, 2019 9:51 AM
  • Hi,

    I did enable TLS1.0 on Server where i am attempting to install HPC 2012 R2 and DB server but still getting the following error. Can you please suggest next steps.

    OS - Windows 2012 R2 STD

    HPC - HPC 2012 R2 with Update3

    SQL - SQL 2016

    Component Microsoft HPC Pack 2012 R2 Server Components cannot be installed with error code 1603. Fatal error during installation.

    Wednesday, August 19, 2020 9:04 PM