locked
Discovery Server URL & 404 Error RRS feed

  • Question

  • For the email router I need to define the "Microsoft Dynamics CRM Server" which is supposed to be in the format "http://CrmDiscoveryServer:<port>/<OrganizationName> I have the following settings

    OrganizationName = crm
    external DNS: crm -> public IP
    external DNS: dev -> public IP
    internal DNS: crm -> crmserver.[domain].local
    internal DNS: dev -> crmserver.[domain].local

    So based on that my URL should be https://dev.[domain].com/crm However, when I try to access that link in IE I get "404 - File or directory not found. The resource you are looking for might have been removed,". Interestingly

    https://crm.[domain].com gets me to the website
    https://dev.[domain].com give me the error (even without the '/crm')

    The above applies both when I try it on the LAN and WAN. I have a feeling this has something to do with the fact that crm is also my organization name but I can't figure out what is wrong and what the proper URL for the email router is. Any help is appreciated.

    Friday, May 18, 2012 6:54 AM

All replies

  • hfaun,

    Are you running CRM 2011? CRM 2011 only supports a single URL binding. Which means if you have more than one URLs to access CRM website (eg: https://crm.domain.com or http://crm.local), you will need to pick one of them.

    The way to find out how many bindings you've got for CRM is if you go to IIS and go to the Microsoft Dynamics CRM node. You will see on the right hand menu items how many bindings you've got.

    To fix it, you will need to remove the bindings you don't want as well as updating the settings in Deployment Manager with the correct URL.

    Let me know if this makes sense.


    Dimaz Pramudya - CRM Developer - CSG (Melbourne) www.xrmbits.com http://twitter.com/xrmbits

    Friday, May 18, 2012 7:01 AM
  • Thanks for the quick reply. Yes, it is 2011. When I go to IIS->Sites there is only one site which is Microsoft Dynamics CRM. The bindings say

    :80(http),808:*(net.tcp),*(net.pipe),localhost(net.msmq),localhost(msmq.formatname),*:443(https)

    That leads to the following questions:

    1) I guess I only need 443. So should I remove all the other items? Note that I also have SQL on that server in case that matters.

    2) What is the proper URL for the email router then? https://[domain].com/crm?

    3) In the Deployment Manger->Properties->Web Address I have the binding type to https and all addresses as internalcrm.[domain].com. Should I change all the addresses to crm.[domain].com?

    4) Should I remove dev, auth, and internalcrm from my DNS entries?

    Friday, May 18, 2012 7:18 AM
  • hfaun,

    Yes, you will need to remove all the bindings except one you need (in this case probably the HTTPS). I suggest you put the subdomain in your binding, so that your CRM is accessible thru https://crm.domain.com/CrmOrg/main.aspx

    In the Deployment Manager, you will need to update it to https://crm.domain.com/

    Yes, you can remove all the dev, auth, internalcrm from your DNS entries.

    I hope this helps. If my response answered your question, please mark the response as an answer and also vote as helpful.


    Dimaz Pramudya - CRM Developer - CSG (Melbourne) www.xrmbits.com http://twitter.com/xrmbits

    Friday, May 18, 2012 7:23 AM
  • Thanks Dimaz. Frankly, I am somewhat surprised about this. Almost all the resources I have seen need subdomains like auth, [orgname], sts, etc. One popular one that I used a lot is http://www.youtube.com/watch?v=ZD5qaa-G99E (CRM 2011 Claims based Authentication). The Microsoft documentation also mentions many of those subdomains. I am sure you know but I am just puzzled.

    Friday, May 18, 2012 7:36 AM
  • I did leave all the subdomains as per the quoted video above and set the Discovery Server URL to https://internalcrm.[domain].com/crm This did work.
    Sunday, May 20, 2012 7:18 AM