locked
WHS '11 WSSBackup.exe crash? RRS feed

  • Question

  • I've finally cut over to my new WHS '11 machine on new a new CPU. I've slowly moved the storage drives over from the old HS, and moved the share content to the new machine. An upgrade scenario in WHS 11 setup would have been a monster feature for the enthusiasts. All the machines in the house successfully back up to it except for my primary desktop. That machine has ~8.5TB of HD installed on 4 spindles. The initial backup of that box failed. I eventually customized the backup to include only the 1TB boot drive. That worked. I then added in, 1 at a time, drives 2 and 3. I've now tried several times to get a backup that includes the last of the drives, drive 4. WSSBackup crashes:

    Faulting application name: WSSBackup.exe, version: 6.1.8800.16385, time stamp: 0x4d6ed362

    Faulting module name: WSSBackup.exe, version: 6.1.8800.16385, time stamp: 0x4d6ed362

    Exception code: 0xc0000025

    Fault offset: 0x0000000000098af4

    Faulting process id: 0x2620

    Faulting application start time: 0x01ccb0afceef4a2f

    Faulting application path: C:\Program Files\Windows Server\Bin\WSSBackup.exe

    Faulting module path: C:\Program Files\Windows Server\Bin\WSSBackup.exe

    Report Id: fc1ea12b-1d19-11e1-8b3b-50e54951630c

    This failure always leaves the backup database corrupted (robustness? fault tolerant? Not so much.) Repairing the database works, but is very slow, and sometimes fails 1x; a second try then usually succeeds. 

    Any ideas?

    Saturday, December 3, 2011 6:59 AM

All replies

  • How large is the last drive?
    I'm not on the WHS team, I just post a lot. :)
    Saturday, December 3, 2011 11:07 PM
  • 1.5TB. It's the only one of the bunch that's almost full. I just replaced drives 2 & 3 with larger ones; the restore to the new drives went fine. I'm chkdsking the last drive now. Clearly, I take too many pictures ;-).
    Saturday, December 3, 2011 11:43 PM
  • I have the exact same problem and it's driving me NUTS. How frustrating! As you say, what's with leaving the database in a corrupt state? That's pretty poor design since now NOTHING ELSE can be backed up until it's repaired.

    On the client side, I notice a couple minutes after receiving this error message on the server that there's a backup error in the "Application and Services Logs" "Windows Server" log: "Backup job 1 on WHS did not succeed.  Reason: ConnectionLost, System.String[]" which makes sense given that the server-side process crashed.

    I've even tried deleting my whole backup database store and starting from scratch. I'd consider reinstalling WHS2011 but this started happening from the get-go so what would be the point of that?

    After two months of frustration, this is getting pathetic. Am thinking I should drop WHS2011 and go with CrashPlan. If I do that, I'll probably switch to FreeNAS or OpenFiler because then the only reason I had to go with a MS server (i.e. the integrated backup solution) will be gone. At least with these open source projects, there's support.

    Tuesday, December 13, 2011 2:36 PM
  • Agree.

    I have had the original WHS for working very well - no backup errors at all over 2 years.

    WHS is a real disappointment and there seems to be little commitment on MS to fix these problems.

    Tuesday, January 10, 2012 6:25 PM