locked
After reinstallation, admin on WHS cannot access \\SERVER\folder - authorization problem ? RRS feed

  • Question

  • I had installed Windows Home Server p2 with IDE mode in BIOS.

    After seeing that I need to enable AHCI to be able to use all SATA connections in my board (Gigabyte - Nvidia 9400), I have slipstreamed AHCI drivers to WHS installation (http://wiki.wegotserved.com/index.php?title=Slipstream_Windows_Home_Server) and reinstalled my WHS.

    The reinstallation required quite a lot of boots and took several hours but finally finished without problems. I have also used the same password for admin.
    (http://wiki.wegotserved.com/index.php?title=Upgrade_from_Evaluation_version_to_OEM)

    The problem is that, as admin on WHS,  I can not open any folder via \\<SERVER>\...  , even the WHS standart ones (pictures, videos etc.) . It gives authorization error ?!!!

    I created a new share "testme" and saw that I also cannot access the path \\<SERVER>\testme !
    (I can access all folders via "DATA" drive.

    Please help. I do not want to make a new install and move my ~700GB data...

    Wednesday, July 15, 2009 10:35 AM

All replies

  • Have you created any users yet? I recall someone else having the issue you describe; it went away after he created a user. (Sorry, can't find the post ATM.)
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, July 15, 2009 3:29 PM
    Moderator
  • thanks for the recommendation.

    I have created several other users including admin but did not help.

    I have also tried to reset the permissions of the foldes without positive result :(

    Wednesday, July 15, 2009 11:09 PM
  • thanks for the recommendation.

    I have created several other users including admin but did not help.

    I have also tried to reset the permissions of the foldes without positive result :(


    Once you created a user, were you able to access your shares from a client with that same user name?  How did you reset the permissions?  What are the Sharing and Security permissions now?   (Please be specific and post all users, groups, and permissions that it shows for both Sharing and Security.)
    Thursday, July 16, 2009 2:07 AM
    Moderator
  • Hi,

    sorry I did not include details as needed. Hope this is enough.

    I have tried to reset permissions with the following steps;

    1. Created a new user (via management console)

    2. Added the user to administrators group (via Computer management -> Local User and Groups)

    3. Restarted the server, logged on with the new admin

    4. Created a "new share" (via management console)

    5. Checked and saw that new admin cannot access the standart shares via \\<servername>\

    6. Checked and saw that new admin cannot access the "new share" via \\<servername>\
        But the folders are accesible via DATA drive.

    7. Came across with another problem that Management Console cannot see addins setup files, possibly due to read authorization problems (via management console -> Settings -> addins)

    8. Tried to reset sharing permissions for "new share" via (Folder Proporties -> Permissions) by removing all entries and adding new admin user and admin group back. I also applied "replace owner on sub containers and objects" from advanced tab.

    9. Checked and saw that new admin still cannot access the "new share" via \\<servername>\...

    10. Tried to change security settings for "new share" via (Folder Proporties -> Security) removed admin group, added admin group and new admin as Full control.

    11. Checked and saw that new admin still cannot access the "new share" via  \\<servername>\...


    So after spending quite some time I decided to make a fresh install. (I did not try to connect remotely thinking that if I cannot make it on the server due to auth. problems, I probably will fail on client connection)

    I have 3 drives
    Drive 1: 750 GB   System Partition + Primary Partition
    Drive 2: 1500 GB  Data Partition
    Drive 3: 1500 GB  Data Partition

    The recommendation I read is to plug off data partitions (in this case drive 2 & 3) reboot and perform a fresh install. However I believe this is risky becasue the fresh installation will wipe drive 1 which means primary partition will be deleted as well and besides thumbstones, there is chance that primary partition might have real files !

    *** Question1:  Can you please comment on this risk ?

    So I continued as follows;

    13.Removed one of the 1,5TB harddisk from storage pool (took 2 hours)

    14. Started to copy files from DATA drive to removed harddisk (copy process was really!  slow)

    15. Installed "teracopy" and started to "move" files with teracopy (faster but still took many hours with average speed of ~40 MB/sec to move 700 GB). I still did not expect it to be this slow (2 idential SATA-2, Western Digital 1,5 TB green series connected to Gigabyte 9400 board supporting SATA-2), would expect something like 100MB/sec.

    16. I checked  "I/O Write Bytes" and "I/O Other Bytes" via windows task manager and saw that top I/O originates from searchindexer, QSM, teracopy and demigrator service. I snoozed searchindexer and stopped the demigrator service. Copy speed average improved to 55 MB/S.

    *** Question 2: On such a restoration scenario, while copying the files from DATA to non-storage pool harddisks, what are the best practices ?
     a. Is it safe to use other programs such as (teracopy, goodsync,...) on a WHS from file integrity point of view ?
     b. Would you suggest copying files instead of moving, from performance point of view (so there won't be extra work caused by background jobs   to delete the thumbstones) ?
     c. Which services do you suggest to stop to speed up file transfer within the server among disks (without compramising integrity ;) ) ?

    17. Through the last hours of "move" process I realized that I had not applied the updates to the system since my install (which is a trial WHS downloaded a week ago from Microsoft site) and gave it a try.

    18. The update required 52 correction to download. I could not check all of them but the majority was security related.

    19. Before the finish of the move process, the updates asked for a reboot so I did.

    20. After logging on, the problem vanished ?!!! most probably due to updates.

    Overall, it has been a weird experience. I still need to do a fresh install as I messed up some of the standart shares.

    I would appreciate if you can answer my two quesitons above.

    Thursday, July 16, 2009 10:43 AM
  • The issue could be that no network driver was loaded, meaning you didn't get a loopback connection.

    Q1) The primary partition could have real data, but if you've been using Folder Duplication, it should be on the other drives.
    I think that's an acceptable risk. Done a few reinstalls without issues.

    File copy is expected... you're not going to get sustained 100Mb/s, even on modern drives.

    Q2) No one has removed problems with those specific utilities. I have copied lots of data to and from the storage pool with no problems. Disabling those services you saw could definitely help, as then the hard drive isn't seeking between other requests. I don't see any harm.
    Thursday, July 16, 2009 6:59 PM