locked
Map Point 2011 Installation Error RRS feed

  • Question

  • I am attempting to install Map Point 2011 on a Windows 7 SP1 computer. I've tried this with and without Office 2010 installed and receive the same error towards the end of the installation. Sam error on a Windows 7 computer without SP1.

    Error 1911. Could not register type library for file c:\program files\common files\microsoft shared\geography\MPOAI18.dll. Contact your support personnel. When I click ignore a second error is displayed Error 1911  Could not register type library for file c:\program files\microsoft\MapPoint 2011\MPNA83.tlb. Clicking ignore a second time and the installation completes, When I attempt to run the program a command prompt box appears briefly before closing. Map Point does not open.

    I've searched Google and can't find any messages related to this error.

    Any assistance is appreciated.

    Robert



    Wednesday, April 13, 2011 2:13 AM

All replies

  • 32 bit or 64 bit?

    MapPoint may require Office 32 bit: Some report it works okay, although I was not expecting it to work.

    MapPoint runs fine on Win7 x64 as long as all add-ins/etc are 32 bit only.

     

    Richard


    Richard Marsden
    MapPoint Add-ins at Mapping-Tools.com
    Wednesday, April 13, 2011 1:41 PM
  • It's 32 Bit Windows 7 Enterprise.

     

    Robert


    Wednesday, April 13, 2011 3:27 PM
  • I think that I have a solution to "One of the prerequisite components failed to install. Setup will now exit." when trying to install "SW_DVD5_NTRL_MapPoint_2011_W32_English_DLA_NA_Maps_X17-12847.IMG" from Microsoft Action Pack, and this might apply here.

    If you were to try and copy a DLL from your newly burned disc, created from that IMG, you would not be able to.  Instead, Windows (7 Ultimate x64 SP1, in my case) would pop up a small window indicating:

    "Invalid MS-DOS function.", try again or cancel. Neither choice is of any help.  FWIW, you can copy a TXT file...

    Now note that the above-mentioned download is an IMG file, but the website indicates that the file to be downloaded is an ISO file.

    So, here is what you do:

    1) After downloading the above IMG file, change its extension to ISO.
    2) Create a temporary folder on your desktop and extract the contents of the ISO to that new folder (WinRAR was my choice to accomplish that).
    3) Navigate, from that new folder, to MapPoint, MSMap. Launch data.msi.
    4) Done.

    Thursday, June 9, 2011 2:26 AM
  • Robert,

    Did you find any solution to this problem ?

    Mital

    Wednesday, January 25, 2012 10:07 PM