locked
Installing Reporting Server Extension for CRM2011 gives AD Group PrivReportingGroup Error RRS feed

  • Question

  • Hello,

    I recognize there is an entry of the exact same type.

    However, I did define the <Groups AutoGroupManagementOff="true">
    Still I get the error:

    Error| Check PrivReportingGroupActiveDirectoryRightsValidator : Failure: ActiveDirectoryRightsValidator.Failure.Groups PrivReportingGroup

    How come?

    Would s.o. have a suggestion?
    Setup with the config files isn't really worked out well. I should not get this error.

    Also I do not quite understand the tag <instancename>. What is meant? The sqlserver instance, the name of the organization in CRM or what?
    Why should the instancename be "mssqlserver"? This is the name of the service but what has that to do with it? I just took it over and didn't change anything.

    I edited this, I just observed that a default instance is named mssqlserver. So it is OK.

    Here is my config-file for installing Microsoft Dynamics CRM Reporting Extensions:

    <crmsetup>
    
    
    
    <srsdataconnector>
    
    
    
    <srsdataconnectorinstall>
    
    
    
    <configdbserver>myservername</configdbserver> 
    
    
    
    <autoupdateconfigdb>True</autoupdateconfigdb> 
    
    
    
    <instancename>MSSQLSERVER</instancename> 
    
    
    
    <patch update="false" />
    
    
    
    <Groups AutoGroupManagementOff="true">
    
    
    
     <PrivUserGroup>CN=PrivUserGroup,OU=CRM,OU=groups,OU=someou,OU=Resources,DC=europe,DC=company,DC=someentry</PrivUserGroup>
    
    
    
     <SQLAccessGroup>CN=SQLAccessGroup,OU=CRM,OU=groups,OU=someou,OU=Resources,DC=europe,DC=company,DC=someentry</SQLAccessGroup>
    
    
    
     <ReportingGroup>CN=ReportingGroup,OU=CRM,OU=groups,OU=someou,OU=Resources,DC=europe,DC=company,DC=someentry</ReportingGroup>
    
    
    
     <PrivReportingGroup>CN=PrivReportingGroup,OU=CRM,OU=groups,OU=someou,OU=Resources,DC=europe,DC=company,DC=someentry</PrivReportingGroup>
    
    
    
    </Groups>
    
    
    
    </srsdataconnectorinstall> 
    
    
    
    </srsdataconnector>
    
    
    
    </crmsetup>


    Tuesday, March 29, 2011 1:07 PM

All replies

  • Hi

     

    I assume you have CRM2011 application already installed and are trying to install the Reporting extensions. I am also assuming you have local admin rights on the Reporting server.

    Log on to the reporting server locally (or via remote desktop). The reporting extension needs to be installed on the Reporting Services server.

    In the config file for reporting extensions, enter only the following:

     

    <crmsetup>
    <srsdataconnector>
    <configdbserver />
    <autogroupmanagementoff>true</autogroupmanagementoff>
    </srsdataconnector>
    </crmsetup>

    You will get prompted for all other values.

    Also make sure the reporting services sever machine name is included in the PrivReportingGroup AD group.

    This should get it to work. Pls let me know if you run into further issues.

    Thanks and Regards
    AniMandal
    http://xrmadventures.wordpress.com/

    • Proposed as answer by AniMandal Tuesday, March 29, 2011 2:38 PM
    Tuesday, March 29, 2011 2:38 PM
  • Hi,

    thank you - it worked.

    I was not prompted for anything.


    I assume now that the tag autogroupmanagementoff cannot be put into the groups tag.

    Sincerely

    Andreas

    Wednesday, March 30, 2011 9:52 AM
  • Hi Andi

     

    Glad it worked. could you kindly mark the answer as an "Answer"?

     

    Thanks and Regards

    AniMandal

    http://xrmadventures.wordpress.com/

    Wednesday, March 30, 2011 6:24 PM