none
MPI sample program testing under Win7, Visual Studio 2008 RRS feed

  • Question

  • Hi, all.

    I have written an MPI application, using Visual Studio 2008 SP1, under Win7 and could be run successfully before, with an installation of Microsoft HPC Pack 2008 SDK R2 

    The HPC Pack 2008 SDK is download from this link

    https://www.microsoft.com/en-us/download/Details.aspx?id=2800

    After then, I installed Microsoft HPC Client 2008 and then I re-run the MPI program, the program can't be run with the error

    'mpi application on xxx is unable to connect to the smpd manager on null: 1964 error 1722.

    Then I removed both Microsoft HPC Pack 2008 SDK and HPC Client 2008 and reinstall HPC P'ack 2008 SDK R2 again. The error is still reported upon running the program.

    Please help to see how to solve the problem.

    Thanks.

    Regards, Simon


    Thursday, March 31, 2016 6:35 AM

Answers

  • Hi Simon,

    What is the command that you're using to run the mpi program?

    By the way, the MPI redist that comes with HPC Pack 2008 SDK is quite old. I would recommend using our latest MS-MPI package, which is available here:

    https://msdn.microsoft.com/en-us/library/windows/desktop/bb524831(v=vs.85).aspx

    In order to update the MS-MPI redist, you will want to stop the msmpi service on the machine (net stop msmpi), and then uninstall the current MS-MPI package and install the latest one

    Anh

    • Marked as answer by Simon Tong Wednesday, April 6, 2016 8:04 AM
    Thursday, March 31, 2016 6:19 PM
  • Hi Simon,

    There's an issue with msmpi sdk when compiling under Visual Studio 2008 (we do recommend that you use newer versions of Visual Studio. either 2010, 2013, 2015 should all work without issue). However, to compile with Visual Studio 2008 you need add the definition MSMPI_NO_DEPRECATE_20 to the list of preprocessor definitions

    You can add preprocessor definitions under Project Settings -> C/C++ -> Preprocessor -> Preprocessor definitions

    Anh

    • Marked as answer by Simon Tong Friday, April 8, 2016 2:08 AM
    Thursday, April 7, 2016 6:57 AM

All replies

  • Hi Simon,

    What is the command that you're using to run the mpi program?

    By the way, the MPI redist that comes with HPC Pack 2008 SDK is quite old. I would recommend using our latest MS-MPI package, which is available here:

    https://msdn.microsoft.com/en-us/library/windows/desktop/bb524831(v=vs.85).aspx

    In order to update the MS-MPI redist, you will want to stop the msmpi service on the machine (net stop msmpi), and then uninstall the current MS-MPI package and install the latest one

    Anh

    • Marked as answer by Simon Tong Wednesday, April 6, 2016 8:04 AM
    Thursday, March 31, 2016 6:19 PM
  • Dear Anh,

    Let me try to solve this problem under HPC Pack 2008 SDK first as I have difficulties in installing MS-MPI package before that I may spend time to solve it later.

    I run the program under Visual Studio 2008. Inside the 'Debugging' window of 'Configuration Properties' pulldown list, setting is as follows:

    Command: C:\Program Files\Microsoft HPC Pack 2008 SDK\Bin\mpiexec.exe

    Command Arguments: $(TargetPath)

    Please see what I can do to solve the problem.

    Thanks.

    Regards, Simon

    Wednesday, April 6, 2016 8:07 AM
  • Dear Anh,

    On the other hand, I tried to install MS-MPI v7.

    After installation, I type set msmpi and can only find the following environmental variable

    MSMPI_BIN=C:\Program Files\Microsoft MPI\Bin\

    and I can't find any installation and folders about include and library directories.

    Do I need to install further files?

    Regards, Simon
    Wednesday, April 6, 2016 8:58 AM
  • Dear Anh,

    I managed to see the include and library environment variables after I have also installed msmpiskd.msi.

    After I have added the setups into the Visual Studio 2008 environment and compile, a series of the following errors are reported that's about mpi.h

    1>c:\program files (x86)\microsoft sdks\mpi\include\mpi.h(5897) : warning C4091: '' : ignored on left of 'int' when no variable is declared
    1>c:\program files (x86)\microsoft sdks\mpi\include\mpi.h(5897) : error C2143: syntax error : missing ';' before '['

    Appreciate your help on this.

    Regards, Simon


    Wednesday, April 6, 2016 9:28 AM
  • Hi Simon,

    There's an issue with msmpi sdk when compiling under Visual Studio 2008 (we do recommend that you use newer versions of Visual Studio. either 2010, 2013, 2015 should all work without issue). However, to compile with Visual Studio 2008 you need add the definition MSMPI_NO_DEPRECATE_20 to the list of preprocessor definitions

    You can add preprocessor definitions under Project Settings -> C/C++ -> Preprocessor -> Preprocessor definitions

    Anh

    • Marked as answer by Simon Tong Friday, April 8, 2016 2:08 AM
    Thursday, April 7, 2016 6:57 AM