none
Live Writer Photo Album upload problem(s)

    Question


  •  There seem to be a number of problems on photo album upload. I love the idea of photo album upload of a multiple pictures. However, what's good if it doesn't work properly?

     On my desktop with Windows Vista 32 Ultimate, when I try to add multiple pics on the page (either drag&drop or Insert-photo album-add pics) I get error message of External Exception:

          System.Runtime.InteropServices.ExternalException: A generic error occurred in GDI+.
             at System.Drawing.Graphics.CheckErrorStatus(Int32 status)
             at System.Drawing.Graphics.DrawImage(Image image, Int32 x, Int32 y, Int32 width, Int32 height)
             at WindowsLive.Writer.PostEditor.PostHtmlEditing.ImageUtils.ApplyDropShadowOutside(Bitmap bitmap, Nullable`1 crop, Brush       backgroundBrush, Color shadowColor, Int32 shadowRatio, Int32 offset, Int32 borderTop, Int32 borderRight, Int32 borderBottom, Int32       borderLeft)
             at WindowsLive.Writer.PostEditor.PhotoAlbums.Inline.ScalableImage.DrawFinal(Graphics g)
             at WindowsLive.Writer.PostEditor.PhotoAlbums.Inline.ScalableInlineRep.ScaleAndRender(Color bgColor, Int32 targetWidth, List`1       simages)
             at WindowsLive.Writer.PostEditor.PhotoAlbums.Inline.WindowsLiveSpreadInlineRep.DrawCore(List`1 simages, Int32 targetWidth, Color bgColor)
             at WindowsLive.Writer.PostEditor.PhotoAlbums.Inline.WindowsLiveSpreadInlineRep.Draw(PhotoAlbumSmartContent content, Color bgColor)
             at WindowsLive.Writer.PostEditor.PhotoAlbums.PhotoAlbumSmartContent.UpdateDrawingIfNeeded(IPublishingContext       publishingContext)
             at WindowsLive.Writer.PostEditor.PhotoAlbums.PhotoAlbumContentSource.GenerateEditorHtml(ISmartContent content,       IPublishingContext publishingContext)
             at WindowsLive.Writer.PostEditor.ContentSources.ContentSourceManager.PerformInsertion(IContentSourceSite sourceSite,             ContentSourceInfo contentSource)


    On my laptop with Windows 7 7077, I can add those pics but if I try to publish, it says "There was an error with the photo album service. Please try again later."

     It's not any pictures, but certain jpeg pictures that I downloaded from web using "Save Picture As...." I'm not sure if I could attach those files on this.

    Thank you.
    Tuesday, June 2, 2009 11:56 PM

All replies

  • I have same problem! Please, Microsoft you must fix this basic application!
    Saturday, June 6, 2009 8:50 AM
  • Same problem here too.  Is there a solution yet?
    Thursday, August 6, 2009 5:11 AM
  • Can you send the pictures to us so we can take a look at them to see what is different about them?

    email: wlw-team@microsoft.com

    -Brandon Turner [MSFT]
    Sunday, August 16, 2009 10:20 PM
  • I was having the same problem. But when I re-saved the images using "Save for Web" in Photoshop, then it worked. I don't know enough about that to know how that differs, perhaps it is something to do with the size of the images.
    Sunday, September 13, 2009 6:23 PM