Is there a way to highlight text in Firefox, and send the highlighted text to Bing Translator? RRS feed

  • Question

  • I can highlight text in Firefox and send it to Google Translate.  It is sent by/to the query: http://translate.google.com/?q=  And the string causes the highlighted string to populate the query box in Google Translate.

    If I use a similar string for Bing Translate (http://www.bing.com/translator/?q=), it opens the Bing Translate webpage, but does *not* populate the search box with the highlighted text.  I can see the highlighted query string in the new URL, but it doesn't appear to be placed anywhere.

    Does anyone know the correct referral query for Bing Translate?

    • Edited by Squeeky Monday, August 31, 2015 11:34 PM
    Sunday, August 23, 2015 1:47 AM


All replies

  • Hi Squeeky,

    try this:


    Chris Wendt
    Microsoft Translator

    Sunday, August 23, 2015 8:22 PM
  • Thank you Chris.  The /?text= operator does populate the Translator search box (and it also populates the results box, it seems).

    Unfortunately, I can't test it because I can't get Translator to work.  If I enter a French word (either by highlighting/right mouse, or simply manually), it will give translations in French, also on the left side of Translator, but below the input box.  Even though I have selected English, the outlet box is populated with the French word, and there is nothing I can do to make it translate.

    I wondered whether this was a Firefox issue, but the same thing happens in IE and in Chrome.

    • Edited by Squeeky Monday, August 31, 2015 11:35 PM
    Sunday, August 30, 2015 6:07 AM
  • Chris, I see that you have marked your response as the "answer."  That may be (I hope so).  But why doesn't Bing Translator work at all?
    Monday, August 31, 2015 11:37 PM
  • Hi Squeeky,

    Can you elaborate a bit more about your issue please? It seems to be something else that what you initially asked.

    - The parameters seems to work as they should

    - But you are having issues with the bing.com/translator page

    Is this correct? Can you maybe use snip to show us what is happening and share the link on this forum? https://mix.office.com/snip


    Microsoft Translator team - www.microsoft.com/Translator

    Tuesday, September 1, 2015 12:51 AM
  • Hi Olivier,

    Yes, the issue is different.  By using Chris's string, I am now able to highlight text, and have the highlighted text sent to a new page (https://www.bing.com/translator), and the highlighted text will populate the left box (actually, it populates BOTH boxes, left and right, which seems a bit strange to me).

    But when I tried to translate something, I discovered that Bing Translator simply doesn't work.  It doesn't translate.  I don't mean that the translation is poor, I mean that it doesn't translate.

    Let me start with a very simple case.  Open https://www.bing.com/translator in IE (ver 11.0.9600.17959); Windows 7 Ultimate, x64.  In the left box, type "le petit chat" ("the little cat", in French; I didn't type the quotes). Translator auto-detects this as "English".  Not sure why.  It also populates the right box (which is set to output in English) with the same phrase.

    Then I change the language in the left box to French, and I leave the output language as English.  I press the translate button between the two boxes.  Absolutely nothing happens.  "Le petit chat" is still present in both boxes.  No matter what I do, I can't make it translate.  I experimented with the directional arrows above the translate button.  Toggling them does reverse the language labels in the two boxes, but the program still doesn't translate.

    I have also tried this with Firefox (41.0b5) and Chrome (44.0.2403.157).  It doesn't work in either of those, either.

    So, while I am thrilled to have Chris's string, I still don't have the full functionality I am looking for.

    Le sigh!

    • Edited by Squeeky Tuesday, September 1, 2015 5:28 AM
    Tuesday, September 1, 2015 5:27 AM
  • Hi Squeeky,

    So I went to bing.com/translator.

    I typed "le petit chat" and the page auto-detected French and translated it correctly: see the screen capture below

    I'm really sorry but what I see is the expected behavior and I can't reproduce yours. Any chance you could try on another machine maybe? No idea what this could be coming from.

    Microsoft Translator team - www.microsoft.com/Translator

    Tuesday, September 1, 2015 5:34 AM
  • Hi Olivier,

    Thank you for your test.

    I tried using Translator with 3 different devices, all attached to the same router.  My initial report was for a desktop system.  A laptop, also on Windows 7 (Home), had the exact same results.  Finally, I tried the Firefox app over a Samsung Galaxy S4 (running KitKat 4.4.2), and Translator worked there as designed.  This means that I can probably rule out the internet connection (and ISP) as well as the router as the source of the problem.

    I also used VPN to try Translator on a machine in a different state, which is running XP.  Works fine there, as well.

    Back to the two local machines that don't work.  I disabled the Windows firewall, but that didn't make a difference.  Both machines are using Avira anti-virus.  I disabled that too, but that didn't make a difference.

    When I click on the "Translate" button, there is a quick flash of a throbber immediately below it, and the URL bar shows that api.microsofttranslator.com is being contacted.  But clearly there is no connection between the web page and the MS servers.

    Any ideas as to what else I can look at?  I see Javascript.  Does it also use Java?  As I mentioned before, I have the same result in IE, FF and Chrome, so it must be an OS issue.

    Many thanks.

    • Edited by Squeeky Tuesday, September 1, 2015 10:18 PM
    Tuesday, September 1, 2015 10:17 PM
  • Hi Squeeky,

    From what you are telling me it looks like it's an IP address issue. We have been having issues since June with some IP addresses abusing the service. Maybe you randomly got assigned one of them when you ISP renewed your lease. Can you try releasing it from your router and see if you can get another one (I assume from your phone you were on 3G/4G not your wifi so on another IP).

    BTW, we created companion apps for the Apple and Android watches. They work also really well stand-alone (though have so far limited functionalities) too. There is also a Windows 8.1/10 app you can use on you Windows machine. You can find them all at www.microsofttranslator.com/apps


    Microsoft Translator team - www.microsoft.com/Translator

    Wednesday, September 2, 2015 1:59 AM
  • Hi Olivier,

    My phone was tested using WiFi, not 3G/4G (it has a French SIM in it; no roaming; it was in airplane mode with WiFi turned on, so I couldn't possibly have been using 3G/4G by mistake).

    Nevertheless, I rebooted my DSL modem, which gave me a new IP address (AT&T).  Sadly, that didn't solve my problem.

    I liked the IP address theory. But for the phone, it fits my symptoms well.

    I looked at your "apps" link. None of them fits my needs. However, I use OneNote 2013 (heavily) and hadn't realized that it contained translation capabilities. It makes sense that it does; it's part of Office; I just hadn't thought about it.  So I tried to translate "musée" using OneNote.  Didn't work (as in the browsers, it couldn't auto-identify the word as French). 

    Manually changing the input language to French didn't help.

    I looked at my "hosts" file to see whether there have been changes there, but it is stock (no entries at all; only the samples, all of which are commented out).

    Back to the Translator browser page, for additional comments.  The e-mail and "search with Bing" buttons work, but the "voice" buttons do not (neither in the left or the right boxes; there is a brief appearance of a throbber, and then the button returns; no audio).

    • Edited by Squeeky Wednesday, September 2, 2015 5:51 AM
    Wednesday, September 2, 2015 5:21 AM
  • Hi Olivier,

    I have an update.

    I told you that I could access Bing Translator successfully with my phone (using WiFi and Firefox). This is true, *provided* I access the *mobile* version of Bing Translator.  However, there is a link at the bottom of the mobile version for the "Desktop Version" and, when I switch to that, I get exactly the same results that I experience on my desktop and laptop systems; it doesn't work.

    I was concerned that I might have an OS problem (Win7), but since I have now replicated the issue on 2 Win7 machines, and *also* on an Android phone (using the Bing Translator desktop version), it is either a scripting problem in the desktop version, or an IP address that is blocked (which is somehow evoked by the desktop version, but not the mobile version).

    In any event, the results now indicate that it is unlikely to be a configuration problem at my end (and is therefore nothing I can fix).

    I hope this will assist you in diagnosing my issue. 

    • Edited by Squeeky Wednesday, September 2, 2015 9:46 PM
    Wednesday, September 2, 2015 7:46 PM
  • Hi Olivier,

    This is the Thursday update.

    I believe I have determined why Bing Translator doesn't work.  I have HotSpot Shield installed on my laptop.  If I turn on HotSpot Shield, thereby routing all of my traffic through a different IP address, then Bing Translator works fine.  If I disable it, then Bing Translator no longer works.

    So, yes, Microsoft has blocked my IP address (or the range of IP addresses that I have access to).  I'm using AT&T DSL.

    How can we get this fixed?

    p.s. It appears that the mobile version of Bing Translator is *not* blocked, even when going through the same router (and using the same IP address) to AT&T California.  Not sure why.  Apparently, MS can block the desktop app, while leaving the mobile app untouched.

    Thursday, September 3, 2015 5:15 PM
  • Hi Squeeky,

    Can you please contact us privately on www.microsofttranslator.com/contact (indicate that this is for Olivier) with your IP address. we'll then be able to tell you if this was the issue (we'd rather not have you put your address on a public forum :-)).

    As far as Mobile vs. Desktop it's normal. We can explain by email too.


    Microsoft Translator team - www.microsoft.com/Translator

    Thursday, September 3, 2015 10:28 PM
  • Hi Olivier,

    I tried to use www.microsofttranslator.com/contact (3x), and received the message "An unknown error occurred while processing your request. This is most likely due to a connection failure. Please try again."

    Then there were error codes (1 code for each attempt).




    There are obviously serious communications issues at the moment between me and Microsoft.  Can you PM my profile with your e-mail address?


    [Update: I finally got it to go through, after enabling IPv6.  Not sure if that made the difference, or if it was just a coincidence.]

    • Edited by Squeeky Friday, September 4, 2015 12:34 AM
    Friday, September 4, 2015 12:24 AM
  • Glad it worked. Quite odd though. We can continue to investigate if you want though.

    What do you mean by "PM my profile"?


    Microsoft Translator team - www.microsoft.com/Translator

    Friday, September 4, 2015 1:05 AM
  • By "it worked", it means I was able to send the contact form without an error message.  It *doesn't* mean that I succeeded in getting Translator to work (except as outlined above).

    "PM my profile" means "private message" a link in my profile, but I just checked and found that functionality doesn't exist (because I haven't supplied any links).  Therefore, I hope the info on the contact form will find its way to you.

    Friday, September 4, 2015 1:13 AM