locked
Cannot Create New Organization RRS feed

  • Question

  • I am adding a new organization... everything goes fine. Then when it's finished the status says 'pending' instead of 'enabled'. When I refresh the organization is gone...
    Anyone has an idea why this is behaving the way it is?

    It also says this after the new organization is "created":

    Microsoft.Crm.CrmException: Create new Organization
    (Name=.... Id...) failed with Exception:
    System.Reflection.TargetinvocationException.Exception

    • Edited by ThunderSon Monday, May 11, 2009 10:34 AM
    Monday, May 11, 2009 9:31 AM

Answers

  • When SQL Server 2008 was initially released, there was a problem creating organizations with sQL 2008; however, this has been resolved with subsequent rollups.  If you have rollup 3+ installed, it should work.

    • Marked as answer by Jim Glass Jr Monday, July 27, 2009 9:31 PM
    Monday, July 27, 2009 8:37 PM
    Moderator

All replies

  • Are you having these errors when creating a new blank organization, or while importing a database to create an organization?

    run a trace while creating the organization using the CRM diagnostic tool:
    http://blogs.msdn.com/benlec/archive/2008/03/04/crmdiagtool4-for-microsoft-crm-4-0-has-been-released.aspx

    Then you should be able to find a more detailed error as to why it is failing.

    Are you running SQL 2008?  There was initially a problem creating new organizations while running SQL 2008, this has been fixed with the rollups
    .

    If your problem is related to importing an organization:

    What update rollup are you running?  I have seen some problems creating or importing prior to rollup 3 or 4.   in the case where you have deleted a workflow rule that referenced an entity that had been deleted.

    One other thing that you can do that may make it go better is to delete as much out of tables like asynchronousbase, duplicaterecordbase as you can--since the import goes through every record in the database, the more unneccessary records that you can get rid of, the better.

    If you are importing to an environment on the same AD as the source environment, use the "keep existing users" option rather than mapping or auto-mapping.  It will go faster.

    Monday, May 11, 2009 11:18 AM
    Moderator
  • It is for creating a new organization. It still worked a few days ago... so it's a very recent error :(

    I tried to create an organization again now to see what happens and this time the organization was not pending anymore but disabled.

    When I enabled this message shows up:

    MMC has detected an error in a snap-in and will unload it

    - Report this error to MS, then shut down MMC
    -Unload the snap-in and continue running

    Does this have to do with the problem?
    Monday, May 11, 2009 11:53 AM
  • This is the log file error exception:

    05:32:14|  Error| Create new Organization (Name=Practice, Id=5074065a-273e-de11-b7dc-0003ffd0167c) failed with Exception:
    System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.DirectoryServices.DirectoryServicesCOMException (0x800700B7): Cannot create a file when that file already exists. (Exception from HRESULT: 0x800700B7)
     
    Monday, May 11, 2009 12:35 PM
  • I have exactly the same error.

    Have you resolved your problem ?

    Thanks.

    Lionel.

    Wednesday, June 24, 2009 10:51 AM
  • I have not resolved the problem... what I did is backuped my databases and restored them on a new vpc...

    Not the best solution probably but it worked and i was tired of looking for a solution. Another guy that knows a lot about SQL server looked for me (since it's a problem somewhere there) and he coudln't really find a solution immidiately too...
    Wednesday, June 24, 2009 12:01 PM
  • Ok thanks for your feedback.

    I have the same problem on the new VPC available on MS site. This VPC is based on windows server and SQL Server 2008.

    I tried and successfully create a new organization on a previous VPC with windows server 2003 and SQL server 2005 !!!


    Wednesday, June 24, 2009 7:38 PM
  • Hi,

    Try to repair the CRM installation using the CRM DVD. I think that'll solve the issue.
    Best Regards,
    Gagandeep Singh
    http://mscrmnovice.blogspot.com
    Sunday, July 26, 2009 6:44 PM
  • Hi,

    Are you trying to create a organization with similar name which you had before ?


    Vilas http://www.mscrm-vilas.blogspot.com
    Sunday, July 26, 2009 9:10 PM
  • When SQL Server 2008 was initially released, there was a problem creating organizations with sQL 2008; however, this has been resolved with subsequent rollups.  If you have rollup 3+ installed, it should work.

    • Marked as answer by Jim Glass Jr Monday, July 27, 2009 9:31 PM
    Monday, July 27, 2009 8:37 PM
    Moderator
  • I had exactly the same error, for me the problem resulted from Sharepoint running on port 80 on the same machine as Dynamics CRM. I stopped all Sharepoint related websites and AppPools in IIS and voilá the error was gone.
    • Proposed as answer by mozzstar Monday, June 7, 2010 4:06 PM
    Tuesday, December 15, 2009 11:18 AM
  • moontear had the answer - I stopped Sharepoint site and app pool >> went back to deployment manager added the organization with no errors >> restarted the Sharepoint site and pool... all good.

    ( Also, to note I was on rollup 11... just in response to the rollups being the answer)
    Monday, June 7, 2010 4:09 PM