locked
WHS connection lost on all clients after a successful backup RRS feed

  • Question

  • I have been trouble shooting lost connection problems for about two weeks.  I finally did a WHS OS reinstall last night, but did not solve my problem.  WHS is killing its own network connection after backup of a client.  It doesn't seem to matter whether it is a manual backup or an automatic backup, and it doesn't seem to matter which client computer is being backed up.  The connection is lost to all client computers.  It's not my router, because I have reserved an IP address for the WHS machine and each of the client computers can still see one another on the network.  I can also still see the internet from the client computers.

    I can access the WHS machine via a directly connected monitor, keyboard and mouse after the connection is lost.  However, the WHS machine can no longer see the client machines (by going to Network Places and opening the workgroup that is common to the server and clients) or the internet.  I'm convinced that something needs to be changed within my network connection configuration to prevent the loss of connection after a client back-up, but I don't know what to change.  My network configuration is very standard.  As I've previously said, I just reinstalled the WHS OS last night and did not change any network settings.  I enabled web sites in the WHS console and all is well with the exception of a couple of errors associated with ports blocked by my ISP.  All necessary ports are forwarded within my router as prescribed and required for WHS.

    My WHS machine is a home build as follows:

    MSI K9N2G Neo FD mobo
    AMD Athlon X2 2.6 GHz CPU
    2 x 1 GB of DRAM
    1 x 500 GB Seagate HD
    2 x 1 TB Seagate HD's
    550 W Coolermaster eXtreme Power Plus PSU (w/ 2 x 16 A, 12V rails) Could a 16A rail be too small?

    My software and Add-Ins are as follows:

    Whiist
    Advanced Admin Console
    Disk Management
    Avast for WHS
    Diskeeper for WHS
    Lights Out
    hMailServer
    DynDNS IP updater

    All software and add ins are working well with the exception of the lost connection issue after backups.

    Please help.  I'm beyond frustrated.

    Thank you,
    Michael

    Saturday, February 21, 2009 5:25 PM

All replies

  • Onboard network cards sometimes are not that reliable. Did you install the latest drivers from the maker of the network chip?
    Other than that you could try a PCI network card, which brings real Windows Server 2003 drivers.
    Can you check the event log for any related error messages?
    Best greetings from Germany
    Olaf
    Saturday, February 21, 2009 7:05 PM
    Moderator
  • Olaf,

    Thank you so much for replying to my plea for help.  Yes, I am using the latest drivers for the onboard NIC.

    The event viewer showed no errors before the lost connection.  Backup is the last thing that shows up.  I went to the WHS logs and looked at the backup log.  The following is an excerpt:

    [2/21/2009 12:03:36 PM 1334] Backup set 11 for HOME-LAPTOP has finished.
    [2/21/2009 12:03:36 PM 1334] Session: ThreadMain end for 0026B7B0
    [2/21/2009 12:03:36 PM 1334] ReconnectableStream: Destroyed ServerReconnectableStream for {5A33F18C-6127-4DEF-A7E2-12AC98805834}
    [2/21/2009 12:03:36 PM 1334]  TLS::~TLS going away (first time)...
    [2/21/2009 12:03:36 PM 1334] Breaking TLS sesssion...

    The times are exactly when I lost connection.  WHS console says that the backup was completed for the client HOME-LAPTOP.

    I'm willing to run out and get a network card.  Will a PCI card still allow 1 Mbps connections?  Or, should it be a PCI-e card?

    Also, could it be a power issue?  I'm not crazy about the two 16 A rails with my PSU.  16 A seems light to me based upon my research.

    Thanks in advance for any help you can give me.

    Michael
    Saturday, February 21, 2009 7:26 PM
  • Olaf,

    I've been told in another forum that those lines from my WHS backup log are normal.  Can you recommend any other logs to look at to gather some clues?

    Saturday, February 21, 2009 7:37 PM
  • MDwyer said:

    I've been told in another forum that those lines from my WHS backup log are normal.  Can you recommend any other logs to look at to gather some clues?


    not really.
    I have seen the network connection going down on some Windows 2003 servers with IDE disks while copying a larger amount of data. This was usually on systems with IDE drives. In this case the Windows Explorer stuck more and more (kind of memory leak) - in such situation also the network connection has gone lost - but that was long ago. But so it must not always be the network interface. On another system uninstalling the Virus scanner fixed a connection loss all few days.

    If you try to access the server via the shortcut Shared folders on Server - does this still work? (Workgroups and network neighbourhood are not very reliable. Can the server reach itself via the mentioned shortcut, if you try this from a local logon?
    If the connection got lost, can you still ping the server by name and by IP address?

    You can try also, to put the following lines to a .reg file via notepad and import this into your servers registry and reboot (this fixed a loss of network connection on some servers in our company):

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager\Memory
    Management]
    "PagedPoolSize"=dword:ffffffff
    "PoolUsageMaximum"=dword:00000030


    If it would be an power issue, you would see other trouble (i.e. bluescreens or unexpected reboots).
    After that change reboot.
    Best greetings from Germany
    Olaf
    Saturday, February 21, 2009 8:10 PM
    Moderator
  • Olaf,

    When the connection is lost, I cannot access the WHS machine via any of the clients by any means; not by the shared folders, console nor RDP.  As I've said, the only way I can get into the server is to attach a monitor, keyboard and mouse.  When I get into the server, I cannot see any of the clients via network places, etc.  They are even grayed out in the console.

    I did not try pinging the server from a client or from within itself.

    I'll try your suggestion for the registry entry and let you know.  I'm holding off on going to get another NIC, but BestBuy is right around the corner, so I can get one rather quickly if I decide to do it.

    Thank you so much for trying to help.

    Michael

    Saturday, February 21, 2009 8:18 PM
  • Olaf,

    The registry entry did not work.  In fact, the connection was lost before the backup was complete (about 94%).  It has done that before, but most of the time it completes successfully before losing the connection.

    While the connection was down, I tried pinging the server from a client and it didn't work, but I could ping the router from the client.

    From within the server, I could ping itself, but I could not ping the router or a client.

    Any other suggestions?

    Thanks,
    Michael
    Saturday, February 21, 2009 8:44 PM
  • Olaf,

    I broke down and tried a different NIC (disabling the onboard NIC) and that solved the problem with the lost connection.

    However, in the course of re-installing the connector on one of my clients, I'm now seeing an error on the client PC.

    When the PC boots up I get a "Home Server Information Collector error".  I tried uninstalling and reinstalling the connector several times but the error won't go away.

    The Event Viewer on my client PC shows an application error as follows:

    Event Type: Error
    Event Source: Application Error
    Event Category: (100)
    Event ID: 1004
    Date:  2/22/2009
    Time:  8:22:59 PM
    User:  N/A
    Computer: HOME-DESKTOP-1
    Description:
    Faulting application ClientInfo.exe, version 6.0.1800.24, faulting module ClientInfo.exe, version 6.0.1800.24, fault address 0x00013bfd.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 41 70 70 6c 69 63 61 74   Applicat
    0008: 69 6f 6e 20 46 61 69 6c   ion Fail
    0010: 75 72 65 20 20 43 6c 69   ure  Cli
    0018: 65 6e 74 49 6e 66 6f 2e   entInfo.
    0020: 65 78 65 20 36 2e 30 2e   exe 6.0.
    0028: 31 38 30 30 2e 32 34 20   1800.24
    0030: 69 6e 20 43 6c 69 65 6e   in Clien
    0038: 74 49 6e 66 6f 2e 65 78   tInfo.ex
    0040: 65 20 36 2e 30 2e 31 38   e 6.0.18
    0048: 30 30 2e 32 34 20 61 74   00.24 at
    0050: 20 6f 66 66 73 65 74 20    offset
    0058: 30 30 30 31 33 62 66 64   00013bfd

    If I can solve this one, I will be in good shape.  I appreciate any help you can give me.

    Thanks,
    Michael

    Monday, February 23, 2009 6:04 PM