locked
Unable to restore system disk, WHS says it is UEFI - it is not! RRS feed

  • Question

  • Have WHS 2011 with all fixes auto installed and with KB2781272.  Trying to restore a WIN7 system disk on an older ASUS MB which is NOT UEFI, disk manager properties for the drive in question = MBR.  I have restored this system at least twice in the past. Only thing relatively new is a dual boot install of WIN10 on another drive.  Once the client restore loads and finds the drivers, when I select the WIN7 system disk for restore, WHS claims the drive is on a UEFI BIOS machine & calls for KB2781272.

    Looking at the WHS system, I do NOT see KB2781272 listed as installed.  However, I tried to install it again & the updater says it is already installed.

    Anybody else seeing this?

    THX,  Bill


    Bill

    Tuesday, April 21, 2015 7:45 PM

All replies

  • Hi Bill,

    Firstly, I recommend you to uninstall that KB in an elevated command prompt window:

    wusa.exe /uninstall /kb:2781272

    Then you can restart the server to see if you can install that KB.

    Best regards,

    Susie


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, April 22, 2015 9:41 AM
  • MBR does not mean it is not uEFI. an efi partition would.  Do you have like an F12 for boot options?  Does it list any uefi options in that menu?

    Grey

    Wednesday, April 22, 2015 1:29 PM
  • You might lose your/some backups if you uninstall the uEFI hotfix.  Unplug the drive with WIN 10 and see what happens

    Grey

    Wednesday, April 22, 2015 5:52 PM
  • Oops, didn't lose some, lost ALL the backups.  Same thing happened when I installed the UEFI Hotfix last summer.   The good news is that the original problem that prompted me to want to restore the WIN7 system is gone - apparently a bad fix for Office that was replaced last night.

    Given that all my client boxes are OK and I have no backups, I plan to re-install WHS & all the fixes including the UEFI Hotfix, then try things again.  

    Previously I removed the WIN10 drive from the BCD and re-wrote the MBR, that didn't make any difference, WHS still claimed the WIN7 box was UEFI & it is not.

    I'll post again after the rebuild, probably mid next week.

    THX!


    Bill

    Wednesday, April 22, 2015 6:29 PM
  • open diskmgmt.msc on your win 7 box and see if it has an efi partition.  And or look in your BIOS for any mention of uEFI or like I said press whatever key to get boot menu choices and see if uEFI is in there.  If you are restoring to the same hardware that it was backed up on, I would not expect any problems.

    Grey

    Wednesday, April 22, 2015 8:42 PM
  • Thanks Grey.  I have looked though this machine's BIOS - no EFI mentioned anywhere.  On the System's "C" disk using Disk Management Properties/Volumes, I see  Partition style "MBR".  All the disks, including the WIN10 disk are "MBR".  I looked at my other 3 WIN7 systems, all are MBR.  I looked at the tablet that I got last summer, it is "GPT". When I first added the tablet into the mix last summer is when I bumped into KB2881272 for the first time. After installing the KB then (which caused the loss of all the existing backups) the tablet was supported fine and the following backups on the WIN7 boxes were fine.  <o:p></o:p>

    Between last summer and now, I have restored  at least 2 of the WIN7 boxes more than once.  Now I am getting the UEFI error message when I try to restore this box.  <o:p></o:p>

    What I have done so far:  1) removed the WIN10 system from the BCD, same error.  2) removed the drive with WIN10, same error. 3) Noticed that KB2781272 was not listed in the installed fix list (used wmic qfe to create machine readable list and used "FIND", not there).   4) Tried to install KB2781272, installer says it is already installed,  5) Removed KB2781272, all backups are gone.  6) Held my breath... installed KB2781272, backups are back!  7) Tried restore of WIN7 system disk, same complaint from WHS.<o:p></o:p>

    Now if you haven't given up reading all this...  I looked at the nasty-gram again and realized I was misinterpreting it.  Here it is - the lousy English is Microsoft, not me:<o:p></o:p>

    Your backup is created on computer that contains UEFI-based system partition.   For restoring this computer, you need to boot into the UEFI-based system partition. Click NO so you can stop the restore and restart. If you click YES and continue, you must follow the instructions in the Knowledge Base article 2781272 to fix this issue.  <o:p></o:p>

    I had been clicking NO and terminating the restore.  Just for fun, I looked for "the instructions in the Knowledge Base article 2781272" - nothing came with the fix, nothing in the online documentation I found seems to mention anything like this...   So, I try again, get the message, and give it a YES.   The restore works just fine.<o:p></o:p>

    Now for more detective work...  Tried a different WIN7 desktop. Again, this machine has an MBR partition, no mention of EFI anywhere in the BIOS.  Restore gets the same nasty-gram, give it a YES and it restores fine.  I thought that possibly WIN10 did something to the original system, but no.. WIN10 has never been on the second machine.<o:p></o:p>

    So there are a few outstanding issues:   1) Why the UEFI message on machines without UEFI?  2) Why doesn’t KB2781272 show in the installed fixlist?  3) Where is the doc mentioned in the error message? And, the message is clear as mud.<o:p></o:p>

    And a wish:  I sure wish Microsoft would keep WHS alive.  I’ve been using WHS since it was first released.  I’m just a home user with cobbled together PCs, but given the “Oh *^%#! that I personally have done, and the disasters my kids managed to create, WHS has been a very valuable tool.<o:p></o:p>

    Thanks to all. Bill<o:p></o:p>


    Bill

    Friday, April 24, 2015 4:58 PM
  • are you using a CD/DVD to boot the box to run the restore?

    Grey

    Friday, April 24, 2015 5:36 PM
  • Hi Grey,   sure am

    Bill

    Friday, April 24, 2015 5:52 PM
  • You need to make a thumb drive like the KB says :)

    From the Dashboard>Computers>More Backup Task>Tools


    Grey


    • Edited by Still Grey Friday, April 24, 2015 5:57 PM
    • Proposed as answer by Still Grey Saturday, April 25, 2015 10:13 PM
    Friday, April 24, 2015 5:54 PM
  • Hi Grey,  do you mean this:  (From KB2781272)

    Issue 1

    During the restore operation on a UEFI-based client computer, if the original client restore CD is used without having this hotfix installed, the client may be unable to start in EFI mode because of a Windows Preinstallation Environment (Windows PE) issue. To work around this issue, create a USB key by using the Create Key wizard on the server that has this hotfix installed. Then, use the USB key when you restore the client.

    The machine is NOT UEFI....      but I'll give it a try.


    Bill

    Friday, April 24, 2015 7:23 PM
  • Hi again Grey,  Made the bootable thumb drive from the Server /w KB2781272.  Neither of my desktops will boot from USB.  I then tried my laptop...  first ensured that it issued the error message when initiating a restore using the WHS CD, it does and it is also not UFI.  Then I booted the thumb drive and it indeed performed the restore without error.

    Both the error message and the description in KB2781272 are very misleading, worse inaccurate.  

    Thanks for your effort, it is truly appreciated.  

    Regards,  Bill


    Bill

    Saturday, April 25, 2015 9:52 PM
  • The problem is that restore cd that came with the software is not aware of the uefi changes. I am just surprised the restore wizard pulls that error to present it.

    I am just the opposite here.  I would have a hard time finding a system to boot from DVD :)

    Suppose you need to try to make a bootable dvd with the files on the thumb drive.  I never seem to have much luck doing that for some reason.  But then I try freeware LOL

    Yes, we know error reporting is bad and very often misleading.

    Thank you for taking the time to follow this through and report back.  We do appreciate you.


    Grey

    Saturday, April 25, 2015 10:13 PM
  • I have a Dell Ultrabook without an Ethernet port. I tried a USB network adapter but couldn't get it to work without the drivers as they I couldn't load them via the restore wizard. However, I came across the following video that has helped. It shows how to perform a full client restore to a hard drive connected to another computer on the network. The trick is to have a wired connection to the server. Following the steps in the video, I got the UEFI-related error message but clicked Yes and it seems to moving along. I'll find out after the remaining 3 1/2 hours the wizard says it needs to complete the restore. Fingers crossed. After I restore my ultrabook, I'm on to restoring my daughter's ultrabook. FYI: I'm also glad to report if your computer has an SSD, there are SSD to USB adapters now where you can plug it into a USB port and it works great! Here's the one I bought: http://amzn.com/B00NING8K2

    http://connecteddigitalworld.com/2011/04/13/windows-home-server-2011-client-restore-wizard-video-edition/

    Friday, August 21, 2015 5:04 AM