none
How do I disable WFC on compute nodes using a node template?

    Question

  • Hi,

    I have a cluster with infiniband. Unhappily, the head node there isn´t the infiniband interface and my network topology is like number 3. Then I need to disable Windows firewall in compute nodes to run MPI application. I saw the article "Disable or Enable Windows Firewall on the Compute Nodes" (http://technet.microsoft.com/en-us/library/dd772588(WS.10).aspx) but it didn´t work. In my provision log I saw my command was executed.

    Time Message
    3/26/2010 8:56:51 AM Executing command netsh advfirewall set allprofiles state off as user cluster\administrator

    When the deploy finished I was going to check it. But it didn´t work  

    C:\Users\administrator.CLUSTER>netsh advfirewall show allprofiles state

    Domain Profile Settings:
    ----------------------------------------------------------------------
    State                                 ON

    Private Profile Settings:
    ----------------------------------------------------------------------
    State                                 ON

    Public Profile Settings:
    ----------------------------------------------------------------------
    State                                 ON
    Ok.

    What´s wrong?

    Best regards,

    Bino

     

    Friday, March 26, 2010 12:23 PM

Answers

  • Hey Bino

    Just to follow up Parmita's post, Giovanni Marchetti gives more info about using a 'fake' loopback adapter on the headnode to kid HPC Server into operating as you require on his blog here http://blogs.technet.com/gmarchetti/archive/2009/02/23/faking-networks.aspx You can then set your cluster to true Topology 3.

    I've used this technique in the past when running off a virtualised headnode (No InfiniBand driver support in 2008 Hyper-V). It works around the firewall management issue, but there are a couple of provisos, firstly the DHCP issue Giovanni mentions, and secondly the fact that you'll need to run up a subnet manager somewhere other than your headnode if your IB switch cannot act as one.

    Cheers

    Dan

    Thursday, May 20, 2010 9:18 AM

All replies

  • Some questions for you :

    So, when you try to run a mpi job it fails because firewall is blocking communication?

    how did you setup topology 3 on your cluster ( loopback adapter fro IB on the headnode?)

    you are running v2?

    thanks

    -parmita


    pm
    Friday, March 26, 2010 6:35 PM
    Moderator
  • Hi Parmita,

    Yes, my mpi job fails because firewall. I have to disable before of running my job.

    In my head node I use network topology number 1. Then I change the variable CCP_MPI_NETMASK to use my IB network.

    Regards,

    Bino

    Friday, March 26, 2010 6:54 PM
  • Hey Bino

    Just to follow up Parmita's post, Giovanni Marchetti gives more info about using a 'fake' loopback adapter on the headnode to kid HPC Server into operating as you require on his blog here http://blogs.technet.com/gmarchetti/archive/2009/02/23/faking-networks.aspx You can then set your cluster to true Topology 3.

    I've used this technique in the past when running off a virtualised headnode (No InfiniBand driver support in 2008 Hyper-V). It works around the firewall management issue, but there are a couple of provisos, firstly the DHCP issue Giovanni mentions, and secondly the fact that you'll need to run up a subnet manager somewhere other than your headnode if your IB switch cannot act as one.

    Cheers

    Dan

    Thursday, May 20, 2010 9:18 AM