none
Playing multiple cameras of same model not working - AFORGE Player RRS feed

  • Question

  • I can play with two cameras simultaneously using aforge player(one was PC webcam and another was a USB camera). Now when I'm trying with two cameras which is connected from a PCB, is not working (both camera are of same model). Camera which is connected to first player is only playing. Second player shows "connecting.." message only. Seems the issue was with same model of camera. . This might be a limitations of drivers/system. Can I resolve this? or can I reach in a summary what is the exact issue? When I'm running the same app in Windows 8 it is working. My lap is windows 10.

    private void StartCameras() { try { // create first video source videoSource1 = new VideoCaptureDevice(videoDevices[camera1Combo.SelectedIndex].MonikerString); videoSourcePlayer1.VideoSource = videoSource1; videoSource1.NewFrame += new AForge.Video.NewFrameEventHandler(Video1_NewFrame); videoSourcePlayer1.Start(); // create second video source if (camera2Combo.Enabled == true) { videoSource2 = new VideoCaptureDevice(videoDevices[camera2Combo.SelectedIndex].MonikerString);

    videoSourcePlayer2.VideoSource = videoSource2; videoSource2.NewFrame += new AForge.Video.NewFrameEventHandler(Video2_NewFrame); videoSourcePlayer2.Start(); } } catch(Exception ex) { string exx = ex.Message; } }



    Tuesday, February 26, 2019 3:57 AM

All replies

  • Hi NSDSZ,

    Thank you for posting here.

    In your code, is the class VideoCaptureDevice you use belongs to the third party product(AForge.Video.DirectShow.dll) or the Microsoft library(System.Windows.dll)?

    We are waiting for your update.

    Best regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, February 26, 2019 9:37 AM
  • Hi using Aforge library. AForge.Video.DirectShow.dll
    Tuesday, February 26, 2019 9:44 AM
  • Hi NSDSZ

    Thanks for feedback.

    According your post, your question is more relevant to the Aforge, please post in the following forum.

    http://www.aforgenet.com/forum/viewforum.php?f=2

    The Visual C# forum discuss and ask questions about the C# programming language, IDE, libraries, samples, and tools.

    Note: This response contains a reference to a third-party World Wide Web site. Microsoft is providing this information as a convenience to you.

    Microsoft does not control these sites and has not tested any software or information found on these sites; Therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there.

    There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.

    Best regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Wednesday, February 27, 2019 5:41 AM