locked
Can't permanently remove English (United States) language RRS feed

  • Question

  • I'm using English (New Zealand) as the default language on my WHS and associated computers.  The WHS keeps resetting its default language to English (United States) even though I've repeatedly removed this language both from the console and RDP.

    Every time I access the WHS by either method following a restart, I am faced with the language bar.  In the console, I can turn off the bar and remove the US language (following a prompt that US English is in use and will be removed following a restart/logoff), and this will persist until the next time the WHS is restarted.  This means that the next time I log into the console, the language bar is gone, and presumably NZ English is being used.  After restarting the WHS system and opening the console again, US English is back to being the default language.

    This is the same behavior I see when connecting to the WHS using RDP.  I can remove US English (following the same prompt), logoff from RDP, and immediately reconnect and find US English is again present and used as the default language.  Auuuugh!

    How can I get this language removed "permanently"?  I tire of seeing the language bar and I wish the OS would recognize that US and NZ English are not different enough to require bothering me with language selections.

    Thanks!
    Saturday, March 15, 2008 9:16 PM

Answers

All replies

  • Saturday, March 15, 2008 9:18 PM
  • T, I assume this is the part of that post to which you are referring:

     Tom Ziegmann wrote:

    You can shut off [the language bar] by logging in to the administrator desktop, and following the below steps.

     

    1. RDP to the Administrator Desktop

    2. Click on Start

    3. Click on Regional and Language Options

    4. Click the Languages tab

    5. Click on Details

    6. Click on Language Bar

    7. Uncheck "Show the Language Bar on desktop"



    No, this does not answer my question.  In my initial post here I described how I have done this exact process (and removed the US English language at the same time), disconnected my RDP session, reconnected using RDP, and still had US English used as the default language.  On the subsequent RDP the language bar is not visible.  However my issue is not with the language bar; it's with permanently removing US English as the default language.

    Can anyone help with this vexing problem, please?
    Sunday, March 16, 2008 2:57 AM
  • Have you tried changing the Region from within the Home Server Console?

    Sunday, March 16, 2008 7:34 AM
    Moderator
  • Hi Tom - my region as set in the console is already English (New Zealand).
    Sunday, March 16, 2008 9:06 AM
  • Exact same problem, with exact same steps taken in a vain attempt to fix.

    Region: English (Australia)
    Default Language: English [United States} after every re-start.

    Kelly42, I've come to the conclusion that MS hates the Anzacs
    Monday, March 17, 2008 6:01 AM
  • Hey i have been trying for ages to get rid of the stupid americain language from my computer! can someone tell me a registry code or file to delete so it can't keep installing itself again on restart? I speak Australian and speel Australian why the * would I want the yanks spastic way of spelling things on my laptop GRRR! I am this close to formatting it to lynix! Or buying a Mac
    Monday, March 24, 2008 5:14 AM
  • Same issue here also in Australia.

     

    following the steps does remove the language bar, but it returns on reboot.

     

    Peter.

    Monday, March 24, 2008 7:09 AM
  • A bug has been filed about this issue.

    Tuesday, March 25, 2008 12:47 PM
  •  

    Hi everyone,

     

    For those of you who are trying to remove the English(United States) keyboard, can you please try the following:

     

    0. Make sure there are no other applications such as the home server console running currently.  Then Remote Desktop to the home server.

    1. Open the Regional and Language Options Control Panel Applet

    2. Confirm that only English (United States) and English (Australia) or English (New Zealand) keyboards are installed.

    3. Set the default input language to English (New Zealand) or English (Australia)

    4. Close Regional and Language Options Control Panel Applet

    5. Open Regional and Language options Control panel applet

    6. remove English (United States) keyboard

    7. Close Regional Options Control Panel Applet

    8. Open Regional and Language options Control Panel Applet

    9. Double check and make sure English (United States) keyboard continues to be absent from the list.

    10. reboot.

     

    I think this should get rid of the keyboard for you.  The reason being that if there is one app that currently still uses the English (United States) keyboard, you wouldn't be able to remove it.  So that's why I am asking for multiple opening / closing of the regional and langauge options applet.

     

    Please let me know if this works,

    thanks,

     

     

    Ken

    • Proposed as answer by Ballscrew bob Monday, July 12, 2010 3:48 AM
    Wednesday, March 26, 2008 1:18 AM
  • Hi Ken - thanks for your reply.

     

    I followed all of your steps exactly, but I'd like to add:

    11. Reconnect to the home server using RDP.  Find that while the Language Bar is absent, the English (United States) language is back within the Regional and Language Options applet!  Sigh and admit defeat.

     

    Thanks for your suggestion.  In addition to trying your steps as written, I had also previously performed them with a reboot between steps 7 and 8.  This didn't help either.

     

    I'm glad to hear this bug has been filed, and I hope a fix is forthcoming.

     

    Wednesday, March 26, 2008 5:40 AM
  • I have the same problem, and it never fixed. I remove English language about 100 to see it appear again when I restart.
    Tuesday, September 16, 2008 4:56 AM
  • Is there a bug fix for this yet?
    Saturday, February 21, 2009 9:18 PM
  • Has there been any progress on this issue?  I have a machine that I'm supposed to deliver to some French speaking people and I don't think they want to have US English as the default language. :(
    • Proposed as answer by Don Crabtree Tuesday, April 5, 2011 12:27 PM
    Thursday, May 7, 2009 2:28 PM
  • Has there been any progress on this issue?  I have a machine that I'm supposed to deliver to some French speaking people and I don't think they want to have US English as the default language. :(
    You could always install the French localized version of Windows Home Server. It's probably not available in the US, however...
    I'm not on the WHS team, I just post a lot. :)
    Thursday, May 7, 2009 5:17 PM
    Moderator
  • Yours truly was the ANSWER.

    Thank you Ken

    So much better than the "I filed a bug report and that is the answer"

    This worked to change a US to CANADA and a US to UK and the console opens quicker too.


    Do unto others before they get chance to screw you !
    Monday, July 12, 2010 3:48 AM
  • I wasted a lot of time trying to get the english input language removed from my WHS and change it to danish. I tried Kens solution but it didn't solve my issue. English was still the default.

    I then went into the regional and language settings on my client pc (a Windows 7 machine). Inside the settings on my client danish was the main language but english was also present. I removed english and tried logging into my WHS. Solved my problem since the language settings is determined by the client.

    Monday, April 4, 2011 10:08 PM
  • For all those trying to help here, I would like to say that Tom is right as far as he goes, but the problem is far deeper.

    UK English is also an option, but my computer refuses to understand that I DO NOT WANT ANY AMERICAN LANGUAGE on my computer

    Most of the software was written by Americans, who never experience the frustration of this many-times-daily problem.

    Kind regards

    David

    Tuesday, February 18, 2014 2:27 AM
  • I have the same problem, but I found out when I disable COM+ Event system service. US layout keyboard won't appear after restart. I don't really know how important that service is, but it works for me.
    • Proposed as answer by Fixer Jim Thursday, May 15, 2014 8:06 PM
    • Unproposed as answer by Fixer Jim Thursday, May 15, 2014 8:17 PM
    Sunday, April 27, 2014 3:58 PM
  • I have English UK set as my only location in regional settings.

    I also have the same problem of it defaulting to English (United States)

    It's been driving me a little nutty of late.

    I set the language bar to be visible  and noticed that whenever I clicked on a web page the default language would change from English (United Kingdom) over to English (United States).

    Every time I needed to type a £ sign I got a # sign instead.

    So in Internet Explorer I went to Tools, Internet Options, Programs and changed by default HTML editor from Microsoft Word to Notepad.

    That seems to have stopped it for the time being.

    I suspect its because the default setting in Word HTML editing is set to English US (because HTML is written in US English) but I've not had time to follow up my suspicions....

    • Proposed as answer by Fixer Jim Thursday, May 15, 2014 8:17 PM
    Thursday, May 15, 2014 8:15 PM