locked
MPI Cluster debugger in MSVS 2010 SP 1: mpishim.exe location issue RRS feed

  • Question

  • I am trying to debug an open MPI application in Visual Studio 2010 SP1 using the MPI Cluster debugger. When I launch the application, I get the following error message:

    MPISHIM: Command line incomplete.  USAGE: mpishim100.exe PortNumber ComputerName

    On inspection of the batch file mpishim.bat, which is automatically generated in the built tree by Visual Studio, I can see that this error message is caused by wrong use of quotes. The batch file contains the following command:

    "E:\Apps64\openmpi-1.6\bin\mpiexec.exe" -n 1 -wdir "E:\Users\UserName\Build\mpi-examples\src\Debug\UserName\matvec_row" -np 2 "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Remote Debugger\x64\mpishim100.exe" 61863 127.0.0.1

    I suspect the last arguments should be within the quotation marks. There is no way for me to fix this, because VS generates the file from scratch every time I start debugging. I have tried to change the mpishim.exe location parameter within the VS project options, hoping that putting it in a path not containing spaces would fix the problem. However, VS seems to ignore the non-default value I enter there, and keeps on referring to the standard location within the VS install directory.


    Monday, September 17, 2012 9:14 AM

All replies

  • Hi chripton,

    Do you mean that you are debugging a remote Cluster Application? Did it work well before? Whether other apps have the same issue?

    MPISHIM: Command line incomplete. USAGE: mpishim100.exe PortNumber ComputerName

    Like this thread “Debugging MPI app in VS2010”, it seems that there is a mistake in the command line.

    In addition, we would check the prerequisites for MPI Debugging. See “How to: Debug a Remote Cluster Application

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, September 18, 2012 7:53 AM
  • Dear Jack,

    thank you for your reply.

    I am debugging a local 'open MPI' programme. To be sure, I have launched the remote debugger. Nothing changed.

    I have also found the post you are referring to. I think I am experiencing exactly the same problem. Regrettably, no solutions are being proposed in that post.

    I am able to debug MPI programmes on another machine that has Visual Studio 2008 installed.

    I went through the steps in the Remote Debugging Howto you are referring to.

    Looking at the contents of the generated file mpishim.bat, I am pretty sure that is where the problem lies. Again, I suspect that the problem is how the windows command prompt deals with spaces and quotes. In Visual Studio 2008, I was able to refer to a copy of mpishim.exe that I copied to a path not containing spaces. Visual Studio 2010, however, seems to ignore the content of the 'mpishim.exe location' setting. I keeps on referring to the original location in the MSVS2010 install directory.

    Kind Regards,

    Tuesday, September 18, 2012 9:42 AM
  • Hi chripton,

    Sorry for my delay.

    I suspect that the problem is how the windows command prompt deals with spaces and quotes.

    I doubt that it is related to your command line. Actually, I didn’t debug this kind of app before, since it is related to debug the specific app, to help you resolve this issue, I suggest you post this issue in the Windows HPC Server Message Passing Interface (MPI) forum for better support. Thanks for your understanding.

    Sincerely,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, September 20, 2012 8:14 AM