locked
ERROR : Method not found: 'Void Microsoft.Synchronization.Data.Server.SqlSyncAdapterBuilder.set_ChangeTrackingType(Microsoft.Synchronization.Data.Server.ChangeTrackingType)'. RRS feed

  • Question

  • Hi,

    I configured WCF Server in the new system.  I am getting below error when i am syncing..

    <s:Fault xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><faultcode xmlns:a="a:InternalServiceFaulthttp://schemas.microsoft.com/net/2005/12/windowscommunicationfoundation/dispatcher">a:InternalServiceFault</faultcode><faultstring xml:lang="en-IN">Method not found: 'Void Microsoft.Synchronization.Data.Server.SqlSyncAdapterBuilder.set_ChangeTrackingType(Microsoft.Synchronization.Data.Server.ChangeTrackingType)'.</faultstring><detail><ExceptionDetail xmlns="http://schemas.datacontract.org/2004/07/System.ServiceModel" xmlns:i="http://www.w3.org/2001/XMLSchema-instance"><HelpLink i:nil="true" /><InnerException i:nil="true" /><Message>Method not found: 'Void Microsoft.Synchronization.Data.Server.SqlSyncAdapterBuilder.set_ChangeTrackingType(Microsoft.Synchronization.Data.Server.ChangeTrackingType)'.</Message><StackTrace>   at PNG.Subsystem.Components.CustomServerSyncProvider.GetTransactionSyncAdapters()
       at PNG.Subsystem.Components.CustomServerSyncProvider.Synchronize(SyncType syncType)
       at PNG.Subsystem.Components.CustomServerSyncProvider..ctor(SyncType syncType)
       at PNG.Subsystem.WCFSyncWebService.TransactionSyncService..ctor()
       at CreatePNG.Subsystem.WCFSyncWebService.TransactionSyncService()
       at System.ServiceModel.Dispatcher.InstanceBehavior.GetInstance(InstanceContext instanceContext, Message request)
       at System.ServiceModel.InstanceContext.GetServiceInstance(Message message)
       at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc&amp; rpc)
       at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage4(MessageRpc&amp; rpc)
       at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)</StackTrace><Type>System.MissingMethodException</Type></ExceptionDetail></detail></s:Fault>



    • Edited by mathi.nb Tuesday, September 13, 2011 2:48 PM
    Tuesday, September 13, 2011 11:32 AM

Answers

  •  

    Thanks for response...

    Solved the issue by adding the required assembles...

    I thought, No need to install framework..

    After installed the framework. its works fine.

    Is it possible with out installing framework?

     



    • Marked as answer by mathi.nb Wednesday, September 14, 2011 1:08 PM
    • Edited by mathi.nb Tuesday, January 10, 2012 6:43 AM
    Wednesday, September 14, 2011 12:56 PM

All replies

  • are you able to hit the service from a browser at all?

    does your client have an updated proxy?

    Wednesday, September 14, 2011 1:21 AM
  •  

    Thanks for response

    Yes! i can view the service from browser.

    There is no change in proxy...

    It's working in my box...I configured in new box... there it's not working.

     

    Wednesday, September 14, 2011 4:05 AM
  • just a guess.

    what was the target platform when you built the WCF service? (x86? 64?) does it match the platform where you deployed the WCF service? 

    Wednesday, September 14, 2011 5:52 AM
  •  

    Thanks for response...

    Solved the issue by adding the required assembles...

    I thought, No need to install framework..

    After installed the framework. its works fine.

    Is it possible with out installing framework?

     



    • Marked as answer by mathi.nb Wednesday, September 14, 2011 1:08 PM
    • Edited by mathi.nb Tuesday, January 10, 2012 6:43 AM
    Wednesday, September 14, 2011 12:56 PM