locked
Reports Issue RRS feed

  • Question

  • Hi All,

    So I have CRM 4.0, Rollup 6, SQL 2008, IIS, SSRS and CRM Report Connector all installed.

    Still reports are not working

    The following error is poping every time
    Web service request GetDataSourceContents to Report Server http://peregrin/ReportServer/ReportService2005.asmx failed with SoapException. Error: The item '/Exigy_MSCRM/4.0/MSCRM_DataSource' cannot be found.
    C:\inetpub\wwwroot\ 
       PEREGRIN 
        
       3244 
       w3wp.exe 
       NT AUTHORITY\NETWORK SERVICE 
       CrmReportingException 
       The item '/Exigy_MSCRM/4.0/MSCRM_DataSource' cannot be found. 
       http://peregrin/Exigy/CRMReports/rsviewer/reportviewer.aspx 
       /Exigy/CRMReports/rsviewer/reportviewer.aspx 
    
    What should I do please,

    Please i need help

    Regards,




    Tuesday, February 2, 2010 8:42 AM

Answers

  • Can you confirm that Report Server is installed in Native Mode and not SharePoint Integrated mode
    Wednesday, February 3, 2010 5:36 PM

All replies

  • try adding the datasource from within the admin module of SSRS

    http;//reportserver/reports
    Tiaan van Niekerk http://crmdelacreme.blogspot.com Skype:tiaan.van.niekerk1
    Tuesday, February 2, 2010 9:07 AM
  • Can you guide me how please??
    Tuesday, February 2, 2010 9:12 AM
  • When opening

    http://servername/reports what should i see?

    Should I see CRM default reports? I am asking cause nothing is showing


    When I open 

    http://peregrin/ReportServer all i see is

    peregrin/ReportServer - /



    Microsoft SQL Server Reporting Services Version 10.0.2531.0

    Should I see something else??
    Tuesday, February 2, 2010 9:25 AM
  • It looks that you don't have privilidges to Report Server. In http://peregrin/reports you should see MS CRM reports. Did you logon as SQL admin ?

    Here you have instruction how you can change DataSource: http://msdn.microsoft.com/en-us/library/ms155882(SQL.90).aspx


    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    Tuesday, February 2, 2010 10:38 AM
  • Can you confirm that Report Server is installed in Native Mode and not SharePoint Integrated mode
    Wednesday, February 3, 2010 5:36 PM