locked
Slow File Tranfers (One-way) RRS feed

  • Question

  • I thought maybe I was having a hiccup, so I restarted both client and server before posting here, but am having the same results.

    For files on my client that I want to transfer to a server share, if I copy and paste it to the server share via the client's desktop (Win7 x64), the file transfer is VERY slow (like, 1-2Kb/sec) and it takes forever to start and cancel. It doesn't matter how I attempt to copy/paste the file (either drag via the homegroup, libraries, or directly via the network). I get the same results if I attempt to move it vice copy/paste it.

    However, if I "right-click" copy the file only on my client, and then access my server via the Remote Desktop Connection, then "right-click" paste it to the share (after drilling down to it via the server's explorer), the thing copies over just fine at anywhere from 40-60Mb/sec.

    I have no idea why this is happening. Both the server and clients are relatively new hardware (all Sandy Bridge level) and software (both installed within last week). I did backup the client using the backup wizard and this completed in what I would consider a reasonable time.

    Further, it only seems to happen when I transfer from the client to the server. I just transferred my SC2 backup (folder full of several different folder types, around 6GB) from my server to the client using drag/drop and it went over just fine. Tried to copy it back, though...same results.

    Also, using another computer in my network, I can transfer files both ways just fine, obviously leading me to conclude that it is a client problem only, and this one specifically. Tried to uninstall and reinstall the Connect software and delete and redo my user account, all to no avail. Also, found a post somewhere that talked about homegroups screwing it up. Exited the homegroup on both the client and server, restarting both, no change.

    So, for now, I know how to do the work around, but something is obviously not right. Any thoughts?
    Friday, June 24, 2011 3:22 PM

Answers

  • Turns out its my onboard NIC. I removed the ethernet cable and used a wireless usb dongle I had laying around. Good speeds in any direction by any method. So, FYI. I haven't figured out how to fix it (yet), but its probably a driver  issue.

     

    It is an MSI Z68MA-ED55 (B3) micro-ATX mobo with a Realtek 8111E onboard NIC.

     

    If anyone has had similar problems and have a fix, I'd appreciate it, but this is now not the right topic for this forum.

    • Marked as answer by kariya21 Sunday, June 26, 2011 7:16 PM
    Sunday, June 26, 2011 5:30 PM