none
WHS found, but access very slow, connector refuses to actually talk to it RRS feed

  • Question

  • Hi,
      I've been having some connection problems on a system I built myself (this is the first time I've built a WHS - did it this weekend, so little experience).

    - discovery.exe does find my WHS - but it is _really_ slow. Connector software correctly installs, and when I log in from the WHS console I can see the client machine(s) in the backup list.
    - Trying to log in via the connector software always fails with an error -- can't find windows home server.

      Searching through these forums (thanks) lead to a solution - the problemw as my DSL modem. I use Qwest. No matter what I DNS lookup ("bogus", "server", "myleftfoot") it always comes back with my DSL modem's external address. Internally, of course, this points to nothing. "nslookup" tells me that the DNS server is always my DSL modem, not the external addresses one (might!?) expect. Network config lists my DSL modem as DNS #1 and a "good" external address as DNS #2. I have to follow up with Qwest about this.

      I added my server name to the "hosts" file in c:\windows\system32\drivers\etc, and right away everything started working correctly.

      Which leads me to my question: seriously!? :) Did I really have to do something like that (or switch DNS providers as others on the forum have suggested) to get this to work correctly? Or have I missed another configuration option. But I had no other option other than faking out DNS (or setting up and running my own - one more thing to deal with that I'd like to avoid if possible!). Given how fragile and varied people's home network solutions are I woudl have expected WHS to be fairly clever about discovery: if it could find itself once, it shouldn't suddenly stop being able to find itself...

      Cheers,
        Gordon.

    Gordon
    Tuesday, November 11, 2008 6:00 AM

Answers

  • Hi Gordon,
    is it a DSL modem or a router?
    That the internal address of the router is the DNS server, is correct.
    So it can divide name resolution to the internal and external part. And only queries for resolving external domain names are forwarded from the router to the DNS server of your provider. Some routers are setting DNS suffixes, which may cause name resolution to try finding your internal devices in the Internet. The same happens, if you add a suffix manually.

    While adding the server data to the hosts is a valid workaround (which I recommend from time to time myself), you should keep in mind, that the IP address of the server can change (if the router gets a power outage or changed or the server is down for a longer time) and then troubleshooting requires you to remember that changed file.

    I have experienced recently slowness from one of my clients. The Broadcomm Gigabit adapter on board worked, but made the things very, very slow since some weeks causing file copies to take minutes instead of seconds, backups took hours. After changing to the Realtek adapter, which was also onboard of my Asus mainboard, the speed was normal again (same cable, same router, same DHCP server).
    So slowness may also have to do with the home network components.

    Best greetings from Germany
    Olaf
    • Marked as answer by GordonTWatts Tuesday, November 11, 2008 6:14 PM
    Tuesday, November 11, 2008 9:14 AM
    Moderator
  • Gordon,

    In general, all your computers should be looking at the internal IP address of whatever provides your DHCP range. For example, if your router is 192.168.1.1, then your computers should be looking at that address for DNS services, running ipconfig /all at a Command prompt should result in something like this:

       Host Name . . . . . . . . . . . . : Test-PC
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Mixed
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : Home

    Wireless LAN adapter Wireless Network Connection:

       Connection-specific DNS Suffix  . : Home
       Description . . . . . . . . . . . : Intel(R) Wireless WiFi Link 4965AGN
       Physical Address. . . . . . . . . : 00-13-E8-98-06-AD
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::a483:694e:a24d:7b67%9(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.120(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : 29 October 2008 03:08:01
       Lease Expires . . . . . . . . . . : 19 December 2144 00:10:38
       Default Gateway . . . . . . . . . : 192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DNS Servers . . . . . . . . . . . : 192.168.1.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    The items to note, are the last four entries.

    The usage of a 'host' file will achieve a workaround, but isn't really a longterm solution as it could well lead to problems when you come to do a Client restore, or you add another Client and forget the hosts settings!

    Colin





    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    • Marked as answer by GordonTWatts Tuesday, November 11, 2008 6:14 PM
    Tuesday, November 11, 2008 5:46 PM
    Moderator

All replies

  • Hi Gordon,
    is it a DSL modem or a router?
    That the internal address of the router is the DNS server, is correct.
    So it can divide name resolution to the internal and external part. And only queries for resolving external domain names are forwarded from the router to the DNS server of your provider. Some routers are setting DNS suffixes, which may cause name resolution to try finding your internal devices in the Internet. The same happens, if you add a suffix manually.

    While adding the server data to the hosts is a valid workaround (which I recommend from time to time myself), you should keep in mind, that the IP address of the server can change (if the router gets a power outage or changed or the server is down for a longer time) and then troubleshooting requires you to remember that changed file.

    I have experienced recently slowness from one of my clients. The Broadcomm Gigabit adapter on board worked, but made the things very, very slow since some weeks causing file copies to take minutes instead of seconds, backups took hours. After changing to the Realtek adapter, which was also onboard of my Asus mainboard, the speed was normal again (same cable, same router, same DHCP server).
    So slowness may also have to do with the home network components.

    Best greetings from Germany
    Olaf
    • Marked as answer by GordonTWatts Tuesday, November 11, 2008 6:14 PM
    Tuesday, November 11, 2008 9:14 AM
    Moderator
  • Gordon,

    In general, all your computers should be looking at the internal IP address of whatever provides your DHCP range. For example, if your router is 192.168.1.1, then your computers should be looking at that address for DNS services, running ipconfig /all at a Command prompt should result in something like this:

       Host Name . . . . . . . . . . . . : Test-PC
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Mixed
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : Home

    Wireless LAN adapter Wireless Network Connection:

       Connection-specific DNS Suffix  . : Home
       Description . . . . . . . . . . . : Intel(R) Wireless WiFi Link 4965AGN
       Physical Address. . . . . . . . . : 00-13-E8-98-06-AD
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::a483:694e:a24d:7b67%9(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.120(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : 29 October 2008 03:08:01
       Lease Expires . . . . . . . . . . : 19 December 2144 00:10:38
       Default Gateway . . . . . . . . . : 192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DNS Servers . . . . . . . . . . . : 192.168.1.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    The items to note, are the last four entries.

    The usage of a 'host' file will achieve a workaround, but isn't really a longterm solution as it could well lead to problems when you come to do a Client restore, or you add another Client and forget the hosts settings!

    Colin





    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    • Marked as answer by GordonTWatts Tuesday, November 11, 2008 6:14 PM
    Tuesday, November 11, 2008 5:46 PM
    Moderator
  • Hi,
      Thanks for the answers & help!

    1) I do have a DSL modem, not a cable modem. And attached to the modem is a router. The NAT is provided by the router that sits in front of the modem (which I think also has a NAT in it - but has no wireless). Yes, if I want to access my WHS or similar from the outside world it will be a two step process. :-)

    2) You are exactly right about how the DNS lookup is proceeding on my network. If I type "nslookup bogus", I first get a timeout. I assume it is trying to find the machine name "bogus", and it fails. It then adds one of my default domain names on and does the lookup. I do have default domain names setup so I can save some typing to the common work machines I access -- so I guess this is my fault as it probably isn't a common setting.

    3) Yeah -- thanks for the reminder about the changing server IP address. I've used my router to fix it, so I know I'll have one hell of a time debugging things when that router gets replaced 1.5 years from now and I've forgotten what I've done...

    4) File copies, even on machines that don't have the hosts file changed, run at basically network speed. The hosts file modification seems to be only required to get the connector to work.

    5) The last four entries of my ipconfig/all listing are as expected (and follow the template above, thanks!). I'm pretty sure the problem is that the connector uses a different method of discovery than does just about everything else. It does a lookup of the server's name, finds it, and then assumes that it has the address. When it tries to contact it, it fails. Other stuff (like when the connector is being installed) seems to get the address perhaps by looking at broadcasting objects on the network and then ask its name. Combine this behavior with the very odd behaving DNS lookup (e.g. notachance.nytimes.com resolves to a real IP address) and you get this behavior.

      Thanks for the help. I understand a bit more about why this is happening.

      Cheers,
        Gordon.

    Gordon
    Tuesday, November 11, 2008 6:14 PM
  • GordonTWatts said:

    Combine this behavior with the very odd behaving DNS lookup (e.g. notachance.nytimes.com resolves to a real IP address) and you get this behavior.

    Are you by any chance using OpenDNS?

    As for finding the server, the connector install first attempts a lookup using UPnP, then after that succeeds it tries a name lookup (which will work it's way through DNS, NetBIOS, etc.).


    I'm not on the WHS team, I just post a lot. :)
    Tuesday, November 11, 2008 7:24 PM
    Moderator
  • Hi Ken,
      Thanks. As far as I know, I'm not on OpenDNS. I'm using whatever default DNS that Qwest provides. Is there a way to tell if they are using OpenDNS?

      Yeah -- since I'm an open network behind my NAT, the UPnP works just fine; then the name lookup fails...

      Cheers,
        Gordon.

    Gordon
    Tuesday, November 11, 2008 7:26 PM