none
Browser problems with Windows 10

    Question

  • Hi, I'm a noob so excuse me if I sound like a moron.  I have Windows 7 and have downloaded Windows 10 and am having problems with the browsers (Chrome & Microsoft Edge).

    They are both really slow- half the time they don't load the page saying there's a timing error and the rest of the time they initially don't load and then seems to refresh and successfully loads.

    Anyone else having the same? Any suggestions welcome...

    Cheers

    Aliens On Toast


    Tuesday, August 04, 2015 11:50 PM

Answers

All replies

  • For Edge you can ask over here.

    http://answers.microsoft.com/en-us/ie/forum/msedge?tab=Threads

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Wednesday, August 05, 2015 12:06 AM
    Moderator
  • Hi Aliens On Toast,

    I had a similar problem with Chrome on Windows 10.  After clicking the icon to open Chrome, it take a very long time, over ten minutes, to load.

    I found that was a problem with the Windows Update.  When the Windows Update stuck (you will see in Settings / Update & security, the update stop at some 0 or some percentage.  Once you delete everything in C:\Windows\SoftwareDistribution then restart the PC.  Chrome works again.  I found the same problem on two of my machines and this solution works on both machine.

    I suspect that the problem is related to the Windows Update service (wuauserv).  If you are able to restart the wuauserv, it might fix it.  However, in all my cases, when the update stuck, I am not able to restart the wuauserv.

    Hope this help

    Dennis

    Thursday, October 01, 2015 1:15 PM