locked
Error With Windows Home Server Website (.....homeserver.com) RRS feed

  • Question

  •    Hi All i get this error when i put http://.....homeserver.com

    Server Error in '/Home' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File --> <configuration> <system.web> <customErrors mode="Off"/> </system.web> </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File --> <configuration> <system.web> <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/> </system.web> </configuration>









    and i get this error when i put http://localhost on the server itself


     

    Server Error in '/Home' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Unrecognized configuration section 'connectionStrings'

    Source Error:

    Line 9: --> Line 10: <configuration> Line 11: <connectionStrings/> Line 12: <system.web> Line 13: <trace enabled="true" localOnly="false" pageOutput="false"/>

    Source File: c:\inetpub\home\web.config    Line: 11


    Version Information: Microsoft .NET Framework Version:1.1.4322.2407; ASP.NET Version:1.1.4322.2407



    can any 1 help plz
    Saturday, January 10, 2009 2:24 PM

Answers

  • If you installed teamspeak, did that update the .NET framework? It's possible that the incorrect version is set in IIS, to check, you can use IIS manager, and set the asp.net version in thesite properties.

    Colin


    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    • Marked as answer by snazy2000 Saturday, January 10, 2009 5:51 PM
    Saturday, January 10, 2009 5:28 PM
    Moderator
  • Thx So Much Mate It was set as 1.1 and i changed to 2 and it worked!!!!!
    • Marked as answer by snazy2000 Saturday, January 10, 2009 5:51 PM
    Saturday, January 10, 2009 5:51 PM

All replies

  • snazy2000 said:

       Hi All i get this error when i put http://.....homeserver.com

    Server Error in '/Home' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File --> <configuration> <system.web> <customErrors mode="Off"/> </system.web> </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File --> <configuration> <system.web> <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/> </system.web> </configuration>









    and i get this error when i put http://localhost on the server itself


     

    Server Error in '/Home' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Unrecognized configuration section 'connectionStrings'

    Source Error:

    Line 9: --> Line 10: <configuration> Line 11: <connectionStrings/> Line 12: <system.web> Line 13: <trace enabled="true" localOnly="false" pageOutput="false"/>

    Source File: c:\inetpub\home\web.config    Line: 11


    Version Information: Microsoft .NET Framework Version:1.1.4322.2407; ASP.NET Version:1.1.4322.2407



    can any 1 help plz



    Did it ever work?  What add-ins/apps do you have installed?  Did you get all of the MS updates for your server?  If so, how did you install them (through the Console or from the server desktop)?
    Saturday, January 10, 2009 4:44 PM
    Moderator
  • I only just installed windows home server because i had the 120 days trile and i bought a full verstion so i did reinstall and then this happend but i worked before i reinstalled it. I have done it all from the server itself (updates,installed programs) on the server atm i have Unrealircd and teamspeak server they both work still. i have not installed any addins at all
    Saturday, January 10, 2009 5:02 PM
  • If you installed teamspeak, did that update the .NET framework? It's possible that the incorrect version is set in IIS, to check, you can use IIS manager, and set the asp.net version in thesite properties.

    Colin


    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    • Marked as answer by snazy2000 Saturday, January 10, 2009 5:51 PM
    Saturday, January 10, 2009 5:28 PM
    Moderator
  • Thx So Much Mate It was set as 1.1 and i changed to 2 and it worked!!!!!
    • Marked as answer by snazy2000 Saturday, January 10, 2009 5:51 PM
    Saturday, January 10, 2009 5:51 PM